Bug 12327 - loop in prereq chain error
Summary: loop in prereq chain error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 17377 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-16 14:37 UTC by Richard Ferri
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-05 14:20:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Ferri 2000-06-16 14:37:21 UTC
I noticed that bash and libtermcap have a prereq loop, where
bash requires libtermcap, and libtermcap requires bash.  If I 
enter both of these packages on a single rpm command, I expect
rpm to handle the prereq loop.   When I enter:

   rpm -r /mnt -ih bash-1* libtermcap-2*

rpm correctly installs both, and resolves the prereq loop.  
However, when I enter:

   rpm -r /mnt -ih libtermcap-2* bash-1* 

rpm complains with:

   loop in prerequisite chain: libtermcap bash libtermcap


it seems to me that order of the arguments on the rpm command
line should not matter... I saw this problem on both the 6.1 and 
6.2 release of RH.  The workaround is to specify bash before 
libtermcap when installing a list of RPMs

Comment 1 Jeff Johnson 2000-07-31 15:42:21 UTC
You are correct that thae ordering of arguments should not matter.  I'll take a
look
in rpm-4.1,  and am marking the bug DEFFERED

Comment 2 Richard Ferri 2000-08-07 13:49:48 UTC
Please be aware that this bug is blocking LUI, the linux
utility for cluster install, from being able to do clean
remote RPM installs.  (LUI is a open source product released
under the GPL). LUI is able to install groups of nodes remotely
from a list of RPMs. When I specify all the rpms to install
remotely on a single command line, depending on the order the 
the rpms are specified in,
remote installation very often fails because of this bug. The
workaround, which is quite tedious, is to find which order the
rpm command likes, and specify the rpms in that order...

Comment 3 Jeff Johnson 2000-09-26 19:38:43 UTC
I just checked in a change to fix this problem in rpm-4.1. The change is headed
for rpm-4.0.1,
and (possibly) rpm-3.0.7, but it's gonna take a while to make sure the change is
OK before
releasing updates and errata and such. See lib/depends.[ch] if you need the
change sooner.

Comment 4 Jeff Johnson 2001-01-09 15:33:18 UTC
*** Bug 17377 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.