Bug 1232738 - Cache is not updated after user is deleted from ldap server
Summary: Cache is not updated after user is deleted from ldap server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.7
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lukas Slebodnik
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 12:09 UTC by Amith
Modified: 2020-05-02 18:06 UTC (History)
9 users (show)

Fixed In Version: sssd-1.12.4-47.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:46:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 3722 None None None 2020-05-02 18:06:01 UTC
Red Hat Product Errata RHBA-2015:1448 normal SHIPPED_LIVE sssd bug fix and enhancement update 2015-07-20 18:43:53 UTC

Description Amith 2015-06-17 12:09:03 UTC
Description of problem:
It is a regression of bz678410 and bz894381. Observed automation failures on all archs. Memory cache is not updated after user is deleted from ldap server.

Version-Release number of selected component (if applicable):
sssd-1.12.4-46.el6

How reproducible:
Always

Steps to Reproduce:
1. # id puser1
uid=2001(puser1) gid=2001 groups=2001

2. Delete puser1 from ldap server

3. # ssh -l puser1 localhost
puser1@localhost's password:
Permission denied, please try again.
puser1@localhost's password:

4. # id puser1
uid=2001(puser1) gid=2001 groups=2001   <== Should not work
  
Actual results:
ldbsearch shows that the user still exists in cache, even after the entry_negative_timeout.

Expected results:
User should also be removed from cache.

Additional info:

Comment 3 Jakub Hrozek 2015-06-17 17:45:21 UTC
No need to mark QE-reported bugs as private.

Thank you for reporting the bug, though.

Comment 4 Jakub Hrozek 2015-06-17 17:45:59 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2681

Comment 7 Jakub Hrozek 2015-06-22 09:03:19 UTC
* master: 9fc96a4a2b07b92585b02dba161ab1eb2dbdad98                           
* sssd-1-12: d0d6956c3748ba670448edd548b8edd37c5f5c1a

Comment 9 Amith 2015-06-23 05:21:09 UTC
Verified the bug on SSSD Version: sssd-1.12.4-47.el6

Successful execution of the automation suite verifies this bug. See the results from testcase: "bz678410-and-bz894381-id-command-shows-recently-deleted-users" on beaker job https://beaker.engineering.redhat.com/jobs/990732.

Comment 11 errata-xmlrpc 2015-07-22 06:46:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1448.html


Note You need to log in before you can comment on or make changes to this bug.