Bug 1232773 - Provide v4l-cx2341x-init.mpg that was in ivtv-firmware
Summary: Provide v4l-cx2341x-init.mpg that was in ivtv-firmware
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 22
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 12:59 UTC by Gilles J. Seguin
Modified: 2015-07-10 19:09 UTC (History)
3 users (show)

Fixed In Version: linux-firmware-20150521-53.git3161bfa4.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-10 19:09:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Gilles J. Seguin 2015-06-17 12:59:12 UTC
Description of problem:
file /lib/firmware/v4l-cx2341x-init.mpg from install of ivtv-firmware is not present in the move to linux-firmware package

Version-Release number of selected component (if applicable):
linux-firmware-20150521-52.git3161bfa4.fc22.noarch
v4l-utils-1.6.2-1.fc22.x86_64  
v4l2-utils removed, going back to v4l-utils package name
ivtv-firmware

How reproducible:


Steps to Reproduce:
1. after figuring out how to have v4l2-ctl application because of obsolete and removed problematic
2. activating the capture card ex.: v4l20ctl -i 2

3. it require the decoder firmware that is missing from the move to linux-firmware

4. activating the video out

5. it require the encoder firmware that is missing from the move to linux-firmware

Actual results:


Expected results:
needs firmware files
v4l-cx2341x-enc.fw
v4l-cx2341x-dec.fw
v4l-cx2341x-init.mpg

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=1211055#c9

Comment 1 Josh Boyer 2015-06-17 13:28:57 UTC
(In reply to Gilles J. Seguin from comment #0)
> Description of problem:
> file /lib/firmware/v4l-cx2341x-init.mpg from install of ivtv-firmware is not
> present in the move to linux-firmware package
> 
> Version-Release number of selected component (if applicable):
> linux-firmware-20150521-52.git3161bfa4.fc22.noarch
> v4l-utils-1.6.2-1.fc22.x86_64  
> v4l2-utils removed, going back to v4l-utils package name
> ivtv-firmware

What exactly do you mean by "v4l2-utils removed, going back to v4l-utils package name" ?

> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. after figuring out how to have v4l2-ctl application because of obsolete
> and removed problematic
> 2. activating the capture card ex.: v4l20ctl -i 2
> 
> 3. it require the decoder firmware that is missing from the move to
> linux-firmware
> 
> 4. activating the video out
> 
> 5. it require the encoder firmware that is missing from the move to
> linux-firmware
> 
> Actual results:
> 
> 
> Expected results:
> needs firmware files
> v4l-cx2341x-enc.fw
> v4l-cx2341x-dec.fw
> v4l-cx2341x-init.mpg

So confusing comments above aside, the net result is you need these 3 firmware files still for whatever you are doing?

Comment 2 Gilles J. Seguin 2015-06-20 06:59:37 UTC
(In reply to Josh Boyer from comment #1)
> (In reply to Gilles J. Seguin from comment #0)
> > Description of problem:
> > file /lib/firmware/v4l-cx2341x-init.mpg from install of ivtv-firmware is not
> > present in the move to linux-firmware package
> > 
> > Version-Release number of selected component (if applicable):
> > linux-firmware-20150521-52.git3161bfa4.fc22.noarch
> > v4l-utils-1.6.2-1.fc22.x86_64  
> > v4l2-utils removed, going back to v4l-utils package name
> > ivtv-firmware
> 
> What exactly do you mean by "v4l2-utils removed, going back to v4l-utils
> package name" ?
> 
> > How reproducible:
> > 
> > 
> > Steps to Reproduce:
> > 1. after figuring out how to have v4l2-ctl application because of obsolete
> > and removed problematic
> > 2. activating the capture card ex.: v4l20ctl -i 2
> > 
> > 3. it require the decoder firmware that is missing from the move to
> > linux-firmware
> > 
> > 4. activating the video out
> > 
> > 5. it require the encoder firmware that is missing from the move to
> > linux-firmware
> > 
> > Actual results:
> > 
> > 
> > Expected results:
> > needs firmware files
> > v4l-cx2341x-enc.fw
> > v4l-cx2341x-dec.fw
> > v4l-cx2341x-init.mpg
> 
> So confusing comments above aside, the net result is you need these 3
> firmware files still for whatever you are doing?

The net result is that the merge of the package
ivtv-firmware
into the package linux-firmware package
is a disaster.

what ever i am doing, that does not sound good... :-(

Then the reply is, somebody does not know what they are doing and
should reverse what they have done relative to ivtv-firmware

Some you provide some answer.
- why the package renaming ? (v4l2-utils to v4l-utils)

- why have removed the encoder firmware ?

- why have removed the decoder firmware ?

- Can you provide confirmation that thoses change have been tested ?

- why are you asking if we need the removed files ?

may be of some help,
see in f21 what the ivtv-firmware provides, i do not want to confuse you with to much informations.


Confused user

Comment 3 Josh Boyer 2015-06-23 15:16:46 UTC
Can you download the packages from https://jwboyer.fedorapeople.org/pub/bz1232773/noarch/ and see if they solve the firmware issue for you?

(I have no idea about v4l2-utils/v4l-utils, that has nothing to do with the firmware files so it is outside the scope of this bug.)

Comment 4 Gilles J. Seguin 2015-06-24 08:54:59 UTC
(In reply to Josh Boyer from comment #3)
> Can you download the packages from
> https://jwboyer.fedorapeople.org/pub/bz1232773/noarch/ and see if they solve
> the firmware issue for you?

Yes, it solves the the firmware issue

# rpm -Uvh linux-firmware-20150521-53.git3161bfa4.fc22.noarch.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:linux-firmware-20150521-53.git316################################# [ 50%]
Cleaning up / removing...
   2:linux-firmware-20150521-52.git316################################# [100%]

# rpm -ivf ivtv-firmware-20080701-28.noarch.rpm
Preparing packages...
ivtv-firmware-2:20080701-28.noarch

now, i can do
$ v4l2-ctl -i 2
Video input set to 2 (Composite 1: ok)
[gilles@danse ~]$ cat /dev/video0 > "test.mpg"

thanks for your time
bug should be closed

Comment 5 Josh Boyer 2015-06-24 13:24:50 UTC
(In reply to Gilles J. Seguin from comment #4)
> (In reply to Josh Boyer from comment #3)
> > Can you download the packages from
> > https://jwboyer.fedorapeople.org/pub/bz1232773/noarch/ and see if they solve
> > the firmware issue for you?
> 
> Yes, it solves the the firmware issue
> thanks for your time
> bug should be closed

Thank you for testing.  I've pushed the changes to the Fedora repositories.  The bug will be closed when the packages make it through the Fedora updates system.

Comment 6 Fedora Update System 2015-06-24 13:34:12 UTC
linux-firmware-20150521-53.git3161bfa4.fc22,ivtv-firmware-20080701-28 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/linux-firmware-20150521-53.git3161bfa4.fc22,ivtv-firmware-20080701-28

Comment 7 Fedora Update System 2015-06-25 08:20:46 UTC
Package linux-firmware-20150521-53.git3161bfa4.fc22, ivtv-firmware-20080701-28:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20150521-53.git3161bfa4.fc22 ivtv-firmware-20080701-28'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10692/linux-firmware-20150521-53.git3161bfa4.fc22,ivtv-firmware-20080701-28
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-07-10 19:09:36 UTC
linux-firmware-20150521-53.git3161bfa4.fc22, ivtv-firmware-20080701-28 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.