Bug 1232818 - Amarok has an unmet dependency on rhel7: audiocd-kio
Summary: Amarok has an unmet dependency on rhel7: audiocd-kio
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: amarok
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2015-06-17 14:35 UTC by J Chapin
Modified: 2016-01-03 01:27 UTC (History)
4 users (show)

Fixed In Version: amarok-2.8.0-19.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-03 01:27:20 UTC
Type: Bug


Attachments (Terms of Use)

Description J Chapin 2015-06-17 14:35:47 UTC
Description of problem:

Error: Package: amarok-2.8.0-8.el.x86_64 (epel)
Requires: audiocd-kio

Version-Release number of selected component (if applicable):
2.8.0-8.el7.x86_64


How reproducible:
100% of the time

Steps to Reproduce:
1.yum install amarok
2.view error

Actual results:

Error: Package: amarok-2.8.0-8.el.x86_64 (epel)
Requires: audiocd-kio


Expected results:

amarok installed


Additional info:

Comment 1 Rex Dieter 2015-06-17 14:54:45 UTC
See
https://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F
note:

"NOTE for RHN users
You need to also enable the 'optional' repository to use EPEL packages as they depend on packages in that repository. This can be done by enabling the RHEL optional subchannel for RHN-Classic. For certificate-based subscriptions see Red Hat Subscription Management Guide. For EPEL 7, in addition to the 'optional' repository (rhel-7-server-optional-rpms), you also need to enable the 'extras' repository (rhel-7-server-extras-rpms)."

Can you verify you have these extra repos enabled?

Comment 2 Rex Dieter 2015-06-17 14:55:25 UTC
or are using centos7 ?

Comment 3 J Chapin 2015-06-19 23:44:17 UTC
I have the following channels enabled:


epel/x86_64                                         Extra Packages for Enterprise Linux 7 - x86_64                                                     8,095
rhel-7-server-eus-rpms/7Server/x86_64               Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)                                 5,744
rhel-7-server-extras-rpms/x86_64                    Red Hat Enterprise Linux 7 Server - Extras (RPMs)                                                     52
rhel-7-server-optional-rpms/7Server/x86_64          Red Hat Enterprise Linux 7 Server - Optional (RPMs)                                                5,833
rhel-7-server-rpms/7Server/x86_64                   Red Hat Enterprise Linux 7 Server (RPMs)

Comment 4 J Chapin 2015-06-23 21:50:19 UTC
In case it helps any, here is some additional information:
$ sudo yum repolist
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
repo id                                                                      repo name                                                                                                                   status
epel/x86_64                                                                  Extra Packages for Enterprise Linux 7 - x86_64                                                                              8,107
google-chrome                                                                google-chrome                                                                                                                   3
rhel-7-server-eus-rpms/7Server/x86_64                                        Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)                                                          5,744
rhel-7-server-extras-rpms/x86_64                                             Red Hat Enterprise Linux 7 Server - Extras (RPMs)                                                                              52
rhel-7-server-optional-rpms/7Server/x86_64                                   Red Hat Enterprise Linux 7 Server - Optional (RPMs)                                                                         5,833
rhel-7-server-rpms/7Server/x86_64                                            Red Hat Enterprise Linux 7 Server (RPMs)                                                                                    7,046
rhel-ha-for-rhel-7-server-eus-rpms/7Server/x86_64                            Red Hat Enterprise Linux High Availability (for RHEL 7 Server) - Extended Update Support (RPMs)                               104
rhel-ha-for-rhel-7-server-rpms/7Server/x86_64                                Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (RPMs)                                                         128

Comment 5 J Chapin 2015-06-29 13:25:05 UTC
https://rhn.redhat.com/rhn/channels/software/Search.do does not appear to return any results for "audiocd-kio"

Comment 6 Rex Dieter 2015-06-29 16:13:29 UTC
OK, confirmed from others that dep is not satisifed properly in standard rhel7-server repos (I suspect it may be workstation only).

I'll work to remove it.

Comment 7 Fedora Update System 2015-12-17 19:08:54 UTC
amarok-2.8.0-19.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-44d2610abb

Comment 8 Fedora Update System 2015-12-18 14:20:15 UTC
amarok-2.8.0-19.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update amarok'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-44d2610abb

Comment 9 Fedora Update System 2016-01-03 01:25:57 UTC
amarok-2.8.0-19.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.