Bug 123283 - XFree86 to Xorg upgrade not perfect
XFree86 to Xorg upgrade not perfect
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-15 16:03 EDT by Nathan G. Grennan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file from after upgrade (3.10 KB, text/plain)
2004-05-19 13:32 EDT, Michael "Murph" Robbert
no flags Details
xorg.conf after fixing the problem as described (2.82 KB, text/plain)
2004-05-19 13:33 EDT, Michael "Murph" Robbert
no flags Details

  None (edit)
Description Nathan G. Grennan 2004-05-15 16:03:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040501 Galeon/1.3.14

Description of problem:
I upgraded a computer from FC1 to FC2 via DVD. After the upgrade had
finished it came up to gdm. I logged in and about 10 dialog windows
appeared in the top left corner complaining about Xorg errors. This
reminded me of having upgraded to Xorg duing I believe FC2T2. I looked
in /etc/X11 and found XF86Config from FC1 still there. It hadn't
changed at all. There was no xorg.conf. Also the X symlink was still
pointing to XFree86 instaed of Xorg. I transferred a working xorg.conf
from my FC2T3 machine and diffed it with the old XF86Config. Next I
edited xorg.conf for the proper video driver. Then I removed
XF86Config and remade the symlink properly.

Note I didn't see firstboot after the upgrade. I had uninstalled it
after using it with FC1. Naturally it wasn't installed during an
upgrade, and hence wasn't avaliable after the upgrade to be started on
boot. I am told this isn't related, but thought I would mention it anyway.

Version-Release number of selected component (if applicable):
anaconda-10.0-5

How reproducible:
Didn't try

Steps to Reproduce:
1. Install FC1
2. Upgrade to FC2
3. Login to X
    

Actual Results:  Xorg errors in dialog windows

Expected Results:  No Xorg errors in dialog windows

Additional info:
Comment 1 Michael "Murph" Robbert 2004-05-19 13:32:08 EDT
Created attachment 100351 [details]
XF86Config file from after upgrade
Comment 2 Michael "Murph" Robbert 2004-05-19 13:33:09 EDT
I got some similar results when upgrading from FC1 to FC2. My upgrade
was via local HTTP mirror. Upgrade went fine w/o errors. When I first
rebooted kudzu detected HW changes. A USB hub went missing(still
looking into this) and it detected a new keyboard(AT Translated Set 2
keyboard). No hardware was actually changed. I didn't think too much
of this and still am not sure if this was relevant or not, but then
once gdm had started I logged in and got a bunch of error windows that
read:
Error activating XKB configuration. It also told me to send the
following info:
============================================================
[mrobbert@poincare mrobbert]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
[mrobbert@poincare mrobbert]$ gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
============================================================

When I found this bug report I looked in /etc/X11 and found that I
didn't have an xorg.conf file either. I tried copying my XF86Config
file to xorg.conf and restarting X, but that didn't help. I then moved
the xorg.conf and XF86config files out of the way, shut down X, and
ran system-config-display. I configured the correct resolution and
quit out of that. It generated an xorg.conf and now the problem is
gone. I am attaching my XF86Config file from after the upgrade as well
as the new xorg.conf file in case you want to see them.
Comment 3 Michael "Murph" Robbert 2004-05-19 13:33:52 EDT
Created attachment 100352 [details]
xorg.conf after fixing the problem as described
Comment 4 Jonathan Smith 2004-05-30 11:41:54 EDT
I am experiencing a similar problem. Any non-QT GUI fails, to include 
Mozilla and Firefox. The upgrade from FC1 -> FC2 effectively isolated 
me from the Internet until I discovered a QT-based version of Opera 
for Linux.

Whenever I run setup, then select X configuration, 
configure-system-display goes into a black void; the only way to 
recover is a power reset. 

I have a file /etc/X11/xorg.conf and continue to have a problem. 
Commenting out load dri makes no diff.

Since others report an absence of such problems after upgrading, and 
I specifically mean choosing upgrade at the time of installation from 
CD, I suspect that the issue may be related to a failed ddc probe of 
my KDS X-7e monitor.

My original report of this bug was made a duplicate of a "resolved" 
"harmless" issue, i.e., the XKB error. This is originally what 
happened and even after I resolved the XKB error I had the same 
critical problem, i.e., an inability to run any GUI other than one 
that is QT-based.

I would appreciate any advice on how to restore functionality after 
this crippling upgrade.
Comment 5 Wil Cooley 2004-06-07 16:09:55 EDT
Commenting out the 'Option "XkbRules" "xfree86"' line causes the XKB
error to go away for me.

--- XF86Config  2004-06-05 22:29:26.000000000 -0700
+++ xorg.conf   2004-06-07 13:04:23.556368584 -0700
@@ -58,7 +58,7 @@
        Option  "XkbOptions"    "ctrl:nocaps"
        Identifier  "Keyboard0"
        Driver      "keyboard"
-       Option      "XkbRules" "xfree86"
+#      Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
 EndSection
Comment 6 Mike A. Harris 2004-06-08 14:40:51 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:03:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.