Bug 1232938 - rhel-osp-director: HA deployment - openstack-nova-novncproxy fails to start.
Summary: rhel-osp-director: HA deployment - openstack-nova-novncproxy fails to start.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Giulio Fidente
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 21:02 UTC by Alexander Chuzhoy
Modified: 2015-08-05 13:54 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-11.el7ost
Doc Type: Bug Fix
Doc Text:
The novncproxy service failed to start due to socket binding conflicts. This meant novncproxy service would not be available. This fix configures the novncproxy serviceto bind only on the controller internal_api address. The novncproxy now starts successfully.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
controller1 logs (8.49 MB, application/x-gzip)
2015-06-17 21:28 UTC, Alexander Chuzhoy
no flags Details
controller2 logs (7.97 MB, application/x-gzip)
2015-06-17 21:28 UTC, Alexander Chuzhoy
no flags Details
controller3 logs (8.11 MB, application/x-gzip)
2015-06-17 21:29 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 183630 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-06-17 21:02:35 UTC
rhel-osp-director: HA deployment - openstack-nova-novncproxy fails to start.

Environment:
novnc-0.5.1-2.el7ost.noarch
openstack-nova-novncproxy-2015.1.0-12.el7ost.noarch
instack-undercloud-2.1.2-1.el7ost.noarch

Steps to reproduce:

1. Deploy HA overcloud.
2. Login to any controller and run "pcs status"

Result:

Failed actions:
    openstack-ceilometer-notification_start_0 on overcloud-controller-2 'not running' (7): call=232, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:39 2015', queued=2001ms, exec=7ms
    openstack-nova-novncproxy_start_0 on overcloud-controller-2 'not running' (7): call=238, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:39 2015', queued=2001ms, exec=2ms
    neutron-server_start_0 on overcloud-controller-2 'not running' (7): call=264, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:51 2015', queued=2001ms, exec=3ms
    openstack-ceilometer-central_start_0 on overcloud-controller-2 'not running' (7): call=265, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:49 2015', queued=2000ms, exec=3ms
    openstack-heat-api-cloudwatch_monitor_60000 on overcloud-controller-0 'not running' (7): call=176, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:27 2015', queued=0ms, exec=3ms
    openstack-nova-novncproxy_start_0 on overcloud-controller-0 'not running' (7): call=289, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:01:10 2015', queued=2001ms, exec=7ms
    openstack-ceilometer-notification_start_0 on overcloud-controller-1 'not running' (7): call=237, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:38 2015', queued=2001ms, exec=4ms
    openstack-nova-novncproxy_start_0 on overcloud-controller-1 'not running' (7): call=243, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:39 2015', queued=2001ms, exec=4ms
    openstack-ceilometer-central_start_0 on overcloud-controller-1 'not running' (7): call=270, status=complete, exit-reason='none', last-rc-change='Wed Jun 17 16:00:48 2015', queued=2000ms, exec=7ms



Expected result:
The openstack-nova-novncproxy shouldn't be in the list of failed actions.

Comment 3 Alexander Chuzhoy 2015-06-17 21:28:02 UTC
Created attachment 1040086 [details]
controller1 logs

Comment 4 Alexander Chuzhoy 2015-06-17 21:28:32 UTC
Created attachment 1040087 [details]
controller2 logs

Comment 5 Alexander Chuzhoy 2015-06-17 21:29:03 UTC
Created attachment 1040089 [details]
controller3 logs

Comment 6 Giulio Fidente 2015-06-18 08:01:20 UTC
WebSocket proxy attempts to listen on 0.0.0.0, will work on a fix.

Comment 9 Omri Hochman 2015-07-10 20:15:46 UTC
verified : openstack-tripleo-heat-templates-0.8.6-34.el7ost.noarch

Comment 11 errata-xmlrpc 2015-08-05 13:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.