Bug 1232943 - devtest_testenv.sh doesn't support --baremetal-bridge-names or --vlan-trunk-ids parameters
Summary: devtest_testenv.sh doesn't support --baremetal-bridge-names or --vlan-trunk-i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 21:22 UTC by Dan Sneddon
Modified: 2015-08-05 13:54 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-0.0.7-0.1.1664e566.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-06-17 21:22:13 UTC
Description of problem:
I am trying to test network isolation in virt, but I am finding that the version of devtest_testenv.sh in instack does not support the right parameters. In the upstream version we can pass multiple baremetal bridge names and vlan IDs and the VMs would have multiple bridges connected to simulate 3 network adapters, and 5 VLANs across the bridges.

Version-Release number of selected component (if applicable):
instack.noarch                   0.0.7-1.el7ost           @rhelosp-7.0-director-poodle
instack-undercloud.noarch        2.1.2-1.el7ost           @rhelosp-7.0-director-poodle


How reproducible:
100%

Steps to Reproduce:
1. Before running instack-virt-setup, run
2. export TESTENV_ARGS="--baremetal-bridge-names 'brbm brbm1 brbm2' --vlan-trunk-ids='10 20 30 40 50'" 
3. Then run instack-virt-setup

Actual results:
+ eval 'sudo -H -E tripleo devtest_testenv.sh --baremetal-bridge-names="brbm brbm2 brbm3" --vlan-trunk-ids="10 20 30 40 50" instackenv.json'
++ sudo -H -E tripleo devtest_testenv.sh '--baremetal-bridge-names=brbm brbm2 brbm3' '--vlan-trunk-ids=10 20 30 40 50' instackenv.json
devtest_testenv.sh: unrecognized option '--baremetal-bridge-names=brbm brbm2 brbm3'
devtest_testenv.sh: unrecognized option '--vlan-trunk-ids=10 20 30 40 50'


Expected results:
The test environment should be set up with VMs with 3 NICs and 5 VLANs on the baremetal bridges.

Additional info:
This works upstream, so I think we just need a newer version of devtest_testenv.sh downstream.

Comment 2 Dan Sneddon 2015-06-17 21:25:11 UTC
This is preventing testing in virtual environments of the network configuration code. We can test on bare metal, but it would be really great if we could get broader test coverage on the network isolation code.

Comment 5 Marios Andreou 2015-06-24 13:09:31 UTC
FYI since I came across this today, I had to get openstack-tripleo v0.0.7 (I had 0.0.6) to get a clean run for instack-virt-setup (after setting TESTENV_ARGS as above).


---> Package openstack-tripleo.noarch 0:0.0.7-0.1.1664e566.el7ost will be an update

Comment 6 Marius Cornea 2015-07-22 15:03:00 UTC
export TESTENV_ARGS="--baremetal-bridge-names 'brbm brbm1 brbm2' --vlan-trunk-ids='10 20 30 40 50'" 

instack-virt-setup

After setup is complete:

[stack@lenovo-x3850-02 ~]$ sudo ovs-vsctl show
3101f6c7-3a32-485b-929b-e010173a0798
    Bridge brbm
        Port "vnet1"
            tag: 0
            trunks: [0, 10, 20, 30, 40, 50]
            Interface "vnet1"
        Port brbm
            Interface brbm
                type: internal
    Bridge "brbm2"
        Port "brbm2"
            Interface "brbm2"
                type: internal
    Bridge "brbm1"
        Port "brbm1"
            Interface "brbm1"
                type: internal
    ovs_version: "2.3.1-git3282e51"

Comment 8 errata-xmlrpc 2015-08-05 13:54:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.