Bug 1232976 - Should include 'environments' directory in openstack-tripleo-heat-templates RPM
Summary: Should include 'environments' directory in openstack-tripleo-heat-templates RPM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: Mike Burns
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-18 00:37 UTC by Dan Sneddon
Modified: 2015-08-05 13:54 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-10.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-06-18 00:37:49 UTC
Description of problem:
The openstack-tripleo-heat-templates RPM does not include the 'environments' directory. This directory includes sample files that show how to configure isolated networking.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates  0.8.6-9.el7ost

How reproducible:
100%

Steps to Reproduce:
1. install openstack-tripleo-heat-templates RPM
2.
3.

Actual results:
'environments' directory not included

Expected results:
'environments' directory should be included

Additional info:
This will simplify the instructions for configuring network isolation, since the user can copy the sample configuration templates and edit them to get started, instead of cut-and-pasting from the documentation.

Comment 5 Amit Ugol 2015-07-06 11:25:23 UTC
Tested with openstack-tripleo-heat-templates-0.8.6-23.el7ost.noarch
$ ls -1 /usr/share/openstack-tripleo-heat-templates/environments
cinder-netapp-config.yaml
net-bond-with-vlans.yaml
net-single-nic-with-vlans.yaml
network-isolation.yaml
overcloud-steps.yaml
puppet-ceph-devel.yaml
puppet-pacemaker.yaml
puppet-tenant-vlan.yaml
README.md

Comment 7 errata-xmlrpc 2015-08-05 13:54:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.