Bug 123303 - The source rpm doesn't build
The source rpm doesn't build
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: doxygen (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-16 12:58 EDT by Zenon Panoussis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-17 10:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The last part of a build trace (12.15 KB, text/plain)
2004-05-16 13:06 EDT, Zenon Panoussis
no flags Details
rpm -qa |sort (24.50 KB, text/plain)
2004-05-17 07:53 EDT, Zenon Panoussis
no flags Details

  None (edit)
Description Zenon Panoussis 2004-05-16 12:58:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040126

Description of problem:
The build process hangs at building docs, startpage. The cause appears
to be incorrect paths to Fontmap (see attachment).

Version-Release number of selected component (if applicable):
doxygen-1.3.5-0.RHEL3.1.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb doxygen-1.3.5-0.RHEL3.1.src.rpm
2. wait a few minutes


Additional info:
Comment 1 Zenon Panoussis 2004-05-16 13:06:44 EDT
Created attachment 100257 [details]
The last part of a build trace 

I was too quick about that Fontmap conclusion, the right Fontmap is actually
found on lines 61 and 70 of the attachement. Whatever the real problem is, I
can' figure it.
Comment 2 Ngo Than 2004-05-17 04:23:58 EDT
it's strange! it can be built without this problem in our build
enviroment.

it looks like that some packages, which are needed für building of
doxygen, are missing on your running machine.

could you please check if the following packages tetex-dvips,
tetex-latex, ghostscript have been installed on your machine.

if not, please install them and start rebuild again. thanks
Comment 3 Zenon Panoussis 2004-05-17 07:53:12 EDT
Created attachment 100269 [details]
rpm -qa |sort
Comment 4 Zenon Panoussis 2004-05-17 07:55:58 EDT
A you can see I'm building on a full AS install but, because of bug
#110752, double-checking those three was the first thing I did. 

The only packages missing on the build machine are certain RHEL
BuildReqs that are not part of the RHEL distro (e.g. bonobo, gal,
gtkhtml, nasm etc) and a couple of RHEL packages that BuildReq such
packages (e.g. gimp-perl, depends on Gtk-Perl, which is not part of
RHEL). 

What non-RHEL packages does your build environment include, if any? 
Comment 5 Ngo Than 2004-05-17 08:51:52 EDT
i have taken a look in your attachment, it looks sane. It's strange
why it does not rebuild on your machine.

Could you please send me the output of 'rpmbuild --rebuild
doxygen-1.3.5-0.RHEL3.1.src.rpm'. thanks
Comment 6 Zenon Panoussis 2004-05-17 09:44:30 EDT
Well, no. There's a new problem namely: now it builds OK, exit 0. The
only thing that happened with that machine between yesterday and today
is a reboot, so we can assume some linking issue somewhere, impossible
to find. I suggest a resolution of CLOSED MAGIC. 
Comment 7 Ngo Than 2004-05-17 10:05:23 EDT
ok, i close it now as notabug. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.