Bug 1233090 - rhel-osp-director: should support openstack log collector /sos
Summary: rhel-osp-director: should support openstack log collector /sos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ga
: Director
Assignee: Brad P. Crochet
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-18 08:29 UTC by Ofer Blaut
Modified: 2015-08-05 13:54 UTC (History)
8 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-26.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237099 None None None Never
Gerrithub.io 237100 None None None Never
Gerrithub.io 237441 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ofer Blaut 2015-06-18 08:29:16 UTC
Description of problem:

rhel-osp-director: should support openstack log collector /sos

[root@overcloud-controller-1 heat-admin]#  rpm -qa | grep rhos-log-collector
[root@overcloud-controller-1 heat-admin]# 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.rpm -qa | grep rhos-log-collector
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Lee Yarwood 2015-06-18 09:47:13 UTC
(In reply to Ofer Blaut from comment #0)
> Description of problem:
> 
> rhel-osp-director: should support openstack log collector /sos
> 
> [root@overcloud-controller-1 heat-admin]#  rpm -qa | grep rhos-log-collector
> [root@overcloud-controller-1 heat-admin]# 

We are no longer shipping the rhos-log-collector tool provided by the sos-plugins-openstack package in OSP 7. However both the under and over cloud should have sos installed. I'm rebuilding my director env now but please feel free to confirm if this is present in both clouds in the meantime!

Comment 2 Lee Yarwood 2015-06-18 16:46:24 UTC
(In reply to Lee Yarwood from comment #1)
> (In reply to Ofer Blaut from comment #0)
> > Description of problem:
> > 
> > rhel-osp-director: should support openstack log collector /sos
> > 
> > [root@overcloud-controller-1 heat-admin]#  rpm -qa | grep rhos-log-collector
> > [root@overcloud-controller-1 heat-admin]# 
> 
> We are no longer shipping the rhos-log-collector tool provided by the
> sos-plugins-openstack package in OSP 7. However both the under and over
> cloud should have sos installed. I'm rebuilding my director env now but
> please feel free to confirm if this is present in both clouds in the
> meantime!

I've just confirmed that sos is missing for the undercloud and overcloud in the latest puddle. Odd given that the docs were already listing it and I'm sure it's there upstream. 

I assume we will need seperate instack-undercloud and overcloud-full BZs for this?

Comment 3 Mike Burns 2015-06-18 18:08:56 UTC
A single bug is sufficient, I think.  For the undercloud, we could auto-install the package by having a dependency relationship or we could document it.

For the overcloud, it's likely a DIB element

Comment 4 Lee Yarwood 2015-06-19 15:37:53 UTC
(In reply to Mike Burns from comment #3)
> A single bug is sufficient, I think.  For the undercloud, we could
> auto-install the package by having a dependency relationship or we could
> document it.
> 
> For the overcloud, it's likely a DIB element

Thanks Mike, 

I've submitted the following .spec change for python-rdomanager-oscplugin so that sos is installed before we run `openstack undercloud install` :

Add sos as a required package.
https://review.gerrithub.io/237100

Thankfully we already have an element for `sosreport`[1] that we can reuse for the overcloud. I've submitted the following to have this used when building images :

Add sosreport element to overcloud images.
https://review.gerrithub.io/237099

I assume we use the same process when building images?

Lee

[1] https://github.com/rdo-management/tripleo-image-elements/tree/mgt-master/elements/sosreport

Comment 5 James Slagle 2015-06-19 17:16:02 UTC
need to make same image build patch to instack-build-images as well while we're still trying to merge the unified cli for building images

Comment 6 Mike Burns 2015-06-23 12:15:23 UTC
Patches are not yet merged, moving to ON_DEV.  Also, the instack-undercloud version of this is not yet fixed.

Comment 7 Lee Yarwood 2015-06-24 08:14:32 UTC
(In reply to Mike Burns from comment #6)
> Patches are not yet merged, moving to ON_DEV.  Also, the instack-undercloud
> version of this is not yet fixed.

Thanks Mike, I've pushed the following instack-build-images patch for this :

Add the sosreport element when building images. 
https://review.gerrithub.io/#/c/237441/

Comment 9 Ofer Blaut 2015-07-08 13:49:35 UTC
sos is installed on undercloud  - instack-undercloud-2.1.2-11.el7ost.noarch


[stack@puma33 ~]$ rpm -qa | grep sos
sos-3.2-15.el7_1.1.noarch


but not on over cloud nodes
[heat-admin@overcloud-compute-0 ~]$  sudo rpm -qa | grep sos
[heat-admin@overcloud-controller-1 ~]$ rpm -qa | grep sos

Comment 10 Ofer Blaut 2015-07-08 13:52:02 UTC
python-rdomanager-oscplugin-0.0.8-18.el7ost.noarch


ca

Comment 12 Ofer Blaut 2015-07-16 13:03:32 UTC
[root@overcloud-controller-2 heat-admin]# rpm -qa | grep sos
sos-3.2-16.el7ost.2.noarch

[heat-admin@overcloud-compute-0 ~]$ rpm -qa | grep sos
sos-3.2-16.el7ost.2.noarch


python-rdomanager-oscplugin-0.0.8-32.el7ost.noarch

Comment 14 errata-xmlrpc 2015-08-05 13:54:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.