Bug 1233139 - Null pointer dreference in dht_migrate_complete_check_task
Summary: Null pointer dreference in dht_migrate_complete_check_task
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1233158 1233517
TreeView+ depends on / blocked
 
Reported: 2015-06-18 10:02 UTC by Raghavendra G
Modified: 2016-06-16 13:13 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1233158 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:13:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra G 2015-06-18 10:02:20 UTC
Description of problem:

        if (gf_uuid_compare (stbuf.ia_gfid, tmp_loc.inode->gfid)) {
		gf_msg (this->name, GF_LOG_ERROR, 0,
                        DHT_MSG_GFID_MISMATCH,
		        "%s: gfid different on the target file on %s",
                        tmp_loc.path, dst_node->name);
                ret = -1;
		local->op_errno = EIO;
                goto out;
	}

        dst_node = dht_subvol_get_cached (this, tmp_loc.inode);

dst_node->name is accessed in the log, but dst_node is assigned later on.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-18 10:57:18 UTC
REVIEW: http://review.gluster.org/11313 (cluster/dht: Fix Null pointer dereference while logging) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Anand Avati 2015-06-19 05:16:24 UTC
COMMIT: http://review.gluster.org/11313 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit dda7608736857ac5fb539f2c04a1499999c984ed
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Thu Jun 18 16:23:50 2015 +0530

    cluster/dht: Fix Null pointer dereference while logging
    
    Change-Id: I1ea358b83267b0bcdf654ce18fe881fd4a6bf08d
    BUG: 1233139
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/11313
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Anand Avati 2015-06-23 07:19:47 UTC
REVIEW: http://review.gluster.org/11363 (cluster/dht: remove check for gfid change during mirgation-complete task) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Niels de Vos 2016-06-16 13:13:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.