Bug 123319 - LTC8605-laus package prevents clean install of rhel3 u2 errata
LTC8605-laus package prevents clean install of rhel3 u2 errata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: up2date-rhel3-u3
  Show dependency treegraph
 
Reported: 2004-05-16 21:45 EDT by Bill Goodrich
Modified: 2007-11-30 17:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 14:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shows laus issues (2.92 KB, text/plain)
2004-05-25 15:54 EDT, Brock Organ
no flags Details

  None (edit)
Description Bill Goodrich 2004-05-16 21:45:39 EDT
The following has be reported by IBM LTC:  
laus package prevents clean install of rhel3 u2 errata
Hardware Environment: z900

Software Environment: rhel3 u2 


Steps to Reproduce:
1. up2date -u 
2.
3.

Actual Results:
Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy
dependencies:
Name                                    Version        Release
--------------------------------------------------------------
laus-libs                               0.1            56RHEL3
laus-libs                               0.1            56RHEL3

file /lib/liblaus.so.1.0.0 from install of laus-libs-0.1-56RHEL3
conflicts with
file from package laus-0.1-54RHEL3
file /lib/liblaussrv.so.0.0.0 from install of laus-libs-0.1-56RHEL3
conflicts
with file from package laus-0.1-54RHEL3

Expected Results:
Clean install. 

Additional Information:
Tried to do rpm -F for laus package.

rpm -Fv laus-0.1-56RHEL3.s390x.rpm
warning: laus-0.1-56RHEL3.s390x.rpm: V3 DSA signature: NOKEY, key ID
db42a60e
error: Failed dependencies:
        liblaus.so.1()(64bit) is needed by laus-0.1-56RHEL3
        liblaussrv.so.0()(64bit) is needed by laus-0.1-56RHEL3
        liblaus.so.1()(64bit) is needed by (installed) pam-0.75-54
    Suggested resolutions:
        laus-0.1-54RHEL3.s390x.rpm
Comment 1 Suzanne Hillman 2004-05-18 10:47:39 EDT
This is a _different_ problem than in bug #123317? Is this a clean
install of U2? If so, how? It looks like using NFS or FTP, not the
ISOs, but I wanted to be sure.
Comment 2 Brock Organ 2004-05-18 15:07:32 EDT
I've confirmed this behavior in our internal RHNQA environment using a
fresh U2 install:

> # up2date --showall | grep laus
> laus-0.1-56RHEL3.s390x
> laus-devel-0.1-56RHEL3.s390x
> laus-libs-0.1-56RHEL3.s390
> laus-libs-0.1-56RHEL3.s390x
> # 

The laus-0.1-56RHEL3.s390 package is missing from the above list;
additionally, the downloads do not pull down the .s390 packages, just
the s390x packages:

> .qa.[root@byron root]# up2date -u laus laus-libs laus-devel
> <...>
> Name                                    Version        Rel
> ----------------------------------------------------------
> laus         0.1   56RHEL3   s390x
> laus-devel   0.1   56RHEL3   s390x
> laus-libs    0.1   56RHEL3   s390x
>
> <...>
> # ls /var/spool/up2date/laus-*rpm
> laus-0.1-56RHEL3.s390x.rpm  
> laus-devel-0.1-56RHEL3.s390x.rpm  
> laus-libs-0.1-56RHEL3.s390x.rpm
> # 

So there seem to be two issues in this report:

1) missing from the channel is laus-0.1-56RHEL3.s390
2) the downloads do not get the .s390 packages, just the s390x ones 
Comment 3 Bill Goodrich 2004-05-18 18:09:59 EDT
This is a clean install of U2 using a unified tree created from the 
ISOs. It was an NFS install. 

I was able to get past this by installing both variants of the laus-
libs rpms. I had to pull the s390 rpm from RHN manually. I used rpm -
U and had to specify --replacefiles to get past file conflicts with a 
prior version of laus. I was then able to complete the update. 

This workaround is not a solution. 

This is similar to 123317 but they are separate problems. The source 
of the problems is the laus-libs rpms. 
Comment 4 Brock Organ 2004-05-25 15:54:18 EDT
Created attachment 100563 [details]
shows laus issues

The problem is still present in the live RHN channel, attaching a text file
that shows the current state ...
Comment 5 Adrian Likins 2004-05-27 18:49:45 EDT
re comment #4,

what the problem in the channel? or the .s390 laus updates
missing? 
Comment 6 Bill Goodrich 2004-06-16 09:46:25 EDT
I did a build of RHEL3 U2 GA. I registered with RHN and did an up2date
-u up2date. I then tried to do an up2date -u to pull the errata from
the channel. Here is the resuults. Note: I included an display of the
up2date rpm level. 


RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy
dependencies:
Name                                    Version        Release
--------------------------------------------------------------
laus-libs                               0.1            56RHEL3
laus-libs                               0.1            56RHEL3

file /lib/liblaus.so.1.0.0 from install of laus-libs-0.1-56RHEL3
conflicts with file from package laus-0.1-54RHEL3
file /lib/liblaussrv.so.0.0.0 from install of laus-libs-0.1-56RHEL3
conflicts with file from package laus-0.1-54RHEL3

[root@redhat4 root]# rpm -q up2date
up2date-4.2.16-1
Comment 7 Brock Organ 2004-06-16 14:22:11 EDT
The problem is still present in the live RHN channel ... using
internal test systems I am seeing the same behavior as in Bill's last
comment (with the live channel) ...
Comment 10 Bill Goodrich 2004-08-04 14:26:59 EDT
Updated up2date to: up2date-4.2.33-1

This did not help.

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy
dependencies:
Name                                    Version        Release
--------------------------------------------------------------
laus-libs                               0.1            56RHEL3
laus-libs                               0.1            56RHEL3

file /lib/liblaus.so.1.0.0 from install of laus-libs-0.1-56RHEL3
conflicts with file from package laus-0.1-54RHEL3
file /lib/liblaussrv.so.0.0.0 from install of laus-libs-0.1-56RHEL3
conflicts with file from package laus-0.1-54RHEL3

Same as before.                                                      
                                                                     
                                                                     
                                                                     
                                                                     
                                                                     
                                                                     
      
Comment 11 Jay Turner 2004-08-09 13:14:19 EDT
Adrian, I'm seeing this on x86_64 with up2date-4.2.33-1 as well as
up2date-4.2.34-1.  Appears that something doesn't realize there's a
new laus available as well which resolves these conflicts.
Comment 12 James Laska 2004-08-19 14:16:33 EDT
still busted on ppc (RHEL3-U2 -> up2date -fu) using up2date-4.2.33-1.ppc

file /etc/init.d/audit from install of laus-0.1-62RHEL3 conflicts with
file from package laus-0.1-56RHEL3

installed prior to update:
  laus-0.1-56RHEL3.ppc
  laus-0.1-56RHEL3.ppc64
  laus-devel-0.1-56RHEL3.ppc
  laus-libs-0.1-56RHEL3.ppc
  laus-libs-0.1-56RHEL3.ppc64

attempting to update:
  laus                                    0.1            62RHEL3     
     ppc
  laus-devel                              0.1            62RHEL3     
     ppc
  laus-libs                               0.1            62RHEL3     
     ppc
  laus-libs                               0.1            62RHEL3     
     ppc64

Looks like RHN is missing the laus.ppc64 package.
Comment 14 Jay Turner 2004-08-19 14:56:49 EDT
Looks like we might need to add laus.pp64.  I'll look at it here shortly.
Comment 15 Jay Turner 2004-08-19 22:05:47 EDT
Crap.  So, RHEA-2004:200-26 (the laus errata which went out right
after U2) shipped with laus.ppc and laus.ppc64 (the only arch which
shipped a multi-lib laus.)  Net result is the above brokeness, and I
think the best solution is going to be to just continue to ship
laus.ppc64.  Means that we need to update the U3 errata, as well as
get the package pulled into the U3 builds.
Comment 20 Bob Johnson 2004-09-01 11:15:37 EDT
this fix is across all arches, please test with U3 gold once it goes live.
Comment 21 Bill Goodrich 2004-09-20 14:21:53 EDT
This problem does not occur on RHEL3 U3

Note You need to log in before you can comment on or make changes to this bug.