Bug 1233199 - Always enable config drive in Nova for the undercloud
Summary: Always enable config drive in Nova for the undercloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-18 12:20 UTC by Lucas Alvares Gomes
Modified: 2015-08-05 13:54 UTC (History)
4 users (show)

Fixed In Version: instack-undercloud-2.1.2-4.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 236548 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Lucas Alvares Gomes 2015-06-18 12:20:55 UTC
Description of problem:
We dependent on information being passed to the instances via the config driver.

We should enable the config drive in Nova for all the instances in the undercloud.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

This can can be done by editing the nova.conf:

[DEFAULT]
...
force_config_drive=True

Comment 4 James Slagle 2015-06-23 14:14:30 UTC
merged: https://code.engineering.redhat.com/gerrit/51377
built: instack-undercloud-2.1.2-4.el7ost

Comment 6 nlevinki 2015-07-19 12:38:57 UTC
Verified on 17.1 build
# Set to "always" to force injection to take place on a config
# drive. NOTE: The "always" will be deprecated in the Liberty
# release cycle. (string value)
#force_config_drive=<None>
force_config_drive=True

Comment 8 errata-xmlrpc 2015-08-05 13:54:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.