Bug 123322 - Error activating XKB configuration.
Error activating XKB configuration.
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-16 23:49 EDT by Damien
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damien 2004-05-16 23:49:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When logging into X (gnome) I get a dialog with the following
information.  Despite this I see no noticable functional difference
from before the the message started happening.

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb



Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Boot up.
2. Log into gnome.
3.
    

Actual Results:  Get above described dialog.

Expected Results:  Normal startup, no dialog.

Additional info:

As requested by the dialog:

[damien@congo damien]$ xprop -root | grep XKB && echo "----" &&
gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
----
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
[damien@congo damien]$
Comment 1 Anthony Clark 2004-05-17 15:24:43 EDT
same here, always on boot up / after log into gdm/gnome:

[us@gir us]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "microsoft", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "microsoft", "us", "", ""

[us@gir us]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 2 Anthony Clark 2004-05-17 15:31:59 EDT
Also happens if I attempt to change the keyboard layout or layout
options indie the Keyboard Preferences app
(Applications->Preferences->Keyboard)

Nothing shows up in /var/log/Xorg.0.log, /var/log/messages or dmesg
Comment 3 Mike A. Harris 2004-05-17 15:35:06 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:03:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.