Bug 1233283 - Ceilometer mongo url not set on all controllers in HA setup
Summary: Ceilometer mongo url not set on all controllers in HA setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Giulio Fidente
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-18 15:17 UTC by Marius Cornea
Modified: 2015-08-05 13:54 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-12.el7ost
Doc Type: Bug Fix
Doc Text:
The mongodb node list would only build correctly on one Controller node, which meant all other Controller nodes had Ceilometer configured with an empty list of mongodb nodes. This fix corrects the mongodb node list on all Controller nodes. Ceilometer has a properly populated list of mongodb nodes.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 193179 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marius Cornea 2015-06-18 15:17:17 UTC
Description of problem:
Ceilometer mongo url not set on all controllers in a 3 controller node deployment.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-9.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with 3 controllers and 2 computes 
2. Check ceilometer.conf on the controllers for the mongodb connection configuration
3.

Actual results:
[heat-admin@overcloud-controller-0 ~]$ sudo grep mongo /etc/ceilometer/ceilometer.conf
connection=mongodb://192.0.2.17:27017,192.0.2.16:27017,192.0.2.18:27017/ceilometer?replicaSet=tripleo

[heat-admin@overcloud-controller-1 ~]$ sudo grep mongo /etc/ceilometer/ceilometer.conf
connection=mongodb:///ceilometer?replicaSet=

[heat-admin@overcloud-controller-2 ~]$ sudo grep mongo /etc/ceilometer/ceilometer.conf
connection=mongodb:///ceilometer?replicaSet=


Expected results:
The correct mongodb connection gets configured on all 3 controllers.

Additional info:

Comment 3 Marios Andreou 2015-06-19 11:44:01 UTC
upstream fix for this @ https://review.openstack.org/#/c/193179/ by gfidente. I tested it locally with control-scale 2 (cloned downstream tht and cherrypicked the template over, rebuilt roles) and Overcloud Deployed OK


 and [root@overcloud-controller-1 heat-admin]# sudo cat /etc/ceilometer/ceilometer.conf | grep mongo connection=mongodb://192.0.2.16:27017,192.0.2.14:27017/ceilometer?replicaSet=tripleo

Comment 6 errata-xmlrpc 2015-08-05 13:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.