Bug 123344 - Network install via BitTorrent (similar to HTTP install)
Network install via BitTorrent (similar to HTTP install)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 08:00 EDT by Niels Kristian Jensen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels Kristian Jensen 2004-05-17 08:00:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I am fond of the FTP and HTTP install metohods using the bootable CD 
made from boot.iso - but I would be even more happy to see 
a "BitTorrent" option.

Benefits include very little input, since only the tracker needs to 
be input.

Other benefits would be significatly lower pressure on your servers 
and mirrors.

I am not able to supply an enhancement to do this, but if you point 
to some files of the anaconda program where the enhancement may be 
input, some one else may be able to do it.

I'll be glad to help you test it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Patch
2. Get test-results from me
3. Profit :-)
    

Additional info:
Comment 1 Ricky Ng-Adam 2004-05-24 14:08:47 EDT
It would be nice if when this feature is implemented, there would also
be possible to have a checkbox with "Create cd-rom/dvd images from
Bittorrent downloads".  That way, the install can proceed quickly by
Bittorrent but future installs can also be done from those burned images.
Comment 2 Jeremy Katz 2004-10-07 14:08:48 EDT
The problem is that bittorrent is really only useful for larger files
and when the people using it join the torrent.  Which doesn't work so
well with the way the installer works.

Note You need to log in before you can comment on or make changes to this bug.