Bug 1233443 - katello-backup and katello-restore is missing
Summary: katello-backup and katello-restore is missing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.1.0
Hardware: All
OS: Linux
medium
high vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1248341 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-18 23:47 UTC by Johan Swensson
Modified: 2019-08-15 04:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:03:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1172415 None None None Never
Red Hat Knowledge Base (Solution) 1544443 None None None Never

Internal Links: 1172415

Description Johan Swensson 2015-06-18 23:47:09 UTC
Description of problem:
The documentation mentions katello-backup as the supported way of backing up a Satellite 6 server. However this command is not available after installation.
Same thing goes for katello-restore.

Version-Release number of selected component (if applicable):
6.1.0 (beta)

How reproducible:
Easy

Steps to Reproduce:
1. /usr/bin/katello-backup
2. yum provides "*katello-backup*"


Actual results:
Script not available.

Expected results:
Script should be available.

Additional info:
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/ch18.html

Comment 1 RHEL Product and Program Management 2015-06-18 23:53:36 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Christine Fouant 2015-06-30 16:47:41 UTC
Created redmine issue http://projects.theforeman.org/issues/10960 from this bug

Comment 4 David O'Brien 2015-07-05 23:06:40 UTC
Might need to follow up which repos are enabled/required for this. The backup and restore scripts were a late addition. mmccune (on CC) will be best contact I expect.

Comment 5 Christine Fouant 2015-07-06 15:40:46 UTC
There is a p-r open still awaiting review and ACKs https://github.com/Katello/katello/pull/5183

Comment 6 Mike McCune 2015-07-07 01:33:34 UTC
NOTE:

The backup and restore scripts are not available in the Satelite 6.1 Beta but will be available in the GA release.

The docs reflect the location that will be used in the GA release.

Apologies for the confusion.

Comment 9 Tazim Kolhar 2015-07-31 06:01:23 UTC
FAILEDQA:
# rpm -qa | grep foreman
foreman-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.1-1.el7sat.noarch
foreman-vmware-1.7.2.33-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-postgresql-1.7.2.33-1.el7sat.noarch
foreman-debug-1.7.2.33-1.el7sat.noarch
foreman-gce-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.18-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-proxy-1.7.2.5-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.33-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-compute-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.4-1.el7sat.noarch
foreman-libvirt-1.7.2.33-1.el7sat.noarch

steps:
the script is not available

# /usr/bin/katello-backup
-bash: /usr/bin/katello-backup: No such file or directory

Comment 10 Tazim Kolhar 2015-07-31 13:53:08 UTC
VERFIED:
# rpm -qa | grep foreman
foreman-proxy-1.7.2.5-1.el6_6sat.noarch
foreman-1.7.2.33-1.el6_6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el6_6sat.noarch
foreman-postgresql-1.7.2.33-1.el6_6sat.noarch
cloud-qe-9.idmqe.lab.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
ruby193-rubygem-foreman_docker-1.2.0.18-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el6_6sat.noarch
cloud-qe-9.idmqe.lab.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-libvirt-1.7.2.33-1.el6_6sat.noarch
foreman-ovirt-1.7.2.33-1.el6_6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.4-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el6_6sat.noarch
foreman-debug-1.7.2.33-1.el6_6sat.noarch
foreman-vmware-1.7.2.33-1.el6_6sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el6_6sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el6_6sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el6_6sat.noarch
foreman-selinux-1.7.2.13-1.el6_6sat.noarch
cloud-qe-9.idmqe.lab.eng.bos.redhat.com-foreman-client-1.0-1.noarch
foreman-gce-1.7.2.33-1.el6_6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el6_6sat.noarch
foreman-compute-1.7.2.33-1.el6_6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.1-1.el6_6sat.noarch

steps:
Re-tested it on one of the latest snap
# /usr/bin/katello-backup
Usage: katello-backup <backup directory>

script is available

Comment 11 Corey Welton 2015-07-31 16:14:07 UTC
Additional verification:

[root@cloud-qe-9 ~]# which katello-backup
/usr/bin/katello-backup
[root@cloud-qe-9 ~]# which katello-restore
/usr/bin/katello-restore

Comment 12 Mike McCune 2015-08-06 19:45:21 UTC
*** Bug 1248341 has been marked as a duplicate of this bug. ***

Comment 13 Bryan Kearney 2015-08-12 16:03:20 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.