Bug 123348 - make sendmail.cf silently fails without sendmail-cf RPM
Summary: make sendmail.cf silently fails without sendmail-cf RPM
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-17 13:28 UTC by Josh Kelley
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 14:54:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:299 normal SHIPPED_LIVE Updated sendmail packages 2004-09-01 04:00:00 UTC

Description Josh Kelley 2004-05-17 13:28:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
If the sendmail-cf package is not installed, then running "make" or
"make sendmail.cf" from the /etc/mail directory silently fails.

Version-Release number of selected component (if applicable):
8.12.11-3

How reproducible:
Always

Steps to Reproduce:
1. Install sendmail package.
2. Remove sendmail-cf package.
3. rm /etc/mail/sendmail.cf
4. make -C /etc/mail


Actual Results:  No output.

Expected Results:  Error message saying that sendmail.cf cannot be
created without the sendmail-cf package.

Additional info:

Comment 1 Steve Bonneville 2004-06-11 14:32:19 UTC
This would be nice.  I frequently see students in training classes
have problems with using sendmail.mc because they forget to verify
whether or not sendmail-cf is installed.

Comment 2 Thomas Woerner 2004-06-15 14:54:36 UTC
This will be fixed in the next release and in rawhide.

Comment 3 Jay Turner 2004-09-02 02:55:22 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-299.html



Note You need to log in before you can comment on or make changes to this bug.