Bug 123355 - support for video card (Toshiba laptop)
support for video card (Toshiba laptop)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: FutureFeature, Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-05-17 12:23 EDT by Diana Inkpen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 12:10:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Diana Inkpen 2004-05-17 12:23:34 EDT
Description of problem: Video card not supported. My video card is 
Trident XP4m32 Graphic Processing Unit, on a laptop Toshiba Protege 
R100. WindowsXP on the same laptop uses a video card driver Trident 
XP4 / Cyber-XP4. 
Fedora works on my videocard with VESA driver (generic) but I cannot  
see what is on the screen unless I limit to 256 color.


Description of another problem: CD-ROM or PCMCIA not supported. 
 On the same laptop, Toshiba Protege R100, I cannot use my Targus 
slim-line DVD/CD-RW Drive 32 bit CardBus and 16-bit PC card. Probably 
the Toshiba ToPIC100 Card Bus Controller is not supported?

I would appreciate if support for my videocard and CD unit can be 
added in the future. Thank you.
Comment 2 Mike A. Harris 2004-09-21 02:21:16 EDT
Thanks for the bug report.  We need you to supply the output of the
following command, in order to investigate the failure:

lspci -vvn

In addition to that, can you please manually edit the config file
for your X server and set the driver name to "trident" and try
starting the X server.  If this fails or does not work for any
reason, please try using the "vesa" driver instead.

Please indicate which if any of the above two drivers work with
your video hardware, and we will investigate the issue further once
you've updated the report with this information.

Thanks in advance.


Setting bug status to "NEEDINFO" pending requested information.
Comment 3 Diana Inkpen 2004-09-21 23:23:29 EDT
It work with vesa driver, but only with the lowest possible number of
colors. If I set it to 256 colors, I can see what is on the dislay.
With more colors it does not work, the display is unreadable and the
colors are strange and mixed up. 

With trident diver it cannot start the X server.

lspci -vvn

00:00.0 Class 0600: 8086:3340 (rev 03)
        Subsystem: 1179:0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Region 0: Memory at d0000000 (32-bit, prefetchable)
        Capabilities: [e4] #09 [f104]
        Capabilities: [a0] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit-
FW- Rate=<none>
 
00:01.0 Class 0604: 8086:3341 (rev 03)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: dff00000-f7ffffff
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
00:1d.0 Class 0c03: 8086:24c2 (rev 03)
        Subsystem: 1179:0001
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 11
        Region 4: I/O ports at efe0 [size=32]
 
00:1d.1 Class 0c03: 8086:24c4 (rev 03)
        Subsystem: 1179:0001
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 11
        Region 4: I/O ports at ef80 [size=32]

 00:1d.7 Class 0c03: 8086:24cd (rev 03) (prog-if 20)
        Subsystem: 1179:0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin D routed to IRQ 11
        Region 0: Memory at 10000000 (32-bit, non-prefetchable)
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] #0a [2080]
 
00:1e.0 Class 0604: 8086:2448 (rev 83)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR+
        Latency: 0
        Bus: primary=00, secondary=02, subordinate=04, sec-latency=64
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: dfd00000-dfdfffff
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
00:1f.0 Class 0601: 8086:24cc (rev 03)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
 
00:1f.1 Class 0101: 8086:24ca (rev 03) (prog-if 8a [Master SecP PriP])
        Subsystem: 1179:0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 11
        Region 0: I/O ports at <ignored>
        Region 1: I/O ports at <ignored>
        Region 2: I/O ports at <ignored>
        Region 3: I/O ports at <ignored>
        Region 4: I/O ports at bfa0 [size=16]
        Region 5: Memory at 10000400 (32-bit, non-prefetchable) [size=1K]
00:1f.5 Class 0401: 8086:24c5 (rev 03)
        Subsystem: 1179:0205
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 11
        Region 0: I/O ports at 1000
        Region 1: I/O ports at 1400 [size=64]
        Region 2: Memory at 10000800 (32-bit, non-prefetchable) [size=512]
        Region 3: Memory at 10000a00 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
00:1f.6 Class 0703: 8086:24c6 (rev 03)
        Subsystem: 1179:0001
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin B routed to IRQ 11
        Region 0: I/O ports at 1800
        Region 1: I/O ports at 1480 [size=128]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
01:00.0 Class 0300: 1023:2100 (rev 91)
        Subsystem: 1179:0002
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 8
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f0000000 (32-bit, non-prefetchable)
        Region 1: Memory at efc00000 (32-bit, non-prefetchable) [size=4M]
        Region 2: Memory at e0000000 (32-bit, non-prefetchable)
[size=128M]
        Region 3: Memory at dfff8000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: [80] AGP version 2.0
                Status: RQ=33 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW- AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit-
FW- Rate=<none>
        Capabilities: [90] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)                Status: D0 PME-Enable-
DSel=0 DScale=0 PME-
 
02:08.0 Class 0200: 8086:103d (rev 83)
        Subsystem: 1179:0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min, 14000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at dfdff000 (32-bit, non-prefetchable)
        Region 1: I/O ports at cf40 [size=64]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)                Status: D0 PME-Enable+
DSel=0 DScale=2 PME-
 
02:0a.0 Class 0280: 8086:1043 (rev 04)
        Subsystem: 8086:2581
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (500ns min, 8500ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at dfdfe000 (32-bit, non-prefetchable)
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)                Status: D0 PME-Enable-
DSel=0 DScale=1 PME-
 
02:0b.0 Class 0607: 1179:0617 (rev 33)
        Subsystem: 1179:0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=slow >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 168
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at 10001000 (32-bit, non-prefetchable)
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=0
        Memory window 0: 10400000-107ff000 (prefetchable)
        Memory window 1: 10800000-10bff000
        I/O window 0: 00004000-000040ff
        I/O window 1: 00004400-000044ff
        Latency: 168
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at 10001000 (32-bit, non-prefetchable)
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=0
        Memory window 0: 10400000-107ff000 (prefetchable)
        Memory window 1: 10800000-10bff000
        I/O window 0: 00004000-000040ff
        I/O window 1: 00004400-000044ff
        BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt+
PostWrite+
        16-bit legacy interface ports at 0001
 
02:0d.0 Class 0880: 1179:0805 (rev 05)
        Subsystem: 1179:0001
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at 10000c00 (32-bit, non-prefetchable) [disabled]
        Capabilities: [80] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)                Status: D0 PME-Enable-
DSel=0 DScale=0 PME-
Comment 4 Helmut Manck 2004-11-02 15:30:08 EST
Same Laptop, different result: I use FC2 on the R100 and use the
trident driver, but the driver is awfully slow, xv does not work. Vesa
is somehow colorcorrupted, if 16 bit used, but works and is more fast.
Comment 6 Mike A. Harris 2005-03-21 11:34:06 EST
Here's the PCI ID of your video hardware:

01:00.0 Class 0300: 1023:2100 (rev 91)
        Subsystem: 1179:0002

Device ID 0x2100 is present in our "pcitable" database as:

    0x1023  0x2100  "Card:Trident CyberBlade (generic)"

Which the "Cards" database maps to the following driver:

NAME Trident CyberBlade (generic)
CHIPSET CyberBlade
DRIVER trident
NOCLOCKPROBE


Please do the following steps:

- Upgrade to xorg-x11-6.8.2 from Fedora development.

- Run "system-config-display --reconfig", it should automatically
  use the "trident" driver.

- Reboot your system completely, to force a full video hardware reset.

- When the system comes up, start X using the trident driver.


You mention above:
> With trident diver it cannot start the X server.

If that is the case, then test the new xorg-x11 as requested above.  If
the problem you are experiencing with the "trident" driver persists, please
file a new bug report in X.Org bugzilla located at:

http://bugs.freedesktop.org in the "xorg" component.

When you file your bug report in X.Org bugzilla, attach the X server config
file, and log file from your failed session using the "trident" driver.  Also
include all details for how to reproduce the problem.  If you've found any
workarounds with the "trident" driver, please indicate them in the X.Org
bug report as well.

Once you've filed your bug report in X.Org bugzilla, please paste the URL
here and Red Hat will track the issue in the upstream bugzilla and review
any fixes that become available for consideration in future updates.

Thanks in advance.
Comment 7 Mike A. Harris 2005-03-29 14:54:24 EST
Moving off FC4Blocker list to FC4Target due to lack of feedback however
if problem still occurs, please provide a status update with the information
requested in comment #6.
Comment 8 Mike A. Harris 2005-04-05 12:10:48 EDT
Assuming bug is no longer occuring, due to lack of feedback, and closing
as "RAWHIDE".  If this is incorrect, follow the steps in comment #6
above, update the report with the information requested, and reopen the
report and we'll review it again.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.