Bug 1233557 - Should not display "Upgrade" during rhevh7.1 reinstall in dirty multipath iSCSI environment.
Summary: Should not display "Upgrade" during rhevh7.1 reinstall in dirty multipath iSC...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: Chaofeng Wu
URL:
Whiteboard:
Depends On: 1051742 1233186
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-19 07:18 UTC by Chaofeng Wu
Modified: 2016-03-09 14:31 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-3.3.0-0.16.20151021git51ae965.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:31:38 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
TUI reinstallation screenshot (323.52 KB, image/png)
2015-06-19 07:18 UTC, Chaofeng Wu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC

Description Chaofeng Wu 2015-06-19 07:18:44 UTC
Created attachment 1040767 [details]
TUI reinstallation screenshot

Description of problem:
Reinstall rhevh7.1 by the command line in the grub in multipath iSCSI environment which has been installed rhevh6.7. After boot to the rhevh7.1 installation TUI, the TUI display should not be "<Upgrade 6.7-20150609.0.el6ev to 7.1-20150512.1.el7ev>", because we don't support upgrade from rhevh6.7 to rhevh7.1.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.7-20150609.0.iso
rhev-hypervisor7-7.1-20150512.1.iso

How reproducible:
100%

Steps to Reproduce:
1. PXE install rhev-hypervisor6-6.7-20150609 on the test machine with multipath iSCSI environment.
2. Configure the network then reboot the test machine.
3. PXE install rhev-hypervisor7-7.1-20150512.1.iso with reinstall parameter in cmdline to start up TUI installation.
#cat /proc/cmdline
initrd=/images/rhevh-vdsm7-7.1-20150512.1.el7ev.noarch/initrd0.img ksdevice=bootif rootflags=loop rootflags=ro rd.dm=0 rd_NO_MULTIPATH rd.md=0 crashkernel=256M rootfstype=auto lang=  max_loop=256 rhgb quiet elevator=deadline rd.live.check rd.luks=0 install ro root=live:/rhevh-7.1-20150512.1.el7ev.iso rd.live.image  BOOTIF=01-00-1f-29-03-86-7f reinstall BOOT_IMAGE=/images/rhevh-vdsm7-7.1-20150512.1.el7ev.noarch/vmlinuz0

Actual results:
The TUI show <Upgrade 6.7-20150609.0.el6ev to 7.1-20150512.1.el7ev>.

Expected results:
The TUI should show <Install Hypervisor 7.1-20150512.1.el7ev>, should not show "Upgrade", because major version upgrade is not supported.

Additional info:

Comment 1 Fabian Deutsch 2015-06-24 07:39:55 UTC
This bug probably occurs because of bug 1233186 or bug 1051742. In both cases we fail to erase the previous RHEV-H from disk, and thus it looks like an upgrade to the TUI.

Besides that we can probably enhance the TUI to catch this case.

Comment 2 Chaofeng Wu 2015-11-27 09:08:39 UTC
Verify this bug on rhev-hypervisor7-7.2-20151112.1.iso.

Versions:
rhev-hypervisor6-6.7-20151123.0.iso
rhev-hypervisor7-7.2-20151112.1.iso

Steps:
1. Install and configure rhev-hypervisor6-6.7-20151123.0.iso on the test machine with multipath iSCSI environment.
2. PXE boot to install rhev-hypervisor7-7.2-20151112.1.iso with reinstall command.
Kernel command line: initrd=/images/rhevh-vdsm7-7.2-20151112.1_36/initrd0.img ksdevice=bootif rootflags=loop rootflags=ro rd.dm=0 rd_NO_MULTIPATH rd.md=0 crashkernel=256M rootfstype=auto lang=  max_loop=256 rhgb quiet elevator=deadline rd.live.check rd.luks=0 install ro root=live:/rhev-hypervisor7-7.2-20151112.1.iso rd.live.image  BOOTIF=01-18-a9-05-bf-8b-e6 reinstall BOOT_IMAGE=/images/rhevh-vdsm7-7.2-20151112.1_36/vmlinuz0

Results:
After step2, the TUI install page show < Install Hypervisor 7.2-20151112.1.el7ev >.

The issue was gone, seems fixed by the other patches. So change the status to VERIFIED.

Comment 4 errata-xmlrpc 2016-03-09 14:31:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.