Bug 123367 - Missing deps for devel package.
Missing deps for devel package.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdv (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 14:36 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 06:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-05-17 14:36:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
[root@gruyere ~]# pkg-config --libs libdv
sh: line 1: glib-config: command not found
sh: line 1: glib-config: command not found
sh: line 1: glib-config: command not found
sh: line 1: gtk-config: command not found
sh: line 1: gtk-config: command not found
sh: line 1: gtk-config: command not found
Package 'libdv' requires 'glib >= 1.2.4' but version of GLib is

Please add "Requires:gtk+-devel" in libdv-devel requirement list in
spec file.

Version-Release number of selected component (if applicable):
libdv(0:0.102-1).i386

How reproducible:
Always

Steps to Reproduce:
1. install libdv-devel
2. install pkgconfig
3. pkgconfig libdv --libs
    

Additional info:
Comment 1 Warren Togami 2004-05-31 05:43:09 EDT
arg, build system failed, will probably build tomorrow
Comment 2 John Thacker 2004-06-20 20:58:06 EDT
This actually isn't the right solution.  It's actually a bug in the
pkg-config file, libdv.pc, for libdv.  It's fixed upstream.

What happens in that the libdv people distribute a test application,
playdv, which plays DV files.  It depends on GTK+.  Their build
process incorrectly adds the GTK+ dependencies to the pkg-config file.

Since we don't ship playdv, we shouldn't actually depend on
gtk+-devel, and that's why rpmbuild doesn't pick it up.  The right
solution is to patch libdv.pc.in so that this doesn't happen.  (Which
they've already done in libdv CVS.)  See the following mail message:

http://sourceforge.net/mailarchive/forum.php?thread_id=4431792&forum_id=5458

As a side note, fixing this will fix the bogus gtk+ dependency in
gstreamer-plugins, since gstreamer-plugins uses libdv
Comment 3 John Thacker 2004-06-20 21:03:56 EDT
The only thing that needs to require GTK+ is libdv-tools, which
already does, in other words.

Note You need to log in before you can comment on or make changes to this bug.