Bug 1233772 - Web console links to origin docs
Summary: Web console links to origin docs
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jordan Liggitt
QA Contact: Yanping Zhang
URL:
Whiteboard:
Keywords: UpcomingRelease
: 1238510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-19 13:06 UTC by Jordan Liggitt
Modified: 2015-08-03 20:17 UTC (History)
8 users (show)

(edit)
The Documentation link in the header of the web console previously linked to the latest OpenShift Origin documentation. It has been updated to now point to the OpenShift Enterprise documentation for the current version.
Clone Of:
(edit)
Last Closed: 2015-08-03 20:17:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1540 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 3.0.1.0 bug fix and enhancement update 2015-08-04 00:17:18 UTC

Description Jordan Liggitt 2015-06-19 13:06:13 UTC
Description of problem:
The doc link in the header of the web console refers to the latest origin docs. It should point to the enterprise docs for the current version.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Jordan Liggitt 2015-06-19 15:59:32 UTC
currently, this means replacing
  docs.openshift.org/latest/

with
  docs.openshift.com/enterprise/3.0/

in these three files:
  assets/app/index.html
  assets/app/scripts/filters/util.js
  pkg/assets/bindata.go

a separate issue should be opened to make the docroot configurable, and allow overriding deep link destinations for the specific topics the web console links to

Comment 3 Jordan Liggitt 2015-06-29 17:56:21 UTC
Links fixed in https://github.com/openshift/ose/pull/45

Comment 4 Scott Dodson 2015-06-29 22:49:20 UTC
I still need to build this and determine how we want to version ose/master versus ose/enterprise-3.0. Flipping this back to MODIFIED for now, will sort that out tomorrow.

Comment 5 Jordan Liggitt 2015-06-29 23:02:32 UTC
Ah, sorry. Anything else you need on my end for this?

Comment 8 Yanping Zhang 2015-07-02 02:16:45 UTC
Checked on ose env with version below:
openshift v3.0.1.0
kubernetes v0.17.1-804-g496be63

Login web console, the Documentation links to enterprise/3.0, and links for "Learn more" in "Browse-->Builds","Browse-->Deployments" are all pointing to related enterprise 3.0 docs.
 
Move the bug to Verified.

Comment 9 Yanping Zhang 2015-07-06 05:54:33 UTC
*** Bug 1238510 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2015-08-03 20:17:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1540


Note You need to log in before you can comment on or make changes to this bug.