Bug 123381 - RHN doesn't recognize that machines require updates
RHN doesn't recognize that machines require updates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 16:01 EDT by Norman Elton
Modified: 2007-04-18 13:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHN 3.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-01 19:13:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
E-Mail recieved from RHN (4.35 KB, text/plain)
2004-05-26 13:22 EDT, Norman Elton
no flags Details
E-Mail from RHN, now with headers (5.47 KB, text/plain)
2004-05-26 13:37 EDT, Norman Elton
no flags Details

  None (edit)
Description Norman Elton 2004-05-17 16:01:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/124 (KHTML, like Gecko) Safari/125.1

Description of problem:
When I log into RedHat Network, it shows a list of my 23 machines. Even though I know most need updates, they all appear to be healthy (the blue checkmark). They are all checking in as expected, and if I run rhn_check, it returns immediately.

A few weeks ago, you pushed out a kernel upgrade. Two or three machines (one AS, one WS) were flagged as needing the update. A few days later, another two or three decided they needed the update. The rest have appeared "okay" ever since.

The same thing happened with Service Release 2, released last week. I believe two machines were listed as out of date. The rest of them are reporting to be up to date, although I haven't pushed patches to them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log into RHN
2. Find a machine needing updates. Verify that it doesn't have a new kernel installed.
    

Actual Results:  Machine states that it's up to date on patches. RHN says that it is running kernel-2.4.21-9.0.1.EL.

Expected Results:  Machine should realize it needs kernel-2.4.21-9.0.3.EL

Additional info:
Comment 1 Norman Elton 2004-05-17 16:19:43 EDT
If I run "up2date -p", to update the package profile, RHN correctly reports that the system 
requires updating. However, before running this command, RHN did not think it had the 
latest RPMs.

Even if I can run "up2date -p" on all my machines, this is still an issue. I don't want to have 
to run a command every day to detect whether new updates are really necessary.
Comment 2 Todd Warner 2004-05-26 13:10:24 EDT
Date: Wed, 26 May 2004 11:48:05 -0400
From: Norman Elton <wnelto@net.wm.edu>
Reply-To: Red Hat Network Users List <rhn-users@redhat.com>
To: Bret McMillan <bretm@redhat.com>
Cc: Red Hat Network Users List <rhn-users@redhat.com>
Subject: Re: [rhn-users] RHN not recognizing necessary patches

Bret (and Todd),

Thanks for looking into this. It's a relief to see @redhat.com on your
e-mail addresses.

> 1.  What emails are you receiving?  Ones from RHN, or general errata
>     alerts?

I'm getting RHN Errata Alerts. It explains the errata, then lists the
systems that require updating. In most cases, it's all my systems.

> 2.  What machines is this happening on?  rhel 2.1?  rhel 3?

All the afflicted machines are RHEL 3.

> 3.  What versions of rpm and up2date are the machines running?

I checked one of the afflicted machines. It's running rpm-4.2.2-0.14
and up2date-4.2.16-1

> 4.  Are you doing any local rpm installations using the rpm
>     commandline utility on the machines in question?

Not very often. Every once in a blue moon I'll install an RPM by hand.

> 5.  Do you have the bugzilla # for the bug you filed handy?

Bugzilla #123381. If it helps, my login name is WMNetworking.

Norman
Comment 3 Todd Warner 2004-05-26 13:11:09 EDT
Please post one of these emails.
Comment 4 Norman Elton 2004-05-26 13:22:07 EDT
Created attachment 100598 [details]
E-Mail recieved from RHN
Comment 5 Bret McMillan 2004-05-26 13:27:06 EDT
Can you supply the email headers so we can get an idea when the email
was sent out?
Comment 6 Norman Elton 2004-05-26 13:37:27 EDT
Created attachment 100599 [details]
E-Mail from RHN, now with headers

Questions from Bret...

> time you received the RHN errata email (perhaps attach a copy to
> the bugzilla you filed, including the headers?)

The message was sent from RedHat at Wed, 26 May 2004 10:18:31. Our mail servers
recieved it a few seconds later. I'm attaching the headers.

> time you logged into the RHN website and noticed your systems were
> not correctly flagged as needing errata

I am currently (Wed, 26 Pay 2004 13:27:00) logged into RHN. My machines are
saying that 
they are up to date. I picked one server (named Gretel), selected "List
Packages Installed", 
and confirmed that tcpdump-3.7.2-7.E3.1:14 is the latest version installed. The
errata 
posted above references tcpdump-3.7.2-7.E3.2.i386.rpm. Therefore, RHN should
have 
flagged the machine as being out of date.

> Do you have any rhel 2.1 machines?  If so, are they being marked as
> correctly needing errata in a timely fashion?

We have one RHEL 2.1 machine, however, it's administered by another group. I do
not 
know if it's getting errata correctly or not. It's interested to note that I
never had any 
trouble until a few weeks ago. Unfortunately I do not have an exact date.

> Forgot to ask this before... when you spoke with customer support, was
> an Issue Tracker number given to you?

I wasn't given an issue tracking number. I spoke with both Shane (last week)
and Alissa 
(today).
Comment 7 Chris MacLeod 2004-05-26 18:32:41 EDT
Norman:
We've rerun our task that computes that data (will finish approx
8:30pm EDT) for your org so all your systems should be current.  Right
now we need to wait for another errata to see if the problem manifests
itself again.

The next time an errata comes out (that you get a notification for)
please update this bug with a status of what the website reported for
your systems in that case (either positive it worked or negative same
problem again)

Comment 9 Mihai Ibanescu 2004-06-28 19:00:10 EDT
Marking it as MODIFIED. Please move back to ASSIGNED if issue is still
present, or close it as appropriate.

Note You need to log in before you can comment on or make changes to this bug.