Bug 1233860 - rhel-osp-director: The values for network, floating ip and scales in the deploy-overcloudrc file are being ignored for the overcloud deployment, although the file was sourced.
Summary: rhel-osp-director: The values for network, floating ip and scales in the depl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Ofer Blaut
Dan Macpherson
URL:
Whiteboard:
: 1234510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-19 15:40 UTC by Alexander Chuzhoy
Modified: 2015-08-27 05:51 UTC (History)
8 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-6.el7ost
Doc Type: Bug Fix
Doc Text:
The director previously used a file with network and floating IP options for deployment. However, these network options were ignored in early versions of the director. This fix replaces the file with a set of command line arguments for "openstack overcloud director". The CLI tool now contains the necessary options for configuring network and floating IPs in the Overcloud.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-06-19 15:40:48 UTC
rhel-osp-director: The values for network, floating ip and scales in the deploy-overcloudrc file are being ignored for the overcloud deployment, although the file was sourced.

Environment:
instack-undercloud-2.1.2-1.el7ost.noarch


Steps to reproduce:
. Follow the guide https://repos.fedorapeople.org/repos/openstack-m/docs/internal/master/basic_deployment/basic_deployment.html

There's this step:

Baremetal

Copy the sample overcloudrc file and edit to reflect your environment. Then source this file:

cp /usr/share/instack-undercloud/deploy-baremetal-overcloudrc ~/deploy-overcloudrc
source deploy-overcloudrc


Continue with the guide and deploy the overcloud.


Result:
The values set in the file are being ignored and the networks created on the overcloud have different (default) settings.

Expected results:
The networks should be configured with the settings in the sourced file.

Comment 3 chris alfonso 2015-06-19 17:24:51 UTC
We should support having the rc file as well as passing in params. This probably needs doocumentation specifying it.

Comment 4 Dougal Matthews 2015-06-22 11:15:27 UTC
Not supporting environment files for this was intentional. All of these should be possible to set with arguments to the deploy command. Either individually or by passing an extra environment file.

I would suggest this is really an issue with instack and the docs.

Comment 5 James Slagle 2015-06-22 18:16:27 UTC
(In reply to Dougal Matthews from comment #4)
> Not supporting environment files for this was intentional. All of these
> should be possible to set with arguments to the deploy command. Either
> individually or by passing an extra environment file.
> 
> I would suggest this is really an issue with instack and the docs.

can you submit the appropriate docs update? The initial update made no mention of this change: https://review.gerrithub.io/#/c/236363/

Comment 6 Dan Sneddon 2015-06-22 19:01:21 UTC
*** Bug 1234510 has been marked as a duplicate of this bug. ***

Comment 7 Dan Sneddon 2015-06-22 19:27:59 UTC
Here are the available command line options which replace the deploy-overcloudrc environment variables:

optional arguments:
  -h, --help            show this help message and exit
  --control-scale CONTROL_SCALE
  --compute-scale COMPUTE_SCALE
  --ceph-storage-scale CEPH_STORAGE_SCALE
  --block-storage-scale BLOCK_STORAGE_SCALE
  --swift-storage-scale SWIFT_STORAGE_SCALE
  --control-flavor CONTROL_FLAVOR
                        Nova flavor to use for control nodes.
  --compute-flavor COMPUTE_FLAVOR
                        Nova flavor to use for compute nodes.
  --ceph-storage-flavor CEPH_STORAGE_FLAVOR
                        Nova flavor to use for ceph storage nodes.
  --block-storage-flavor BLOCK_STORAGE_FLAVOR
                        Nova flavor to use for cinder storage nodes.
  --swift-storage-flavor SWIFT_STORAGE_FLAVOR
                        Nova flavor to use for swift storage nodes.
  --use-tripleo-heat-templates
  --neutron-flat-networks NEUTRON_FLAT_NETWORKS
  --neutron-physical-bridge NEUTRON_PHYSICAL_BRIDGE
  --neutron-bridge-mappings NEUTRON_BRIDGE_MAPPINGS
  --neutron-public-interface NEUTRON_PUBLIC_INTERFACE
  --hypervisor-neutron-public-interface HYPERVISOR_NEUTRON_PUBLIC_INTERFACE
  --neutron-network-type NEUTRON_NETWORK_TYPE
  --neutron-tunnel-types NEUTRON_TUNNEL_TYPES
  --neutron-disable-tunneling
  --neutron-network-vlan-ranges NEUTRON_NETWORK_VLAN_RANGES
  --libvirt-type LIBVIRT_TYPE
  --ntp-server NTP_SERVER
  --cinder-lvm
  --tripleo-root TRIPLEO_ROOT
  --nodes-json NODES_JSON
  --no-proxy NO_PROXY
  --plan-uuid PLAN_UUID
                        The UUID of the Tuskar plan to deploy.
  -O <OUTPUT DIR>, --output-dir <OUTPUT DIR>
                        Directory to write Tuskar template files into. It will
                        be created if it does not exist. If not provided a
                        temporary directory will be used.
  -e <EXTRA DIR>, --extra-dir <EXTRA DIR>
                        Directory containing any extra environment files to
                        pass heat. (Defaults to /etc/tripleo/extra_config.d)

Comment 8 Alexander Chuzhoy 2015-06-22 19:36:45 UTC
The arguments don't include (or it's not clear) stuff like: "floating subnet address", "floating subnet gateway IP", "tenant subnet address and gateway"

Comment 9 Alexander Chuzhoy 2015-06-22 20:30:53 UTC
So these are configured now in the postconfig phase:

openstack help overcloud postconfig
/usr/lib/python2.7/site-packages/novaclient/v1_1/__init__.py:30: UserWarning: Module novaclient.v1_1 is deprecated (taken as a basis for novaclient.v2). The preferable way to get client class or object you can find in novaclient.client module.
  warnings.warn("Module novaclient.v1_1 is deprecated (taken as a basis for "
usage: openstack overcloud postconfig [-h]
                                      [--overcloud_nameserver OVERCLOUD_NAMESERVER]
                                      [--floating-id-cidr FLOATING_ID_CIDR]
                                      [--floating-ip-start FLOATING_IP_START]
                                      [--floating-ip-end FLOATING_IP_END]
                                      [--ibm-network-gateway IBM_NETWORK_GATEWAY]
                                      [--network-cidr NETWORK_CIDR]
                                      overcloud_ip

Complete the configuration of the overcloud

positional arguments:
  overcloud_ip          The IP address of the Overcloud endpoint

optional arguments:
  -h, --help            show this help message and exit
  --overcloud_nameserver OVERCLOUD_NAMESERVER
  --floating-id-cidr FLOATING_ID_CIDR
  --floating-ip-start FLOATING_IP_START
  --floating-ip-end FLOATING_IP_END
  --ibm-network-gateway IBM_NETWORK_GATEWAY
  --network-cidr NETWORK_CIDR



Tested the above on my setup - works.

Comment 10 Dougal Matthews 2015-06-23 12:33:01 UTC
The postconfig step has been merged back into the deploy command - it was split out due to an issue with working with two clouds (under and over) in one command. That was resolved by https://bugzilla.redhat.com/show_bug.cgi?id=1234861

Comment 11 Mike Burns 2015-06-23 12:54:51 UTC
Since this is not a valid scenario, the only update needed is a doc update.  Dougal will work on that in the upstream sphinx docs, then we'll get Dan to incorporate that into the product docs.

In the meantime, this is not a blocker

Comment 12 Dougal Matthews 2015-06-23 15:37:17 UTC
Fix midstream: https://review.gerrithub.io/#/c/237372/

Comment 17 Ofer Blaut 2015-06-24 18:27:19 UTC
All these options are been seen by UCLI, we should have doc for it

usage: openstack overcloud deploy [-h] [--control-scale CONTROL_SCALE]
                                  [--compute-scale COMPUTE_SCALE]
                                  [--ceph-storage-scale CEPH_STORAGE_SCALE]
                                  [--block-storage-scale BLOCK_STORAGE_SCALE]
                                  [--swift-storage-scale SWIFT_STORAGE_SCALE]
                                  [--control-flavor CONTROL_FLAVOR]
                                  [--compute-flavor COMPUTE_FLAVOR]
                                  [--ceph-storage-flavor CEPH_STORAGE_FLAVOR]
                                  [--block-storage-flavor BLOCK_STORAGE_FLAVOR]
                                  [--swift-storage-flavor SWIFT_STORAGE_FLAVOR]
                                  [--use-tripleo-heat-templates]
                                  [--neutron-flat-networks NEUTRON_FLAT_NETWORKS]
                                  [--neutron-physical-bridge NEUTRON_PHYSICAL_BRIDGE]
                                  [--neutron-bridge-mappings NEUTRON_BRIDGE_MAPPINGS]
                                  [--neutron-public-interface NEUTRON_PUBLIC_INTERFACE]
                                  [--hypervisor-neutron-public-interface HYPERVISOR_NEUTRON_PUBLIC_INTERFACE]
                                  [--neutron-network-type NEUTRON_NETWORK_TYPE]
                                  [--neutron-tunnel-types NEUTRON_TUNNEL_TYPES]
                                  [--neutron-disable-tunneling]
                                  [--neutron-network-vlan-ranges NEUTRON_NETWORK_VLAN_RANGES]
                                  [--libvirt-type LIBVIRT_TYPE]
                                  [--ntp-server NTP_SERVER] [--cinder-lvm]
                                  [--tripleo-root TRIPLEO_ROOT]
                                  [--nodes-json NODES_JSON]
                                  [--no-proxy NO_PROXY] [--plan-uuid PLAN]
                                  [--plan PLAN] [-O <OUTPUT DIR>]
                                  [-e <EXTRA DIR>]
                                  [--overcloud_nameserver OVERCLOUD_NAMESERVER]
                                  [--floating-id-cidr FLOATING_ID_CIDR]
                                  [--floating-ip-start FLOATING_IP_START]
                                  [--floating-ip-end FLOATING_IP_END]
                                  [--bm-network-gateway BM_NETWORK_GATEWAY]
                                  [--network-cidr NETWORK_CIDR]

Deploy Overcloud

optional arguments:
  -h, --help            show this help message and exit
  --control-scale CONTROL_SCALE
  --compute-scale COMPUTE_SCALE
  --ceph-storage-scale CEPH_STORAGE_SCALE
  --block-storage-scale BLOCK_STORAGE_SCALE
  --swift-storage-scale SWIFT_STORAGE_SCALE
  --control-flavor CONTROL_FLAVOR
                        Nova flavor to use for control nodes.
  --compute-flavor COMPUTE_FLAVOR
                        Nova flavor to use for compute nodes.
  --ceph-storage-flavor CEPH_STORAGE_FLAVOR
                        Nova flavor to use for ceph storage nodes.
  --block-storage-flavor BLOCK_STORAGE_FLAVOR
                        Nova flavor to use for cinder storage nodes.
  --swift-storage-flavor SWIFT_STORAGE_FLAVOR
                        Nova flavor to use for swift storage nodes.
  --use-tripleo-heat-templates
  --neutron-flat-networks NEUTRON_FLAT_NETWORKS
  --neutron-physical-bridge NEUTRON_PHYSICAL_BRIDGE
  --neutron-bridge-mappings NEUTRON_BRIDGE_MAPPINGS
  --neutron-public-interface NEUTRON_PUBLIC_INTERFACE
  --hypervisor-neutron-public-interface HYPERVISOR_NEUTRON_PUBLIC_INTERFACE
  --neutron-network-type NEUTRON_NETWORK_TYPE
  --neutron-tunnel-types NEUTRON_TUNNEL_TYPES
  --neutron-disable-tunneling
  --neutron-network-vlan-ranges NEUTRON_NETWORK_VLAN_RANGES
  --libvirt-type LIBVIRT_TYPE
  --ntp-server NTP_SERVER
  --cinder-lvm
  --tripleo-root TRIPLEO_ROOT
  --nodes-json NODES_JSON
  --no-proxy NO_PROXY
  --plan-uuid PLAN      The UUID of the Tuskar plan to deploy.
  --plan PLAN           The Name or UUID of the Tuskar plan to deploy.
  -O <OUTPUT DIR>, --output-dir <OUTPUT DIR>
                        Directory to write Tuskar template files into. It will
                        be created if it does not exist. If not provided a
                        temporary directory will be used.
  -e <EXTRA DIR>, --extra-dir <EXTRA DIR>
                        Directory containing any extra environment files to
                        pass heat. (Defaults to /etc/tripleo/extra_config.d)
  --overcloud_nameserver OVERCLOUD_NAMESERVER
  --floating-id-cidr FLOATING_ID_CIDR
  --floating-ip-start FLOATING_IP_START
  --floating-ip-end FLOATING_IP_END
  --bm-network-gateway BM_NETWORK_GATEWAY
  --network-cidr NETWORK_CIDR

Comment 18 Ofer Blaut 2015-06-24 18:27:59 UTC
 tested on python-rdomanager-oscplugin-0.0.8-6.el7ost.noarch

Comment 19 Dougal Matthews 2015-07-07 06:59:59 UTC
You are correct that the deploy-overcloudrc isn't the expected way to use the ucli. Parameters  should be used as shown in the above comment. So I don't think this is a valid bug.

Comment 21 errata-xmlrpc 2015-08-05 13:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.