Bug 1234052 - Replaces libgpod base package in RHEL7
Summary: Replaces libgpod base package in RHEL7
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: libgpod
Version: epel7
Hardware: x86_64
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Moez Roy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-20 16:01 UTC by John T. Rose
Modified: 2015-08-24 23:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-24 23:01:17 UTC


Attachments (Terms of Use)

Description John T. Rose 2015-06-20 16:01:45 UTC
Description of problem:

EPEL7 libgpod package replaces base RHEL7 libgpod package.

Version-Release number of selected component (if applicable):

0.8.3-6.el7

How reproducible:

# cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 7.1 (Maipo)

# yum repolist
Loaded plugins: langpacks, product-id, subscription-manager
repo id                                              repo name            status
epel/x86_64                                          Extra Packages for E 8,095
rhel-7-workstation-fastrack-rpms/x86_64              Red Hat Enterprise L   117
rhel-7-workstation-optional-fastrack-rpms/x86_64     Red Hat Enterprise L    58
rhel-7-workstation-optional-rpms/7Workstation/x86_64 Red Hat Enterprise L 5,448
rhel-7-workstation-rpms/7Workstation/x86_64          Red Hat Enterprise L 7,468
repolist: 21,186

# yum --showduplicates list libgpod
Loaded plugins: langpacks, product-id, subscription-manager
Installed Packages
libgpod.x86_64               0.8.2-11.el7                @anaconda/7.1          
Available Packages
libgpod.i686                 0.8.2-11.el7                rhel-7-workstation-rpms
libgpod.x86_64               0.8.2-11.el7                rhel-7-workstation-rpms
libgpod.x86_64               0.8.3-6.el7                 epel                   


Steps to Reproduce:

See above.

Actual results:

Replacement for base RHEL package offered in EPEL.

Expected results:

Nothing in EPEL replacing a base RHEL package.

Additional info:

This appears to be a weird case for the no replacement policy in EPEL since libgpod is available for RHEL7 Workstation and Client but not for Server. So I guess I could see an argument either way about including it in EPEL but these conflicts are frustrating when the end user of EPEL expects there to be no conflicts.

Comment 1 Moez Roy 2015-06-21 02:42:50 UTC
(In reply to John T. Rose from comment #0)
> This appears to be a weird case for the no replacement policy in EPEL since
> libgpod is available for RHEL7 Workstation and Client but not for Server. So
> I guess I could see an argument either way about including it in EPEL but
> these conflicts are frustrating when the end user of EPEL expects there to
> be no conflicts.

The koji build root uses the Server. If I retire this package it will then break the dependencies.

Also you need to consider that there is some mono bindings which are not in either the Workstation/Client (which is provided by this package).

Comment 2 Moez Roy 2015-08-24 22:59:13 UTC
*** Bug 1256545 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.