Bug 1234099 - reposync unicode error
reposync unicode error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:bc932b3115342329a160d2c6755...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-21 07:18 EDT by Daniel Seither
Modified: 2015-08-19 03:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2015-06-21 07:19 EDT, Daniel Seither
no flags Details
File: dso_list (106 bytes, text/plain)
2015-06-21 07:19 EDT, Daniel Seither
no flags Details
File: environ (2.17 KB, text/plain)
2015-06-21 07:19 EDT, Daniel Seither
no flags Details

  None (edit)
Description Daniel Seither 2015-06-21 07:18:56 EDT
Version-Release number of selected component:
dnf-1.0.0-1.fc22

Additional info:
reporter:       libreport-2.5.1
cmdline:        /usr/bin/python -OO /bin/dnf reposync
executable:     /bin/dnf
kernel:         4.0.3-300.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
posixpath.py:80:join:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 30: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 115, in _main
    cli.configure(map(ucd, args))
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1011, in configure
    self.command.configure(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/reposync.py", line 83, in configure
    repo.pkgdir = _pkgdir(opts.download_path, repo.id)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/reposync.py", line 47, in _pkgdir
    return os.path.normpath(os.path.join(os.getcwd(), intermediate, target))
  File "/usr/lib64/python2.7/posixpath.py", line 80, in join
    path += '/' + b
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 30: ordinal not in range(128)

Local variables in innermost frame:
a: '/home/daniel/Downloads/Wanderf\xc3\xbchrer Lappland'
path: '/home/daniel/Downloads/Wanderf\xc3\xbchrer Lappland'
b: u'./'
p: (u'./', u'updates-testing')
Comment 1 Daniel Seither 2015-06-21 07:19:00 EDT
Created attachment 1041398 [details]
File: backtrace
Comment 2 Daniel Seither 2015-06-21 07:19:02 EDT
Created attachment 1041399 [details]
File: dso_list
Comment 3 Daniel Seither 2015-06-21 07:19:03 EDT
Created attachment 1041400 [details]
File: environ
Comment 4 Honza Silhan 2015-07-29 07:20:45 EDT
It looks like bug in reposync. Can you confirm, Michael?
Comment 5 Michael Mráka 2015-08-05 10:17:07 EDT
Well, yes and no.
I'd consider it a bug in python2's os.getcwd() which returns string even if path contains unicode chars. On the other hand we can fix it in our code.

Fixed in 
commit f4b3f5a238f87cba923af1628aa954067f58a6c5
    path may contain unicode (RhBug:1234099)
Comment 6 Fedora Update System 2015-08-10 06:05:31 EDT
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23
Comment 7 Fedora Update System 2015-08-10 06:49:15 EDT
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
Comment 8 Fedora Update System 2015-08-10 22:10:29 EDT
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2015-08-14 22:14:13 EDT
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-08-19 03:51:21 EDT
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.