Bug 12341 - [text-installation] python exception
Summary: [text-installation] python exception
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-16 19:26 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-16 19:26:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-06-16 19:26:13 UTC
Beginning installation at an empty harddisk by pressing "Ok" 3 times, then "Upgrade Existing Installation" (--> "Bad Partition Table") and finally "Skip Drive" and "Ok" results in

Exception occurred
Traceback (innermost last):
  File "/usr/bin/anaconda", line 392 in ?
    intf.run(todo, test = test)
  ...
  File "/usr/lib/anaconda/fstab.py", line 800, in createDruid
    self.readOnly, ignoreBadDrives, self.expert)
TypeError: list of strings

Ok ->

install exited abnormally
...
you may safely reboot your system

Comment 1 Brock Organ 2000-06-18 05:07:59 UTC
verified this behavior ... when presenting an empty disk to the installer and
choosing to "upgrade", we receive an error dialog "An error has occured, no
valid devices were found ..." followed by the above traceback

because of the warning dialog before the traceback, this is not a bug (although
a more graceful exit would be appropriate ... and that is on our feature request
list for future releases)

thank you for the report!


Note You need to log in before you can comment on or make changes to this bug.