Bug 1234121 - After update Network manager loopback address 127.0.0.1 became unavailable
Summary: After update Network manager loopback address 127.0.0.1 became unavailable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1234478 1234760 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-21 13:40 UTC by Mikhail
Modified: 2015-10-04 22:52 UTC (History)
12 users (show)

Fixed In Version: NetworkManager-1.0.6-6.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-04 22:52:32 UTC


Attachments (Terms of Use)
sudo journalctl -u NetworkManager.service (290.07 KB, text/plain)
2015-06-23 10:07 UTC, Kostya Vasilyev
no flags Details
NetworkManager journal DEBUG (147.98 KB, text/plain)
2015-06-23 13:30 UTC, poma
no flags Details
# journalctl -u NetworkManager.service --no-pager -b > NM.log (1.47 MB, text/x-vhdl)
2015-06-23 14:13 UTC, Mikhail
no flags Details

Description Mikhail 2015-06-21 13:40:54 UTC
Description of problem:
After update Network manager loopback address 127.0.0.1 became unavailable


$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet6 fe80::200:ff:fe00:0/64 scope link 
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 94:de:80:6b:dd:24 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.6/24 brd 192.168.1.255 scope global dynamic enp2s0
       valid_lft 77384sec preferred_lft 77384sec
    inet6 2a02:1c8:109:593:96de:80ff:fe6b:dd24/64 scope global noprefixroute dynamic 
       valid_lft 603sec preferred_lft 603sec
    inet6 fe80::96de:80ff:fe6b:dd24/64 scope link 
       valid_lft forever preferred_lft forever
3: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 52:54:00:47:70:76 brd ff:ff:ff:ff:ff:ff
    inet 192.168.124.1/24 brd 192.168.124.255 scope global virbr0
       valid_lft forever preferred_lft forever
4: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 500
    link/ether 52:54:00:47:70:76 brd ff:ff:ff:ff:ff:ff


$ rpm -qa | grep NetworkManager
NetworkManager-openvpn-1.0.2-2.fc22.x86_64
NetworkManager-team-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-pptp-1.1.0-1.20150428git695d4f2.fc22.x86_64
NetworkManager-adsl-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-vpnc-1.0.2-1.fc22.x86_64
NetworkManager-openvpn-gnome-1.0.2-2.fc22.x86_64
NetworkManager-vpnc-gnome-1.0.2-1.fc22.x86_64
NetworkManager-glib-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-wwan-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-bluetooth-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-openconnect-1.0.2-1.fc22.x86_64
NetworkManager-pptp-gnome-1.1.0-1.20150428git695d4f2.fc22.x86_64
NetworkManager-libnm-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-config-connectivity-fedora-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64
NetworkManager-wifi-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64


same problem on i686 architecture.

Comment 1 Kostya Vasilyev 2015-06-22 09:51:14 UTC
Same here, this NetworkManager version was pulled in from @updates-testing.

Downgrading NetworkManager packages reverted the issue.

More info on while the bug was occurring:

- /etc/sysconfig/network-scripts/ifcfg-lo

continued to have IPADDR=127.0.0.1

and yet it was not there in "sudo ifconfig" after completed boot.

- "ifdown / ifup lo" in console would assign the expected 127..., so it's a boot time only issue

- I tried rebooting several times, and once boot was completed, the 127... was missing every time, so it wasn't a random one-time glitch.

Comment 2 Jirka Klimes 2015-06-23 07:51:38 UTC
*** Bug 1234478 has been marked as a duplicate of this bug. ***

Comment 3 Kostya Vasilyev 2015-06-23 10:07:11 UTC
Created attachment 1042203 [details]
sudo journalctl -u NetworkManager.service

After a reboot with [logging] level=DEBUG in NetworkManager.conf

Comment 4 Kostya Vasilyev 2015-06-23 10:09:39 UTC
As requested in 1234478:

*** 1 ***

This is the output of ip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet6 fe80::200:ff:fe00:0/64 scope link 
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: p2p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 60:a4:4c:ca:21:95 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.13/24 brd 192.168.1.255 scope global dynamic p2p1
       valid_lft 86364sec preferred_lft 86364sec
    inet6 fe80::62a4:4cff:feca:2195/64 scope link 
       valid_lft forever preferred_lft forever
3: virbr1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 52:54:00:ec:b0:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.1/24 brd 192.168.100.255 scope global virbr1
       valid_lft forever preferred_lft forever
4: virbr1-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr1 state DOWN group default qlen 500
    link/ether 52:54:00:ec:b0:28 brd ff:ff:ff:ff:ff:ff
5: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 52:54:00:a7:2c:73 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
6: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 500
    link/ether 52:54:00:a7:2c:73 brd ff:ff:ff:ff:ff:ff

p2p1 is my Ethernet, and virbr were probably added by virt-manager (I guess)

*** 2 ***

$cat /etc/sysconfig/network-scripts/ifcfg-lo 

DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback

*** 3 ***

The output of journalctl -u NetworkManager.service is attached above (1042203).

Comment 5 Kostya Vasilyev 2015-06-23 10:18:22 UTC
This line in the log looks interesting:

Jun 23 12:58:44 fiona NetworkManager[972]: <debug> [1435053524.141378] [NetworkManagerUtils.c:1911] monotonic_timestamp_get(): monotonic timestamp started counting 1.083743884 seconds ago with an offset of 8.0 seconds to CLOCK_BOOTTIME (local time is 2015-06-23 12:58:44)ip4_address_delete(): address: deleting IPv4 address 127.0.0.1/8, ifindex 1 dev lo

Interesting part:

ip4_address_delete(): address: deleting IPv4 address 127.0.0.1/8, ifindex 1 dev lo

( not sure why there are two log records, about ip4_address_delete and about monotonic_timestamp_get, mixed into one on a single line... )

Comment 6 poma 2015-06-23 13:30:08 UTC
Created attachment 1042333 [details]
NetworkManager journal DEBUG

Comment 7 Mikhail 2015-06-23 14:13:49 UTC
Created attachment 1042376 [details]
# journalctl -u NetworkManager.service --no-pager -b > NM.log

Comment 8 Marius Vollmer 2015-06-24 06:39:09 UTC
We are hitting the same bug.

I have two machines, both with

   NetworkManager-1.0.4-0.1.git20150618.8cffaf3bf5.fc22.x86_64

One comes up with lo properly configured, the other doesn't.  The immediate difference is:

   # nmcli d
  DEVICE  TYPE      STATE         CONNECTION 
  ens3    ethernet  connected     ens3       
  ens8    ethernet  disconnected  --         
  lo      loopback  unmanaged     --         

vs

  # nmcli d
  DEVICE  TYPE      STATE         CONNECTION  
  eth0    ethernet  connected     System eth0 
  lo      loopback  disconnected  --          

I.e., NetworkManager takes over lo on the broken machine and leaves it disconnected.

I don't know what causes this difference.  Config files and udev properties of /sys/class/net/lo seem to be the same, for example.

I'll be happy to figure this out by comparing the two machines more intelligently, of course, but I could use some help.

Comment 9 Jirka Klimes 2015-06-24 14:11:33 UTC
Thanks guys for testing and providing the info!
The issue is identified now and fixed. We will push a new update soon (hopefully today or tomorrow).

The build contained nm-1-0 branch up to commit 8cffaf3bf56b52458b5db8b0dbd9c27d6ddb17bc.
However, the fix is later in commit acb39d4b3190968d6f84bd229ac67325be479eff that was not included in the package.

Comment 10 Fedora Update System 2015-06-25 10:28:35 UTC
network-manager-applet-1.0.4-0.1.git20160615.28a0e28.fc22, NetworkManager-1.0.4-0.1.git20160624.f245b49a.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/network-manager-applet-1.0.4-0.1.git20160615.28a0e28.fc22,NetworkManager-1.0.4-0.1.git20160624.f245b49a.fc22

Comment 11 Erwan LE PENNEC 2015-06-25 12:15:16 UTC
*** Bug 1234760 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2015-06-26 06:42:38 UTC
Package network-manager-applet-1.0.4-0.1.git20160615.28a0e28.fc22, NetworkManager-1.0.4-0.1.git20160624.f245b49a.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-1.0.4-0.1.git20160615.28a0e28.fc22 NetworkManager-1.0.4-0.1.git20160624.f245b49a.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/network-manager-applet-1.0.4-0.1.git20160615.28a0e28.fc22,NetworkManager-1.0.4-0.1.git20160624.f245b49a.fc22
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2015-07-10 19:07:11 UTC
Package NetworkManager-1.0.4-0.3.git20150707.e3bd4e1.fc22, network-manager-applet-1.0.4-0.1.git20160702.25368df.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-1.0.4-0.3.git20150707.e3bd4e1.fc22 network-manager-applet-1.0.4-0.1.git20160702.25368df.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/NetworkManager-1.0.4-0.3.git20150707.e3bd4e1.fc22,network-manager-applet-1.0.4-0.1.git20160702.25368df.fc22
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2015-07-14 15:45:01 UTC
Package NetworkManager-1.0.4-0.4.git20150713.38bf2cb0.fc22, network-manager-applet-1.0.4-0.1.git20160702.25368df.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-1.0.4-0.4.git20150713.38bf2cb0.fc22 network-manager-applet-1.0.4-0.1.git20160702.25368df.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/NetworkManager-1.0.4-0.4.git20150713.38bf2cb0.fc22,network-manager-applet-1.0.4-0.1.git20160702.25368df.fc22
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-07-18 02:10:00 UTC
Package network-manager-applet-1.0.4-2.fc22, NetworkManager-1.0.4-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-1.0.4-2.fc22 NetworkManager-1.0.4-1.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/NetworkManager-1.0.4-1.fc22,network-manager-applet-1.0.4-2.fc22
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2015-07-29 01:58:25 UTC
Package network-manager-applet-1.0.4-2.fc22, NetworkManager-1.0.4-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-1.0.4-2.fc22 NetworkManager-1.0.4-2.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/NetworkManager-1.0.4-2.fc22,network-manager-applet-1.0.4-2.fc22
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2015-08-15 02:18:59 UTC
Package network-manager-applet-1.0.4-2.fc22, NetworkManager-1.0.6-0.1.20150813git7e2caa2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-1.0.4-2.fc22 NetworkManager-1.0.6-0.1.20150813git7e2caa2.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/NetworkManager-1.0.6-0.1.20150813git7e2caa2.fc22,network-manager-applet-1.0.4-2.fc22
then log in and leave karma (feedback).

Comment 18 Fedora Admin XMLRPC Client 2015-08-18 15:00:14 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 19 Fedora Update System 2015-08-19 08:08:08 UTC
Package network-manager-applet-1.0.4-2.fc22, NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-1.0.4-2.fc22 NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10143/NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22,network-manager-applet-1.0.4-2.fc22
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2015-08-22 02:52:15 UTC
NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22, network-manager-applet-1.0.4-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update NetworkManager network-manager-applet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 21 Fedora Update System 2015-08-23 01:49:13 UTC
NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc22, network-manager-applet-1.0.4-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update network-manager-applet NetworkManager'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 22 Fedora Update System 2015-09-02 16:21:47 UTC
NetworkManager-1.0.6-2.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update network-manager-applet NetworkManager-openvpn NetworkManager-vpnc NetworkManager NetworkManager-openswan'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 23 Fedora Update System 2015-09-08 11:14:38 UTC
NetworkManager-1.0.6-3.fc22 NetworkManager-openswan-1.0.6-2.fc22 NetworkManager-openvpn-1.0.6-3.fc22 NetworkManager-vpnc-1.0.6-3.fc22 network-manager-applet-1.0.6-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 24 Fedora Update System 2015-09-08 21:26:28 UTC
NetworkManager-1.0.6-4.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update network-manager-applet NetworkManager NetworkManager-openvpn NetworkManager-openswan NetworkManager-vpnc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 25 Fedora Update System 2015-09-28 21:00:26 UTC
NetworkManager-1.0.6-6.fc22 NetworkManager-openswan-1.0.6-2.fc22 NetworkManager-openvpn-1.0.6-3.fc22 NetworkManager-vpnc-1.0.6-3.fc22 network-manager-applet-1.0.6-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 26 Fedora Update System 2015-10-02 03:49:16 UTC
NetworkManager-1.0.6-6.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update NetworkManager-openswan network-manager-applet NetworkManager NetworkManager-openvpn NetworkManager-vpnc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10143

Comment 27 Fedora Update System 2015-10-04 22:52:01 UTC
NetworkManager-1.0.6-6.fc22, NetworkManager-openswan-1.0.6-2.fc22, NetworkManager-openvpn-1.0.6-3.fc22, NetworkManager-vpnc-1.0.6-3.fc22, network-manager-applet-1.0.6-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.