Bug 123422 - on AMD64, the events shown are suitable for Athlon not Athlon64
on AMD64, the events shown are suitable for Athlon not Athlon64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oprofile (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 09:55 EDT by David Monniaux
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-20 08:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Monniaux 2004-05-18 09:55:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6)
Gecko/20040116

Description of problem:
On Athlon64:
opcontrol --list-events lists the events for the Athlon processor but
not for the Athlon64.


Version-Release number of selected component (if applicable):
0.7cvs

How reproducible:
Always

Steps to Reproduce:
1.opcontrol --list-events
2.
3.
    

Actual Results:  The list of events for the Athlon.

Expected Results:  The list of events for the Athlon64 (as seen on the
oprofile web site:
http://oprofile.sourceforge.net/docs/amd-hammer-events.php3)

Additional info:
Comment 1 William Cohen 2004-05-20 08:57:42 EDT
The events for the AMD64 are a pure superset of the Athlon events. One
can still get measurements even with the processor being misidentified
as a regular Athlon. However oprofile will not have access to the
AMD64 specific events such as the ones related to the hypertransport
channels.

This problem is due to the kernel misidenting the processor. I have
verified this problem has been fixed in the kernel in Rawhide (FC2-test3).
Comment 2 David Monniaux 2004-05-20 09:04:44 EDT
I'm interested in FPU-related events.

Where is the misidentification problem? If this helps, the kernel
correctly prints in /proc/cpuinfo:
model name      : AMD Athlon(tm) 64 Processor 3200+
Comment 3 William Cohen 2004-05-20 09:23:07 EDT
The oprofile kernel driver has its own cpu identification code; it is
separate from the /proc/cpuinfo. In the case of the x86_64 it is going
to be in arch/i386/oprofile/nmi_int.c of the kernel.
Comment 4 William Cohen 2004-05-20 09:24:41 EDT
The oprofile driver provide the cpu identification information in
/dev/oprofile/cpu_type.

Note You need to log in before you can comment on or make changes to this bug.