Bug 1234222 - [WebUI] UI error message is not appropriate for "Kerberos principal expiration"
Summary: [WebUI] UI error message is not appropriate for "Kerberos principal expiration"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-22 06:05 UTC by Varun Mylaraiah
Modified: 2016-11-04 05:45 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:45:58 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Varun Mylaraiah 2015-06-22 06:05:06 UTC
Description of problem:
[WebUI] UI error message is not appropriate for "Kerberos principal expiration"

Version-Release number of selected component (if applicable):
ipa-server-4.1.0-18.el7_1.3.x86_64

How reproducible:
100%

Actual results:
Error message in UI is:  "The password or username you entered is incorrect".

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=887988#c22

Comment 3 Petr Vobornik 2015-06-22 16:04:07 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5077

Comment 5 Petr Vobornik 2016-04-15 16:03:04 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/2a20c746336f85c4a9bd095db242de11f0015903

Comment 7 Sudhir Menon 2016-08-01 13:10:02 UTC
Observations:
Set the Kerberos principal expiration date in UI for the user.
And then try to login to UI as user post that specified date/time.

On the UI:
Kerberos Principal you entered is expired.

httpd/error_log
[Mon Aug 01 18:36:57.290028 2016] [:error] [pid 6384] ipa: INFO: 401 Unauthorized: kinit: Client's entry in database has expired while getting initial credentials

Comment 9 errata-xmlrpc 2016-11-04 05:45:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.