Bug 1234223 - [WebUI] General invalid password error message appearing for "Locked user"
Summary: [WebUI] General invalid password error message appearing for "Locked user"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-22 06:07 UTC by Varun Mylaraiah
Modified: 2016-11-04 05:46 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:46:03 UTC


Attachments (Terms of Use)
evidence (312.91 KB, image/png)
2016-09-06 12:19 UTC, Pavel Picka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Varun Mylaraiah 2015-06-22 06:07:46 UTC
Description of problem:
UI error message is not appropriate for "Locked user"

Version-Release number of selected component (if applicable):
ipa-server-4.1.0-18.el7_1.3.x86_64

How reproducible:
100%

Steps to Reproduce:
added a user, and set pwd
kinit'd as this user incorrectly 7 time,s and user got locked

Actual results:
Error message in UI is:  "The password or username you entered is incorrect".

Comment 2 Petr Vobornik 2015-06-22 16:03:13 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5076

Comment 4 Martin Bašti 2016-04-28 15:05:49 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/3d07c889ce21ffe1d8baec3fd0c13bc67aa1d725

Comment 6 Pavel Picka 2016-09-06 12:19 UTC
Created attachment 1198211 [details]
evidence

Verified

4.4.0-8

Comment 8 errata-xmlrpc 2016-11-04 05:46:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.