Bug 1234293 - Having RHEVM network on a bonded VLAN together with other networks screws up network-config files
Summary: Having RHEVM network on a bonded VLAN together with other networks screws up ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.3
Hardware: All
OS: Linux
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Dan Kenigsberg
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On: 1203422 1249396 1249397
Blocks: 1242508
TreeView+ depends on / blocked
 
Reported: 2015-06-22 10:03 UTC by Martin Tessun
Modified: 2019-08-15 04:48 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1242508 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:42:19 UTC
oVirt Team: Network
Target Upstream Version:
myakove: needinfo+
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1527173 None None None Never
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC

Description Martin Tessun 2015-06-22 10:03:38 UTC
Description of problem:
Some mandatory interfaces for rhevm network are saves with "ONBOOT=no" when using unified network persistence

Version-Release number of selected component (if applicable):
vdsm-4.16*

How reproducible:
always

Steps to Reproduce:
1. Create a VLAN tagged rhevm-network
2. Create a VM network (also VLAN tagged)
3. In the host create the bond and assign the rhevm network and the VM network to it

Actual results:
The eth-interfaces and the bond-interface that is needed for the rhevm-VLAN is set to ONBOOT=no


Expected results:
The eth-interfaces and the bond that is needed for the rhevm network should stay in ONBOOT=yes

Additional info:

Assuming the following setup:

eth0 + eth1 ==> bond0 ==> bond0.100 ==> rhevm (bridge)
                      ||
                      ==> bond0.200 ==> vm_network (bridge)


Then vdsm first creates the rhevm-network correct and overwrites the config when creating the vm_network files:

MainThread::DEBUG::2015-06-17 09:50:29,561::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-rhevm configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=rhevm
TYPE=Bridge
DELAY=0
STP=off
ONBOOT=yes
IPADDR=192.168.122.2
NETMASK=255.255.255.0
GATEWAY=192.168.122.1
BOOTPROTO=none
MTU=1500
DEFROUTE=yes
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2015-06-17 09:50:29,812::utils::739::root::(execCmd) /sbin/ifdown rhevm (cwd None)
MainThread::DEBUG::2015-06-17 09:50:30,020::utils::759::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0
MainThread::DEBUG::2015-06-17 09:50:30,021::ifcfg::450::root::(_persistentBackup) backing up ifcfg-bond0.100: # original file did not exist

MainThread::DEBUG::2015-06-17 09:50:30,022::ifcfg::313::root::(writeBackupFile) Persistently backed up /var/lib/vdsm/netconfback/ifcfg-bond0.100 (until next 'set safe config')
MainThread::DEBUG::2015-06-17 09:50:30,022::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-bond0.100 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=bond0.100
VLAN=yes
BRIDGE=rhevm
ONBOOT=yes
MTU=1500
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2015-06-17 09:50:30,034::ifcfg::374::root::(_atomicBackup) Backed up /etc/sysconfig/network-scripts/ifcfg-bond0
MainThread::DEBUG::2015-06-17 09:50:30,035::ifcfg::450::root::(_persistentBackup) backing up ifcfg-bond0: DEVICE=bond0
BOOTPROTO=none
TYPE=Bonding
ONBOOT=yes
NM_CONTROLLED=no
BONDING_OPTS='mode=802.3ad miimon=300 lacp_rate=0'

MainThread::DEBUG::2015-06-17 09:50:30,035::ifcfg::313::root::(writeBackupFile) Persistently backed up /var/lib/vdsm/netconfback/ifcfg-bond0 (until next 'set safe config')
MainThread::DEBUG::2015-06-17 09:50:30,036::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-bond0 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=bond0
BONDING_OPTS='mode=802.3ad miimon=300 lacp_rate=0'
ONBOOT=yes
MTU=1500
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2015-06-17 09:50:30,040::utils::739::root::(execCmd) /sbin/ifdown eth0 (cwd None)
MainThread::DEBUG::2015-06-17 09:50:30,706::utils::759::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0
MainThread::DEBUG::2015-06-17 09:50:30,707::utils::739::root::(execCmd) /sbin/ifdown eth1 (cwd None)
MainThread::DEBUG::2015-06-17 09:50:31,370::utils::759::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0
MainThread::DEBUG::2015-06-17 09:50:31,399::ifcfg::374::root::(_atomicBackup) Backed up /etc/sysconfig/network-scripts/ifcfg-eth0
MainThread::DEBUG::2015-06-17 09:50:31,399::ifcfg::450::root::(_persistentBackup) backing up ifcfg-eth0: DEVICE=eth0
HWADDR=AB:CD:EF:AB:CD:EF
BOOTPROTO=none
TYPE=Ethernet
ONBOOT=yes
NM_CONTROLLED=no
USERCTL=no
MASTER=bond0
SLAVE=yes

MainThread::DEBUG::2015-06-17 09:50:31,400::ifcfg::313::root::(writeBackupFile) Persistently backed up /var/lib/vdsm/netconfback/ifcfg-eth0 (until next 'set safe config')
MainThread::DEBUG::2015-06-17 09:50:31,400::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-eth0 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=eth0
HWADDR=ab:cd:ef:ab:cd:ef
MASTER=bond0
SLAVE=yes
ONBOOT=yes
MTU=1500
NM_CONTROLLED=no

MainThread::DEBUG::2015-06-17 09:50:31,429::ifcfg::374::root::(_atomicBackup) Backed up /etc/sysconfig/network-scripts/ifcfg-eth1
MainThread::DEBUG::2015-06-17 09:50:31,430::ifcfg::450::root::(_persistentBackup) backing up ifcfg-eth1: DEVICE=eth1
HWADDR=AB:CD:EF:12:34:56
BOOTPROTO=none
TYPE=Ethernet
ONBOOT=yes
NM_CONTROLLED=no
USERCTL=no
MASTER=bond0
SLAVE=yes

MainThread::DEBUG::2015-06-17 09:50:31,431::ifcfg::313::root::(writeBackupFile) Persistently backed up /var/lib/vdsm/netconfback/ifcfg-eth1 (until next 'set safe config')
MainThread::DEBUG::2015-06-17 09:50:31,431::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-eth1 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=eth1
HWADDR=ab:cd:ef:12:34:56
MASTER=bond0
SLAVE=yes
ONBOOT=yes
MTU=1500
NM_CONTROLLED=no

[...]

MainThread::DEBUG::2015-06-17 09:50:39,019::api::691::setupNetworks::(setupNetworks) Adding network 'vm_network'
MainThread::DEBUG::2015-06-17 09:50:39,020::api::278::root::(addNetwork) validating network...
MainThread::INFO::2015-06-17 09:50:39,020::api::300::root::(addNetwork) Adding network avm_network with vlan=200, bonding=bond0, nics=[u'eth0', u'eth1'], bondingOptions=mode=802.3ad miimon=300 lacp_rate=0, mtu=1500, bridged=True, defaultRoute=False,options={u'stp': False, 'implicitBonding': True}
MainThread::DEBUG::2015-06-17 09:50:39,021::ifcfg::450::root::(_persistentBackup) backing up ifcfg-vm_network: # original file did not exist

MainThread::DEBUG::2015-06-17 09:50:39,022::ifcfg::313::root::(writeBackupFile) Persistently backed up /var/lib/vdsm/netconfback/ifcfg-vm_network (until next 'set safe config')
MainThread::DEBUG::2015-06-17 09:50:39,022::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-vm_network configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=vm_network
TYPE=Bridge
DELAY=0
STP=off
ONBOOT=no
MTU=1500
DEFROUTE=no
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2015-06-17 09:50:39,024::utils::739::root::(execCmd) /sbin/ifdown vm_network (cwd None)
MainThread::DEBUG::2015-06-17 09:50:39,230::utils::759::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0
MainThread::DEBUG::2015-06-17 09:50:39,231::ifcfg::450::root::(_persistentBackup) backing up ifcfg-bond0.200: # original file did not exist

MainThread::DEBUG::2015-06-17 09:50:39,232::ifcfg::313::root::(writeBackupFile) Persistently backed up /var/lib/vdsm/netconfback/ifcfg-bond0.200 (until next 'set safe config')
MainThread::DEBUG::2015-06-17 09:50:39,232::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-bond0.200 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=bond0.200
VLAN=yes
BRIDGE=vm_network
ONBOOT=no
MTU=1500
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2015-06-17 09:50:39,241::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-bond0 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=bond0
BONDING_OPTS='mode=802.3ad miimon=300 lacp_rate=0'
ONBOOT=no
MTU=1500
NM_CONTROLLED=no
HOTPLUG=no

MainThread::DEBUG::2015-06-17 09:50:39,296::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-eth0 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=eth0
HWADDR=ab:cd:ef:ab:cd:ef
MASTER=bond0
SLAVE=yes
ONBOOT=no
MTU=1500
NM_CONTROLLED=no

MainThread::DEBUG::2015-06-17 09:50:39,346::ifcfg::550::root::(writeConfFile) Writing to file /etc/sysconfig/network-scripts/ifcfg-eth1 configuration:
# Generated by VDSM version 4.16.20-1.el6ev
DEVICE=eth1
HWADDR=ab:cd:ef:12:34:56
MASTER=bond0
SLAVE=yes
ONBOOT=no
MTU=1500
NM_CONTROLLED=no

MainThread::DEBUG::2015-06-17 09:50:39,348::utils::739::root::(execCmd) /sbin/ifup bond0 (cwd None)
MainThread::DEBUG::2015-06-17 09:50:39,604::utils::759::root::(execCmd) SUCCESS: <err> = ''; <rc> = 0

As can be seen the later configured vm_network rewrites the configs for bond0, eth0 and eth1, putting a "ONBOOT=no" in there now. This should not be the case, as eth0,1 and bond0 are needed by the rhevm network and should therefore stay in the previously generated config with "ONBOOT=yes".

Comment 2 Fabian Deutsch 2015-06-22 12:15:03 UTC
On what kind of host did you see this issue - RHEL-H or RHEV-H?

Comment 3 Martin Tessun 2015-06-22 12:17:54 UTC
Hi Fabian,

sorry, forgot to mention that. This issue has been observed on a RHEL-H system.

Comment 5 Ido Barkan 2015-07-12 19:15:42 UTC
the work that is being done for https://bugzilla.redhat.com/show_bug.cgi?id=1203422 will solve this bug ,as from 3.5.4 VDSM will create all ifcfg files with ONBOOT=yes.

Comment 8 Michael Burman 2015-07-23 14:29:34 UTC
Verified on 3.6.0-0.0.master.20150627185750.git6f063c1.el6 with vdsm-4.17.0-1054.git562e711.el7.noarch

[root@orchid-vds1 ~]# brctl show
bridge name     bridge id               STP enabled     interfaces
;vdsmdummy;             8000.000000000000       no
m1              8000.00145e17d5b0       no              bond0.168
ovirtmgmt               8000.00145e17d5b0       no              bond0.162
virbr0          8000.5254009bfc0a       yes             virbr0-nic


[root@orchid-vds1 ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond0.168
# Generated by VDSM version 4.17.0-1054.git562e711.el7
DEVICE=bond0.168
VLAN=yes
BRIDGE=m1
ONBOOT=yes
MTU=1500
NM_CONTROLLED=no
IPV6INIT=no
HOTPLUG=no

[root@orchid-vds1 ~]# cat /etc/sysconfig/network-scripts/ifcfg-m1 
# Generated by VDSM version 4.17.0-1054.git562e711.el7
DEVICE=m1
TYPE=Bridge
DELAY=0
STP=off
ONBOOT=yes
MTU=1500
DEFROUTE=no
NM_CONTROLLED=no
IPV6INIT=no
HOTPLUG=no


Restarted network service with success and rebooted server with success, all network configuration kept. Server is UP in rhev-M.

Comment 12 errata-xmlrpc 2016-03-09 19:42:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.