This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 123430 - s-c-desktop warning
s-c-desktop warning
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 11:03 EDT by Chris Ricker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 16:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2004-05-18 11:03:41 EDT
After running s-c-desktop, I see on stdout:

Window manager warning: Working around an application which called
XSetInputFocus (None) or with RevertToNone instead of
RevertToPointerRoot, this is a minor bug in some application.

This is 1.0.14-1
Comment 1 Brent Fox 2004-06-15 11:03:12 EDT
Hmm...I don't see this on my test machines.  What version of metacity
are you running?

Havoc, what does this message mean?  As far as I know,
system-config-display isn't doing anything besides just forking
metacity to provide some window management functions.
Comment 2 Chris Ricker 2004-06-15 11:07:18 EDT
that was stock FC2, so it should be metacity-2.8.1-2
Comment 3 Havoc Pennington 2004-06-15 16:03:07 EDT
Message means what it says - some app called XSetInputFocus(None) or
with RevertToNone. gdk_window_focus (NULL) may do this, I'm not sure.

Metacity doesn't know which app did it though, so can't print out the
blame.

It's possible this could be a metacity bug/confusion, but probably not
likely.

Anyway, the bug is minor in most cases. Basically if the focus ends up
set to None then you can't use your keyboard anymore (this is major),
but it ends up minor since metacity moves the focus back somewhere.
Comment 4 Brent Fox 2004-06-23 16:16:29 EDT
Since I'm unable to reproduce this on my test machines, I'm going to
assume that some other application triggered this message from
metacity.  Closing as 'worksforme'

Note You need to log in before you can comment on or make changes to this bug.