Bug 1234317 - CD / DVD are rarely automounted
CD / DVD are rarely automounted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-22 07:25 EDT by antonio montagnani
Modified: 2016-08-14 07:30 EDT (History)
18 users (show)

See Also:
Fixed In Version: util-linux-2.28-2.fc23 util-linux-2.28-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 19:25:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (13.40 KB, text/plain)
2016-06-13 06:16 EDT, srakitnican
no flags Details

  None (edit)
Description antonio montagnani 2015-06-22 07:25:33 EDT
Description of problem:
after a long time I inserted CD/DVD on my Fedoras

Version-Release number of selected component (if applicable):
nautilus-3.16.2-1.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1.insert CD/DVD
2.
3.

Actual results:
no automount

Expected results:
it shoulb be auto-mounted

Additional info:
Burning a CD or a DVD works fine
Comment 1 Joachim Backes 2015-06-22 07:52:21 EDT
Same on my F22 box.
Comment 2 antonio montagnani 2015-06-26 07:27:04 EDT
naturally if I.....

su
Password: 
[root@Fujiantonio antonio]# mount -t iso9660 /dev/cdrom /media/
mount: /dev/sr0 is write-protected, mounting read-only

I can read all Files.

What is going on???
Comment 3 antonio montagnani 2015-06-26 07:33:07 EDT
output of dmesg.....

[  975.385089] systemd-sysv-generator[4410]: Overwriting existing symlink /run/systemd/generator.late/network.service with real service
[  975.385253] systemd-sysv-generator[4410]: Overwriting existing symlink /run/systemd/generator.late/netconsole.service with real service
[ 1143.309270] sr 2:0:0:0: [sr0] tag#28 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1143.309278] sr 2:0:0:0: [sr0] tag#28 Sense Key : Illegal Request [current] 
[ 1143.309285] sr 2:0:0:0: [sr0] tag#28 Add. Sense: Illegal mode for this track
[ 1143.309290] sr 2:0:0:0: [sr0] tag#28 CDB: Read(10) 28 00 00 04 c6 8a 00 00 02 00
[ 1143.309294] blk_update_request: I/O error, dev sr0, sector 1251880
[ 1143.646557] sr 2:0:0:0: [sr0] tag#29 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1143.646566] sr 2:0:0:0: [sr0] tag#29 Sense Key : Illegal Request [current] 
[ 1143.646572] sr 2:0:0:0: [sr0] tag#29 Add. Sense: Illegal mode for this track
[ 1143.646578] sr 2:0:0:0: [sr0] tag#29 CDB: Read(10) 28 00 00 04 c6 8a 00 00 02 00
[ 1143.646582] blk_update_request: I/O error, dev sr0, sector 1251880
[ 1143.646587] Buffer I/O error on dev sr0, logical block 156485, async page read
[ 1568.806207] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 1568.948005] ISO 9660 Extensions: RRIP_1991A
Comment 4 antonio montagnani 2015-06-26 07:42:31 EDT
and this is my fstab:


#
# /etc/fstab
# Created by anaconda on Wed Mar 12 20:05:16 2014
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora-root /                       ext4    defaults        1 1
UUID=ee7fed51-1613-4cd8-a5da-6b7f5aca49d6 /boot                   ext4    defaults        1 2
UUID=DEA9-8899          /boot/efi               vfat    umask=0077,shortname=winnt 0 0
/dev/mapper/fedora-home /home                   ext4    defaults        1 2
/dev/mapper/fedora-swap swap                    swap    defaults        0 0
Comment 5 antonio montagnani 2015-06-28 10:57:47 EDT
with reference to comment #3 the last two lines are when I issued the mount command from terminal, previous are reported errors when using Nautilus I suppose
Comment 6 antonio montagnani 2015-07-03 01:50:13 EDT
For your info, if useful, my two systems are not fresh installations but fedupped from 21
Comment 7 Joachim Backes 2015-07-03 02:06:27 EDT
(In reply to antonio montagnani from comment #6)
> For your info, if useful, my two systems are not fresh installations but
> fedupped from 21

Sorry, but my system is not fedupped, but a fresh install.

Manually mounting is a (not so good) workaround for me.
Comment 8 antonio montagnani 2015-07-13 11:38:18 EDT
no improvement in twenty days: I am surprised (at least)
Comment 9 antonio montagnani 2015-07-17 13:28:42 EDT
it seems that this bug is underscored :-( . I do not see any activity on that, no info request, nothing. From surprised switching to disappointed
Comment 10 antonio montagnani 2015-07-30 02:02:17 EDT
I guess that the bug is not strictly connected to Nautilus, as different file manager (PCMan) has same results. No idea what other component must be blamed
Comment 11 Joachim Backes 2015-07-30 04:36:50 EDT
My drive is a SATA dvd drive.

Perhaps the info's I receiving by udevadm helps?

udevadm info -q path --name sr0

/devices/pci0000:00/0000:00:1c.4/0000:03:00.0/ata6/host5/target5:0:0/5:0:0:0/block/sr0

udevadm test /devices/pci0000:00/0000:00:1c.4/0000:03:00.0/ata6/host5/target5:0:0/5:0:0:0/block/sr0

calling: test
version 219
This program is for debugging only, it does not run any program
specified by a RUN key. It may show incorrect results, because
some values may be different, or not available at a simulation run.

=== trie on-disk ===
tool version:          219
file size:         6948435 bytes
header size             80 bytes
strings            1757067 bytes
nodes              5191288 bytes
Load module index
timestamp of '/usr/lib/systemd/network' changed
Parsed configuration file /usr/lib/systemd/network/99-default.link
Created link configuration context.
timestamp of '/etc/udev/rules.d' changed
timestamp of '/usr/lib/udev/rules.d' changed
Reading rules file: /usr/lib/udev/rules.d/10-dm.rules
Reading rules file: /usr/lib/udev/rules.d/11-dm-lvm.rules
Reading rules file: /usr/lib/udev/rules.d/11-dm-mpath.rules
Reading rules file: /usr/lib/udev/rules.d/13-dm-disk.rules
Reading rules file: /usr/lib/udev/rules.d/20-crystalhd.rules
Reading rules file: /usr/lib/udev/rules.d/39-usbmuxd.rules
Reading rules file: /usr/lib/udev/rules.d/40-libgphoto2.rules
IMPORT found builtin 'usb_id --export %%p', replacing /usr/lib/udev/rules.d/40-libgphoto2.rules:11
Reading rules file: /usr/lib/udev/rules.d/40-usb-media-players.rules
Reading rules file: /usr/lib/udev/rules.d/40-usb_modeswitch.rules
Reading rules file: /usr/lib/udev/rules.d/42-usb-hid-pm.rules
Reading rules file: /usr/lib/udev/rules.d/50-udev-default.rules
Reading rules file: /usr/lib/udev/rules.d/56-hpmud.rules
Reading rules file: /usr/lib/udev/rules.d/60-cdrom_id.rules
Reading rules file: /usr/lib/udev/rules.d/60-drm.rules
Reading rules file: /usr/lib/udev/rules.d/60-ffado.rules
Reading rules file: /usr/lib/udev/rules.d/60-fprint-autosuspend.rules
Reading rules file: /usr/lib/udev/rules.d/60-keyboard.rules
Reading rules file: /usr/lib/udev/rules.d/60-net.rules
Reading rules file: /usr/lib/udev/rules.d/60-pcmcia.rules
Reading rules file: /usr/lib/udev/rules.d/60-persistent-alsa.rules
Reading rules file: /usr/lib/udev/rules.d/60-persistent-input.rules
Reading rules file: /usr/lib/udev/rules.d/60-persistent-serial.rules
Reading rules file: /usr/lib/udev/rules.d/60-persistent-storage-tape.rules
Reading rules file: /usr/lib/udev/rules.d/60-persistent-storage.rules
Reading rules file: /usr/lib/udev/rules.d/60-persistent-v4l.rules
Reading rules file: /usr/lib/udev/rules.d/60-raw.rules
Reading rules file: /etc/udev/rules.d/60-vboxdrv.rules
Reading rules file: /usr/lib/udev/rules.d/61-accelerometer.rules
Reading rules file: /usr/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
Reading rules file: /usr/lib/udev/rules.d/61-gnome-settings-daemon-rfkill.rules
Reading rules file: /usr/lib/udev/rules.d/61-kde-bluetooth-rfkill.rules
Reading rules file: /usr/lib/udev/rules.d/62-multipath.rules
Reading rules file: /usr/lib/udev/rules.d/63-md-raid-arrays.rules
Reading rules file: /usr/lib/udev/rules.d/64-btrfs.rules
Reading rules file: /usr/lib/udev/rules.d/64-md-raid-assembly.rules
Reading rules file: /usr/lib/udev/rules.d/65-libwacom.rules
Reading rules file: /usr/lib/udev/rules.d/65-md-incremental.rules
Reading rules file: /usr/lib/udev/rules.d/65-sane-backends.rules
Reading rules file: /usr/lib/udev/rules.d/69-cd-sensors.rules
Reading rules file: /usr/lib/udev/rules.d/69-dm-lvm-metad.rules
Reading rules file: /usr/lib/udev/rules.d/69-libftdi.rules
Reading rules file: /usr/lib/udev/rules.d/69-libmtp.rules
Reading rules file: /usr/lib/udev/rules.d/69-pilot-link.rules
Reading rules file: /usr/lib/udev/rules.d/69-xorg-vmmouse.rules
Reading rules file: /usr/lib/udev/rules.d/70-mouse.rules
Reading rules file: /usr/lib/udev/rules.d/70-power-switch.rules
Reading rules file: /usr/lib/udev/rules.d/70-printers.rules
Reading rules file: /usr/lib/udev/rules.d/70-spice-vdagentd.rules
Reading rules file: /usr/lib/udev/rules.d/70-touchpad-quirks.rules
Reading rules file: /usr/lib/udev/rules.d/70-touchpad.rules
Reading rules file: /usr/lib/udev/rules.d/70-uaccess.rules
Reading rules file: /usr/lib/udev/rules.d/70-wacom.rules
Reading rules file: /usr/lib/udev/rules.d/71-seat.rules
Reading rules file: /usr/lib/udev/rules.d/73-seat-late.rules
Reading rules file: /usr/lib/udev/rules.d/75-net-description.rules
Reading rules file: /usr/lib/udev/rules.d/75-probe_mtd.rules
Reading rules file: /usr/lib/udev/rules.d/75-tty-description.rules
Reading rules file: /usr/lib/udev/rules.d/78-sound-card.rules
Reading rules file: /usr/lib/udev/rules.d/80-drivers.rules
Reading rules file: /usr/lib/udev/rules.d/80-kvm.rules
Reading rules file: /usr/lib/udev/rules.d/80-libinput-device-groups.rules
Reading rules file: /usr/lib/udev/rules.d/80-net-setup-link.rules
Reading rules file: /usr/lib/udev/rules.d/80-udisks.rules
Reading rules file: /usr/lib/udev/rules.d/80-udisks2.rules
Reading rules file: /usr/lib/udev/rules.d/85-nm-unmanaged.rules
Reading rules file: /usr/lib/udev/rules.d/85-regulatory.rules
Reading rules file: /usr/lib/udev/rules.d/90-alsa-restore.rules
Reading rules file: /usr/lib/udev/rules.d/90-libgpod.rules
Reading rules file: /usr/lib/udev/rules.d/90-libinput-model-quirks.rules
Reading rules file: /usr/lib/udev/rules.d/90-pulseaudio.rules
Reading rules file: /usr/lib/udev/rules.d/90-vconsole.rules
Reading rules file: /etc/udev/rules.d/90-wireshark-usbmon.rules
Reading rules file: /usr/lib/udev/rules.d/91-drm-modeset.rules
Reading rules file: /usr/lib/udev/rules.d/95-cd-devices.rules
Reading rules file: /usr/lib/udev/rules.d/95-dm-notify.rules
Reading rules file: /usr/lib/udev/rules.d/95-udev-late.rules
Reading rules file: /usr/lib/udev/rules.d/95-upower-csr.rules
Reading rules file: /usr/lib/udev/rules.d/95-upower-hid.rules
Reading rules file: /usr/lib/udev/rules.d/95-upower-wup.rules
Reading rules file: /usr/lib/udev/rules.d/98-kexec.rules
Reading rules file: /usr/lib/udev/rules.d/99-qemu-guest-agent.rules
Reading rules file: /usr/lib/udev/rules.d/99-systemd.rules
Reading rules file: /etc/udev/rules.d/canon-scanner.rules
rules contain 393216 bytes tokens (32768 * 12 bytes), 32965 bytes strings
31957 strings (260624 bytes), 28771 de-duplicated (230846 bytes), 3187 trie nodes used
GROUP 6 /usr/lib/udev/rules.d/50-udev-default.rules:52
GROUP 11 /usr/lib/udev/rules.d/50-udev-default.rules:53
IMPORT builtin 'usb_id' /usr/lib/udev/rules.d/56-hpmud.rules:10
unable to access usb_interface device of '/sys/devices/pci0000:00/0000:00:1c.4/0000:03:00.0/ata6/host5/target5:0:0/5:0:0:0/block/sr0'
IMPORT builtin 'usb_id' returned non-zero
IMPORT 'cdrom_id --lock-media /dev/sr0' /usr/lib/udev/rules.d/60-cdrom_id.rules:16
starting 'cdrom_id --lock-media /dev/sr0'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_CD=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_CD_R=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_CD_RW=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD_R=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD_RW=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD_RAM=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD_PLUS_R=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD_PLUS_RW=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_DVD_PLUS_R_DL=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_MEDIA=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_MEDIA_CD_RW=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_MEDIA_STATE=complete'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_MEDIA_SESSION_COUNT=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_MEDIA_TRACK_COUNT=1'
'cdrom_id --lock-media /dev/sr0'(out) 'ID_CDROM_MEDIA_TRACK_COUNT_DATA=1'
'cdrom_id --lock-media /dev/sr0' [21152] exit with return code 0
LINK 'cdrom' /usr/lib/udev/rules.d/60-cdrom_id.rules:23
IMPORT 'ata_id --export /dev/sr0' /usr/lib/udev/rules.d/60-persistent-storage.rules:32
starting 'ata_id --export /dev/sr0'
'ata_id --export /dev/sr0'(out) 'ID_ATA=1'
'ata_id --export /dev/sr0'(out) 'ID_TYPE=cd'
'ata_id --export /dev/sr0'(out) 'ID_BUS=ata'
'ata_id --export /dev/sr0'(out) 'ID_MODEL=HL-DT-ST_DVDRAM_GH20NS15'
'ata_id --export /dev/sr0'(out) 'ID_MODEL_ENC=HL-DT-ST\x20DVDRAM\x20GH20NS15\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20'
'ata_id --export /dev/sr0'(out) 'ID_REVISION=IL00'
'ata_id --export /dev/sr0'(out) 'ID_SERIAL=HL-DT-ST_DVDRAM_GH20NS15_K0488I00112'
'ata_id --export /dev/sr0'(out) 'ID_SERIAL_SHORT=K0488I00112'
'ata_id --export /dev/sr0'(out) 'ID_ATA_FEATURE_SET_PM=1'
'ata_id --export /dev/sr0'(out) 'ID_ATA_FEATURE_SET_PM_ENABLED=0'
'ata_id --export /dev/sr0' [21153] exit with return code 0
LINK 'disk/by-id/ata-HL-DT-ST_DVDRAM_GH20NS15_K0488I00112' /usr/lib/udev/rules.d/60-persistent-storage.rules:42
IMPORT builtin 'path_id' /usr/lib/udev/rules.d/60-persistent-storage.rules:55
IMPORT builtin 'path_id' returned non-zero
IMPORT builtin 'blkid' /usr/lib/udev/rules.d/60-persistent-storage.rules:67
probe /dev/sr0 noraid offset=0
IMPORT builtin 'blkid' returned non-zero
PROGRAM '/sbin/multipath -c /dev/sr0' /usr/lib/udev/rules.d/62-multipath.rules:15
starting '/sbin/multipath -c /dev/sr0'
'/sbin/multipath -c /dev/sr0'(err) 'need to be root'
'/sbin/multipath -c /dev/sr0' [21154] exit with return code 1
IMPORT builtin skip 'path_id' /usr/lib/udev/rules.d/71-seat.rules:43
no db file to read /run/udev/data/+scsi:5:0:0:0: No such file or directory
RUN 'uaccess' /usr/lib/udev/rules.d/73-seat-late.rules:15
IMPORT 'udisks-part-id /dev/sr0' /usr/lib/udev/rules.d/80-udisks.rules:88
starting 'udisks-part-id /dev/sr0'
'udisks-part-id /dev/sr0'(err) 'using device_file=/dev/sr0 syspath=/sys/devices/pci0000:00/0000:00:1c.4/0000:03:00.0/ata6/host5/target5:0:0/5:0:0:0/block/sr0, offset=0 ao=0 and number=0 for /dev/sr0'
'udisks-part-id /dev/sr0'(err) 'Entering MS-DOS parser (offset=0, size=78647296)'
'udisks-part-id /dev/sr0'(err) 'MSDOS_MAGIC found'
'udisks-part-id /dev/sr0'(err) 'looking at part 0 (offset 0, size 314572800, type 0x17)'
'udisks-part-id /dev/sr0'(err) 'new part entry'
'udisks-part-id /dev/sr0'(err) 'looking at part 1 (offset 0, size 0, type 0x00)'
'udisks-part-id /dev/sr0'(err) 'new part entry'
'udisks-part-id /dev/sr0'(err) 'looking at part 2 (offset 0, size 0, type 0x00)'
'udisks-part-id /dev/sr0'(err) 'new part entry'
'udisks-part-id /dev/sr0'(err) 'looking at part 3 (offset 0, size 0, type 0x00)'
'udisks-part-id /dev/sr0'(err) 'new part entry'
'udisks-part-id /dev/sr0'(err) 'Exiting MS-DOS parser'
'udisks-part-id /dev/sr0'(err) 'MSDOS partition table detected'
'udisks-part-id /dev/sr0'(out) 'UDISKS_PARTITION_TABLE=1'
'udisks-part-id /dev/sr0'(out) 'UDISKS_PARTITION_TABLE_SCHEME=mbr'
'udisks-part-id /dev/sr0'(out) 'UDISKS_PARTITION_TABLE_COUNT=0'
'udisks-part-id /dev/sr0' [21155] exit with return code 0
update old name, '/dev/disk/by-id/wwn-0x48005001' no longer belonging to '/devices/pci0000:00/0000:00:1c.4/0000:03:00.0/ata6/host5/target5:0:0/5:0:0:0/block/sr0'
found 'b11:0' claiming '/run/udev/links/\x2fdisk\x2fby-id\x2fwwn-0x48005001'
no reference left, remove '/dev/disk/by-id/wwn-0x48005001'
handling device node '/dev/sr0', devnum=b11:0, mode=0660, uid=0, gid=11
preserve permissions /dev/sr0, 060660, uid=0, gid=11
preserve already existing symlink '/dev/block/11:0' to '../sr0'
found 'b11:0' claiming '/run/udev/links/\x2fcdrom'
creating link '/dev/cdrom' to '/dev/sr0'
preserve already existing symlink '/dev/cdrom' to 'sr0'
found 'b11:0' claiming '/run/udev/links/\x2fdisk\x2fby-id\x2fata-HL-DT-ST_DVDRAM_GH20NS15_K0488I00112'
creating link '/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH20NS15_K0488I00112' to '/dev/sr0'
preserve already existing symlink '/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH20NS15_K0488I00112' to '../../sr0'
unable to create temporary db file '/run/udev/data/b11:0.tmp': Permission denied
.ID_FS_TYPE_NEW=
ACTION=add
DEVLINKS=/dev/cdrom /dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH20NS15_K0488I00112
DEVNAME=/dev/sr0
DEVPATH=/devices/pci0000:00/0000:00:1c.4/0000:03:00.0/ata6/host5/target5:0:0/5:0:0:0/block/sr0
DEVTYPE=disk
ID_ATA=1
ID_ATA_FEATURE_SET_PM=1
ID_ATA_FEATURE_SET_PM_ENABLED=0
ID_BUS=ata
ID_CDROM=1
ID_CDROM_CD=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_PLUS_R=1
ID_CDROM_DVD_PLUS_RW=1
ID_CDROM_DVD_PLUS_R_DL=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RAM=1
ID_CDROM_DVD_RW=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_CD_RW=1
ID_CDROM_MEDIA_SESSION_COUNT=1
ID_CDROM_MEDIA_STATE=complete
ID_CDROM_MEDIA_TRACK_COUNT=1
ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
ID_FS_TYPE=
ID_MODEL=HL-DT-ST_DVDRAM_GH20NS15
ID_MODEL_ENC=HL-DT-ST\x20DVDRAM\x20GH20NS15\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20
ID_REVISION=IL00
ID_SERIAL=HL-DT-ST_DVDRAM_GH20NS15_K0488I00112
ID_SERIAL_SHORT=K0488I00112
ID_TYPE=cd
MAJOR=11
MINOR=0
MPATH_SBIN_PATH=/sbin
SUBSYSTEM=block
TAGS=:seat:systemd:uaccess:
UDISKS_PARTITION_TABLE=1
UDISKS_PARTITION_TABLE_COUNT=0
UDISKS_PARTITION_TABLE_SCHEME=mbr
UDISKS_PRESENTATION_NOPOLICY=0
USEC_INITIALIZED=376222
run: 'uaccess'
Unload module index
Unloaded link configuration context.
backes@eule [~/Desktop]:
Comment 12 Joachim Backes 2015-08-30 06:47:49 EDT
(In reply to Joachim Backes from comment #1)
> Same on my F22 box.

Same on my F23 box!
Comment 13 eagleton 2015-09-24 14:43:12 EDT
The problem is not Fedora specific - it also affects Antergos, an Arch Linux derivative. I suspect the latest openSUSE has this too, but I haven't tested it systematically. Fedora 21 and Ubuntu 14.04 definitely recognized all my CDS and DVDs.
Comment 14 Joachim Backes 2015-09-25 01:06:47 EDT
Is there is some connection with

https://bugzilla.redhat.com/show_bug.cgi?id=1249286 ?
Comment 15 eagleton 2015-09-25 04:45:31 EDT
Have you tested other file managers? This bug here happens with different file managers, so I'm not sure.
Comment 16 Joachim Backes 2015-09-25 05:10:22 EDT
(In reply to eagleton from comment #15)
> Have you tested other file managers? This bug here happens with different
> file managers, so I'm not sure.

Same with thunar!
Comment 17 antonio montagnani 2015-09-25 10:29:15 EDT
(In reply to Joachim Backes from comment #16)
> (In reply to eagleton from comment #15)
> > Have you tested other file managers? This bug here happens with different
> > file managers, so I'm not sure.
> 
> Same with thunar!

same here. In any case it is not the file manager to mount/umount devices ;-)
Comment 18 eagleton 2015-09-26 15:04:44 EDT
Putting this into my /etc/fstab mounts the CD, but still my DVD drive does not show up in the file manager:
/dev/cdrom  /mnt/cdrom   iso9660 auto,user          0 0
Comment 19 antonio montagnani 2015-09-27 03:40:18 EDT
(In reply to eagleton from comment #18)
> Putting this into my /etc/fstab mounts the CD, but still my DVD drive does
> not show up in the file manager:
> /dev/cdrom  /mnt/cdrom   iso9660 auto,user          0 0

did you try using /dev/sr0 instead??

Should it be mounted in /media or in /mnt??
Comment 20 eagleton 2015-09-27 04:05:56 EDT
Haven't tried this, I would expect the same results using sr0 though. I made a bookmark in Nautilus for convenience, so it's relatively comfortable, but still only a workaround.

I also tried an older kernel in Antergos: 4.1.7 showed the same problem.
Comment 21 eagleton 2015-09-27 04:11:36 EDT
Of course it was not 4.1.7, it should have been 3.14.52.
Comment 22 eagleton 2015-10-17 06:37:13 EDT
It's working again on Antergos/Arch, not sure why - possibly an update of systemd?
Comment 23 Joachim Backes 2015-10-17 06:41:17 EDT
What is Antergos/Arch?
Comment 24 eagleton 2015-10-17 06:45:05 EDT
Antergos and Arch are distributions of Linux, just as Fedora. As with Fedora, they use mostly very new versions of software. That's why I suspect it will be fixed soon in Fedora as well.
Comment 25 antonio montagnani 2015-11-04 03:55:54 EST
same problem in F23
Comment 26 Hernan arce 2015-11-11 10:52:39 EST
same here Fedora 23 upgraded from 22 using dnf-system-upgrade
Comment 27 Steve 2015-12-22 05:53:36 EST
Still an issue for me on Fedora 23 (Lenovo Yoga 12 with an external Bluray writer)

I burnt some files to CD using K3B and then couldn't mount them afterwards.

I got the same error as comment 3 and mounting the drive manually as root worked as well (and the CD was read without problems on a Windows box afterwards).

Is there any further information you need to debug this?
Comment 28 antonio montagnani 2015-12-22 08:04:59 EST
nobody seems to be working on this bug: may the reason be that USB sticks are cheaper than DVD'S therefore not many people are still  using writers.
Anyway very annoying and not very professional to show a system that cannot show-up content of DVD's
Comment 29 Joachim Backes 2015-12-22 09:13:45 EST
(In reply to antonio montagnani from comment #28)
> nobody seems to be working on this bug: may the reason be that USB sticks
> are cheaper than DVD'S therefore not many people are still  using writers.
> Anyway very annoying and not very professional to show a system that cannot
> show-up content of DVD's

++1
Comment 30 javiertury 2015-12-31 13:20:29 EST
In fedora 23 an iso9660 CD causes the same behavior,

$ gvfs-mount -d /dev/sr0
No volume for device file /dev/sr0

$ sudo gvfs-mount -d /dev/sr0
No volume for device file /dev/sr0

However using the mount command directly works as antonio montagnani described.

This bug maybe related to this one in debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=747426
Comment 31 antonio montagnani 2015-12-31 18:43:57 EST
(In reply to javiertury from comment #30)
> In fedora 23 an iso9660 CD causes the same behavior,
> 
> $ gvfs-mount -d /dev/sr0
> No volume for device file /dev/sr0
> 
> $ sudo gvfs-mount -d /dev/sr0
> No volume for device file /dev/sr0
> 
> However using the mount command directly works as antonio montagnani
> described.
> 
> This bug maybe related to this one in debian
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=747426

I am not interested in other distribution bugs, but I find that in this case customer's respect is really poor. No reply since first report that is June 2015.Unless someone decided to drop support for CD writers...
Comment 32 matvanheerden 2016-01-01 07:43:45 EST
Same issue here! Come with Fedora since version 19, and have to now manually mount in 23? Seems that there is a Udev issue, but don't know how to correct it. Will be following closely.
Comment 33 Joachim Backes 2016-01-01 07:56:06 EST
Browsing a little bit in the "udisks" documentation, and probably its a problem of or in the polkit package.
Comment 34 Sylvia Sánchez 2016-01-25 11:10:33 EST
I'm using Fedora 23, Cinnamon Spin, with Plasma 5 installed.  Nor Cinnamon or KDE mount my CD or DVD.  Furthermore, if I want to mount them by hand it returns an "Impossible to mount" message. But the optical device and my CD and DVD work perfectly, in the same laptop I have a Windows 8 and there I can mount them and read them without problems.
My laptop is a Toshiba Satellite C655  (4GB RAM,500GB hard disk, dual core processor).
Comment 35 Robert 2016-03-17 04:03:09 EDT
The problem persists in Fedora 22. Does anyone know if it's also present in Rawhide?
Comment 36 Robert 2016-03-17 04:15:17 EDT
There's more information available here: https://ask.fedoraproject.org/en/question/74796/fedora-22-cd-rs-with-cdfsiso9660-fail-to-mount/

Reseting the SELinux context labels on all files did not solve the problem for me. Making SELinux permissive didn't work either. The only workaround that works is including the drive in fstab, but it totally ruins the user experience, I'm back to the 90's.
Comment 37 antonio montagnani 2016-03-18 05:34:16 EDT
Audio CD are properly mounted . The big issue is that nobody is taking care of this bug and users' experience is really poor (i.e. if you show your Fedora to a friend you have to say that CD's are non mounted, are we joking?)
Comment 38 Robert 2016-03-18 21:59:44 EDT
My CDs also fail to auto-mount in the latest Ubuntu. After some research I think the problem is located in udev and I have opened another bug report upstream: https://github.com/systemd/systemd/issues/2872
Comment 39 srakitnican 2016-03-28 10:10:12 EDT
Same issue here, Fedora 23...

[135093.827955] sr 4:0:0:0: [sr0] tag#25 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[135093.827962] sr 4:0:0:0: [sr0] tag#25 Sense Key : Illegal Request [current] 
[135093.827966] sr 4:0:0:0: [sr0] tag#25 Add. Sense: Illegal mode for this track
[135093.827971] sr 4:0:0:0: [sr0] tag#25 CDB: Read(10) 28 00 00 00 9a d0 00 00 02 00
[135093.827974] blk_update_request: I/O error, dev sr0, sector 158528
[135093.827977] Buffer I/O error on dev sr0, logical block 19816, async page read

After mounting with "mount /dev/sr0 /mnt" I get this

[135094.094862] ISO 9660 Extensions: Microsoft Joliet Level 3
[135094.116565] ISO 9660 Extensions: RRIP_1991A

After that, data is accessible under /mnt.

CD was made with command:

mkisofs -J -r -V CustomTitle -root Directory/ /path/to/Directory | wodim -v speed=8 dev=/dev/sr0 -
Comment 40 Garrett Mitchener 2016-04-05 16:56:19 EDT
I also see this on Fedora 23.

I put in a CD just now, and I think I saw Nautilus blink for a split second, as if it recognized the disk then changed its mind...

from dmesg:

[ 1410.177779] sr 1:0:0:0: [sr0] tag#16 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1410.177788] sr 1:0:0:0: [sr0] tag#16 Sense Key : Illegal Request [current] 
[ 1410.177794] sr 1:0:0:0: [sr0] tag#16 Add. Sense: Invalid field in parameter list
[ 1410.177799] sr 1:0:0:0: [sr0] tag#16 CDB: Read(10) 28 00 00 00 4b 36 00 00 02 00
[ 1410.177803] blk_update_request: I/O error, dev sr0, sector 77016
[ 1410.910011] sr 1:0:0:0: [sr0] tag#17 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1410.910020] sr 1:0:0:0: [sr0] tag#17 Sense Key : Illegal Request [current] 
[ 1410.910025] sr 1:0:0:0: [sr0] tag#17 Add. Sense: Invalid field in parameter list
[ 1410.910030] sr 1:0:0:0: [sr0] tag#17 CDB: Read(10) 28 00 00 00 4b 36 00 00 02 00
[ 1410.910034] blk_update_request: I/O error, dev sr0, sector 77016
[ 1410.910040] Buffer I/O error on dev sr0, logical block 9627, async page read
Comment 41 Joachim Backes 2016-04-06 06:41:47 EDT
Same in Fedora 24
Comment 42 Robert 2016-04-23 17:37:30 EDT
I finally found a workaround. It looks like the problem is not located in udev itself, but in one of it's dependencies: libblkid.

If I replace /usr/lib64/libblkid.so.1.1.0 from my Fedora 22 with the versions included in Fedora 21 or Fedora Rawhide, the CDs are automounted again.

The current package in Rawhide is libblkid-2.28-1.fc25.x86_64.rpm. I hope this doesn't mean we'll have to wait for Fedora 25 to have CD automount working again. At least the problem seems fixed upstream.
Comment 43 Richard Myers 2016-06-02 15:19:28 EDT
I still have this issue with Fedora 23, though I see that my libblkid version is 2.28, which Robert said worked on his machine (Rawhide version):

Name        : libblkid
Version     : 2.28
Release     : 1.fc23
Architecture: x86_64
Install Date: Sun 17 Apr 2016 04:16:41 PM PDT
Group       : Development/Libraries
Size        : 275832
License     : LGPLv2+
Signature   : RSA/SHA256, Wed 13 Apr 2016 08:52:19 AM PDT, Key ID 32474cf834ec9cba
Source RPM  : util-linux-2.28-1.fc23.src.rpm
Build Date  : Wed 13 Apr 2016 04:53:23 AM PDT
Build Host  : buildvm-25.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://en.wikipedia.org/wiki/Util-linux
Summary     : Block device ID library
Description :
This is block device identification library, part of util-linux.

Can someone at RedHat please did into this issue?  The typical error I get is:

[278845.313268] sr 5:0:0:0: [sr0] tag#0 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[278845.313278] sr 5:0:0:0: [sr0] tag#0 Sense Key : Illegal Request [current] 
[278845.313284] sr 5:0:0:0: [sr0] tag#0 Add. Sense: Invalid field in parameter list
[278845.313291] sr 5:0:0:0: [sr0] tag#0 CDB: Read(10) 28 00 00 02 b7 41 00 00 01 00 00 00
[278845.313296] blk_update_request: critical target error, dev sr0, sector 711940
[278845.313303] Buffer I/O error on dev sr0, logical block 177985, async page read

And I can mount the CD manually with:

sudo mount -rv /dev/sr0 /mnt/cd

Thanks!
Comment 44 Ondrej Holy 2016-06-13 02:31:47 EDT
So the bug is in libblkid, let's chage the component to util-linux.
Comment 45 Karel Zak 2016-06-13 04:45:23 EDT
Please, try (as root):

 # LIBMOUNT_DEBUG=all blkid -p -o udev /dev/sr0 &> log

and add the "log" file to the bugzilla. Thanks.
Comment 46 srakitnican 2016-06-13 05:58:34 EDT
The (In reply to Karel Zak from comment #45)
> Please, try (as root):
> 
>  # LIBMOUNT_DEBUG=all blkid -p -o udev /dev/sr0 &> log
> 
> and add the "log" file to the bugzilla. Thanks.

The log file produced is empty
Comment 47 Karel Zak 2016-06-13 06:11:44 EDT
Ah, sorry. Use LIBBLKID_DEBUG=all
Comment 48 srakitnican 2016-06-13 06:16 EDT
Created attachment 1167413 [details]
log
Comment 49 Fedora Update System 2016-06-13 07:12:43 EDT
util-linux-2.28-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-43c60b13d4
Comment 50 Karel Zak 2016-06-13 07:15:50 EDT
srakitnican, try update to util-linux-2.28-2.fc23 please.
Comment 51 Fedora Update System 2016-06-13 07:54:03 EDT
util-linux-2.28-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4c80727621
Comment 52 Joachim Backes 2016-06-13 08:10:23 EDT
util-linux-2.28-3.fc24 seems to solve for me BZ1234317.  At long last :-)

Now, inserted CD's or DVD's are automaticall mounted and there is a desktop icon shown by nautilus!
Comment 53 srakitnican 2016-06-13 10:59:35 EDT
This issue seems fixed, however there seems to be another one, not sure where is the problem exactly... When switching CDs by ejecting them with hardware dvd drive button nautilus reuses old CD mount and some data from CD appears to be missing. Maybe related to multitrack CD. When the CD is ejected from nautilus however, all seems to be fine.
Comment 54 Fedora Update System 2016-06-13 11:57:43 EDT
util-linux-2.28-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4c80727621
Comment 55 Joachim Backes 2016-06-13 12:36:35 EDT
(In reply to srakitnican from comment #53)
> This issue seems fixed, however there seems to be another one, not sure
> where is the problem exactly... When switching CDs by ejecting them with
> hardware dvd drive button nautilus reuses old CD mount and some data from CD
> appears to be missing. Maybe related to multitrack CD. When the CD is
> ejected from nautilus however, all seems to be fine.

Seeing this too. It seems that the event "ejecting the media by pressing the eject button" is not handled properly).

As workaround, you may use "sudo eject /dev/sr0" instead of pressing the eject button. This will unmount the media properly (if no process is sitting in the mounted directory).
Comment 56 Fedora Update System 2016-06-13 18:25:54 EDT
util-linux-2.28-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-43c60b13d4
Comment 57 Karel Zak 2016-06-14 04:23:04 EDT
Note that "eject button" is really not libblkid issue.

The "eject" event is handled by /usr/lib/udev/rules.d/60-cdrom_id.rules and /usr/lib/udev/cdrom_id --eject-media. If you don't like the current behaviour report it against systemd.

Not sure why we don't use eject(1) in this case, cdrom_id does not umount, and all the --eject-media implementation seem pretty basic.
Comment 58 srakitnican 2016-06-14 06:40:28 EDT
https://github.com/systemd/systemd/issues/3536
Comment 59 Fedora Update System 2016-06-15 19:25:06 EDT
util-linux-2.28-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 60 Fedora Update System 2016-06-18 14:32:35 EDT
util-linux-2.28-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 61 Sylvia Sánchez 2016-08-14 07:30:43 EDT
I can confirm this is fixed.
Currently using Workstation24 without issues.

Note You need to log in before you can comment on or make changes to this bug.