Bug 123434 - hang during ifdown on reboot
hang during ifdown on reboot
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 11:34 EDT by Alex Lyashkov
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 20:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from serial console. (6.18 KB, application/x-tar)
2004-05-18 12:48 EDT, Alex Lyashkov
no flags Details

  None (edit)
Description Alex Lyashkov 2004-05-18 11:34:49 EDT
Description of problem:
I started 2.4.21-4smp at UP maschine (it`s my bug..) and textbox been
deadlocked at reboot.

Version-Release number of selected component (if applicable):
2.4.21-4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
part of tasks trace.

kjournald     S 00000000  3776    14      1            58    10 (L-TLB)
Call Trace:   [<c0123464>] schedule [kernel] 0x2f4 (0xf669df3c)
[<c0123b62>] interruptible_sleep_on [kernel] 0x52 (0xf669df80)
[<f88134bc>] kjournald [jbd] 0x14c (0xf669dfb0)
[<f8813350>] commit_timeout [jbd] 0x0 (0xf669dfd4)
[<f8813370>] kjournald [jbd] 0x0 (0xf669dfe4)
[<c010958d>] kernel_thread_helper [kernel] 0x5 (0xf669dff0)
kjournald     S 00000000  3944  2441      1          2445    58 (L-TLB)
Call Trace:   [<c0123464>] schedule [kernel] 0x2f4 (0xf6611f3c)
[<c0123b62>] interruptible_sleep_on [kernel] 0x52 (0xf6611f80)
[<f88134bc>] kjournald [jbd] 0x14c (0xf6611fb0)
[<f8813350>] commit_timeout [jbd] 0x0 (0xf6611fd4)
[<f8813370>] kjournald [jbd] 0x0 (0xf6611fe4)
[<c010958d>] kernel_thread_helper [kernel] 0x5 (0xf6611ff0)

kjournald     S 00000000  3912  2445      1          3220  2441 (L-TLB)
Call Trace:   [<c0123464>] schedule [kernel] 0x2f4 (0xc1fb3f3c)
[<c0123b62>] interruptible_sleep_on [kernel] 0x52 (0xc1fb3f80)
[<f88134bc>] kjournald [jbd] 0x14c (0xc1fb3fb0)
[<f88175c0>] .rodata.str1.32 [jbd] 0x13e0 (0xc1fb3fb4)
[<f8813370>] kjournald [jbd] 0x0 (0xc1fb3fc4)
[<f8813350>] commit_timeout [jbd] 0x0 (0xc1fb3fd4)
[<f8813370>] kjournald [jbd] 0x0 (0xc1fb3fe4)
[<c010958d>] kernel_thread_helper [kernel] 0x5 (0xc1fb3ff0)
Comment 1 Rik van Riel 2004-05-18 12:09:33 EDT
Alex, can you reproduce this bug with the latest RHEL3 kernel ?
(2.4.21-14EL)
Comment 2 Alex Lyashkov 2004-05-18 12:17:25 EDT
I don`t know. -4smp is my "safemode" kernel, base kernel for this box
- freevps kernel, but if it need i recompile -15smp and try start/stop
box. 

Comment 3 Stephen Tweedie 2004-05-18 12:37:00 EDT
"S" state is the normal process state for a journal thread that has no
work to do and is sitting idle.  The processes would have to be in "D"
state for there to be any sign of a deadlock here.

We need better information to even begin to diagnose this.  Just what
exactly does "deadlocked at reboot" mean?  How far does the reboot
process get before stalling?  I assume it's not a complete lockup at
that point, because you can extract process trace info?
Comment 4 Alex Lyashkov 2004-05-18 12:48:00 EDT
Created attachment 100307 [details]
log from serial console.

This full log session recorded from serial console.
system lock after "reboot" command.
Comment 5 Stephen Tweedie 2004-05-18 14:00:29 EDT
Is the hang always at the "eth0: " line?
Comment 6 Alex Lyashkov 2004-05-18 14:32:39 EDT
2.4.21-4 always. -15 not tried.
Comment 7 Stephen Tweedie 2004-05-19 06:53:12 EDT
OK, so "ifdown" is hanging, and this has nothing to do with ext3. 
I'll update the subject line.

Also, we can't support home-built kernels, simply because we have no
idea of the configuration or patches that have been applied there. 
Please try to reproduce this on 2.4.21-15EL.
Comment 8 Alex Lyashkov 2004-05-19 07:54:24 EDT
you look to serial console log or not ? how i see - not.
it`s RH builded 2.4.21-4 kernel and it hanged.
well, i will found time for rebuild 2.4.21-15 and test...


Comment 9 Stephen Tweedie 2004-05-19 09:46:17 EDT
Yes I have, but I was looking at your own comment about recompiling
-15smp.  I'm not sure why you'd have to recompile in order to test
2.4.21-15.EL unless you're using your own home-built configuration.

Anyway, if the ifdown is continually in "R" state in this case, the
important thing is to find out what it's running at that point. 
alt-sysrq-t is not reliable for the current running process (because
it hunts through the stack based on the last recorded stack pointer,
not the _current_ stack pointer), so an alt-sysrq-p (or, if you're
using .15.EL, alt-sysrq-w to grab all CPUs on an SMP box) will help to
find out what is sticking.
Comment 10 Stephen Tweedie 2004-10-14 20:23:18 EDT
Please reopen this bug report if you are able to capture the requested
alt-sysrq-w/p.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.