Bug 1234673 - "openstack overcloud deploy" does not respect command-line parameters
Summary: "openstack overcloud deploy" does not respect command-line parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: Director
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-23 02:12 UTC by Dan Sneddon
Modified: 2015-08-05 13:55 UTC (History)
13 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-8.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, when using the 'openstack overcloud deploy' command, some of the command line parameters were not being used by the code. As a result, the user was unable to set these parameters. With this release, the parameters are now used and sent to the Orchestration service.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:55:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237372 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-06-23 02:12:28 UTC
Description of problem:
When running "openstack overcloud deploy", the command-line parameters are being ignored.

Version-Release number of selected component (if applicable):
Puddle 2015-06-22-1

How reproducible:
100%

Steps to Reproduce:
1. Install undercloud
2. "openstack overcloud deploy -e /home/stack/environments --use-tripleo-heat-templates --neutron-public-interface nic2 --neutron-network-type gre --neutron-tunnel-types gre --libvirt-type kvm --ntp-server clock.redhat.com --control-scale 1 --compute-scale 2 --plan-uuid 35380043-2860-4f11-a458-2b4485ed7b3d"
3.

Actual results:
All the command-line parameters are being ignored, including my environment directory, the neutron public interface, and the compute scale. None of that was respected.

Expected results:
The overcloud should deploy with 2 computes, with neutron public interface on nic2, with network isolation.

Additional info:

Comment 3 Dougal Matthews 2015-06-23 10:11:45 UTC
There are a few different components which cause this issue. 

`--use-tripleo-heat-templates` shouldn't be used with `--plan-uuid` - we shouldn't allow users to do that.

The parameters are, incorrectly not being passed to Heat when using t-h-t. We need to verify they are all being passed in the Tuskar case and the t-h-t case.

Comment 4 Dougal Matthews 2015-06-23 17:04:56 UTC
Midstream fix https://review.gerrithub.io/237372

Comment 5 Dougal Matthews 2015-06-23 19:53:35 UTC
Fix merged.

Comment 6 Dan Sneddon 2015-06-25 01:39:20 UTC
I tried this again today with the latest poodle (2015-06-24 last poodle), and the command line parameters are still not being respected.

Here's what I used:

openstack overcloud deploy -e /home/stack/network_environment.yaml --use-tripleo-heat-templates --neutron-public-interface nic2 --neutron-network-type gre --neutron-tunnel-types gre --libvirt-type kvm --ntp-server clock.redhat.com --control-scale 1 --compute-scale 2

The network_environment.yaml was ignored. The --compute-scale was ignored. I didn't check the other parameters to see if they were respected.

Is this because I'm using --use-tripleo-heat-templates?

Comment 7 Brad P. Crochet 2015-06-25 12:52:34 UTC
@Dan

I do not believe it is ignoring the network_environment.yaml. At least, not by the plugin. In my initial attempt to test, I had syntax errors in my network_environment.yaml, and it would not continue until they were fixed. To me, that is a clear indication that it is *not* being ignored.  This is with whatever puddle is available 06/25/15 at 8:30am EST.

Comment 13 Omri Hochman 2015-07-07 21:54:39 UTC
Verified python-rdomanager-oscplugin-0.0.8-18.el7ost.noarch .

Comment 15 errata-xmlrpc 2015-08-05 13:55:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.