Bug 1234766 - No handlers could be found for logger "pulp.server.db.connection" in satellite 6.0
Summary: No handlers could be found for logger "pulp.server.db.connection" in satellit...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-23 08:21 UTC by Komal
Modified: 2019-09-25 21:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:16:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Komal 2015-06-23 08:21:25 UTC
Description of problem:
While trying to sync a content after running : 

sudo -u apache pulp-manage-db  get this error:

No handlers could be found for logger "pulp.server.db.connection"
^CTraceback (most recent call last):
  File "/usr/bin/pulp-manage-db", line 9, in <module>
    load_entry_point('pulp-server==2.4.0', 'console_scripts', 'pulp-manage-db')()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 299, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2229, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.6/site-packages/pulp/server/db/manage.py", line 30, in <module>
    connection.initialize()
  File "/usr/lib/python2.6/site-packages/pulp/server/db/connection.py", line 71, in initialize
    time.sleep(next_delay)
KeyboardInterrupt

The error seems to be related to https://bugzilla.redhat.com/show_bug.cgi?id=1127846

The fix detailed in the bugzilla is pulp 2.6.0-0.2.beta. 

Version-Release number of selected component (if applicable):
Satellite 6.0

How reproducible:
Always

The reported issue as been tracked in bugzilla : https://bugzilla.redhat.com/show_bug.cgi?id=1127846

KCS : https://access.redhat.com/solutions/1344293

The package pulp-server-2.6.0.10-1.el6_6sat.noarch.rpm seems to be available in satellite 6.1

Can it be considered as a hotfix.

Regards,
Komal

Comment 1 RHEL Product and Program Management 2015-06-23 08:23:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Bryan Kearney 2016-01-04 14:16:02 UTC
Based on comment 5, I am moving this to POST for verification.

Comment 9 jcallaha 2016-04-07 18:23:09 UTC
Verified in Satellite 6.2 beta Snap 6 Compose 2.

Comment 12 errata-xmlrpc 2016-07-27 09:16:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.