Bug 1234936 - Configure -> Environments -> New Environment -> Name field "is alphanumeric and cannot contain spaces"
Summary: Configure -> Environments -> New Environment -> Name field "is alphanumeric a...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Puppet
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-23 14:21 UTC by Tristan hoar
Modified: 2017-08-01 19:57 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-01 19:57:39 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16414 None None None 2016-09-01 13:54 UTC

Description Tristan hoar 2015-06-23 14:21:36 UTC
Description of problem:
The error message is not accurate

Version-Release number of selected component (if applicable):
6.1 beta

How reproducible:
Always

Steps to Reproduce:
1. Go to Configure -> Environments -> New Environment
2. Enter an invalid name e.g Test Servers
3. 

Actual results:
Web UI reports "is alphanumeric and cannot contain spaces"

Expected results:
should say "is alphanumeric or underscore and cannot contain spaces"

Additional info:
Underscores are permitted (and used extensively by Satellite) buy adding this it makes it clearer that hyphens are not permitted

Comment 1 RHEL Product and Program Management 2015-06-23 14:22:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2016-07-08 20:45:44 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 5 Ondřej Pražák 2016-09-01 13:54:10 UTC
Created redmine issue http://projects.theforeman.org/issues/16414 from this bug

Comment 6 Bryan Kearney 2016-09-07 10:08:50 UTC
Upstream bug assigned to szadok@redhat.com

Comment 7 Bryan Kearney 2016-09-07 10:08:54 UTC
Upstream bug assigned to szadok@redhat.com

Comment 8 Bryan Kearney 2016-09-09 20:08:04 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16414 has been resolved.

Comment 9 Bryan Kearney 2017-08-01 19:57:39 UTC
The fix to this bug will be delivered with release 6.3 of Satellite.


Note You need to log in before you can comment on or make changes to this bug.