Bug 123494 - "with" message in firstboot not marked for translation
"with" message in firstboot not marked for translation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: StringChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 17:17 EDT by Christian Rose
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 14:45:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2004-05-18 17:17:31 EDT
Tested with Swedish.

In the firstboot "Display" screen, the're is an informative text
showing the monitor type and graphics adapter on the system. In my case:

"MAG DJ707 with Matrox Millennium G450"

The "with" is not translated. It's most likely not marked for
translation in the source.

The entire sentence should probably be marked for translation, e.g.

/* Translators: The first %s is the monitor make and model,
                the second %s is the graphics adapter make and model. */
g_printf (_("%s with %s"), monitor_name, adapter_name);

This is so that translators can alter the order of the arguments with
printf modifiers if the language requires a different order.
Comment 1 Brent Fox 2004-05-25 11:48:43 EDT
This string comes from system-config-display and the UI is just
plugged  into the firstboot parent window.  As far as I can tell, this
string is correctly marked for translation:

from xConfDialog.py:
   label.set_text(_("%s with %s")%(self.state.get_monitor_name(),
self.state.get_videocard_name()))

And it looks like the string is translated in sv.po:
msgid "%s with %s"
msgstr "%s med %s"

I don't have my test machines at the moment, so I can't try to
reproduce this myself.  I can't explain why the translation isn't
getting shown.
Comment 2 Brent Fox 2004-06-14 14:45:52 EDT
Ah, I see the problem now.  The message is translated in the po files
but I wasn't setting the text domain correctly in the python files. 
Should be fixed in cvs now.  1.0.15-2 will contain the fix once I
rebuild the package.
Comment 3 Christian Rose 2004-06-19 17:32:39 EDT
Thanks a bunch!

Note You need to log in before you can comment on or make changes to this bug.