Bug 1234946 - Allow multiple need info requests to be made in one transaction
Summary: Allow multiple need info requests to be made in one transaction
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: 5.0-RH8
Assignee: Jeff Fearn 🐞
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks: UI-Modernization
TreeView+ depends on / blocked
 
Reported: 2015-06-23 14:45 UTC by Laura Novich
Modified: 2019-11-11 00:18 UTC (History)
5 users (show)

Fixed In Version: 5.0.4-rh33
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-11 00:18:14 UTC


Attachments (Terms of Use)
suggestion (5.88 KB, image/png)
2015-06-23 15:12 UTC, Laura Novich
no flags Details

Description Laura Novich 2015-06-23 14:45:42 UTC
Description of problem:
Using the current model, it is impossible to tag multiple people with a need info request at the same time, forcing the requester to submit several need info requests in succession. This wastes valuable time. It would be better if the need info field allowed for multiple email addresses to be added separated by a comma or semicolon.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jiri Herrmann 2015-06-23 14:57:11 UTC
Another way to go about this might be to add a possibility to create another needinfo bar/pane - much like when creating filters in e-mail clients.

This would add the possibility to automatically select several people assigned to the erratum (for instance the reporter as well as the assignee) without having to copy or write out the precise addresses.

Comment 2 Laura Novich 2015-06-23 15:12:49 UTC
Created attachment 1042386 [details]
suggestion

Comment 3 Laura Novich 2015-06-23 15:13:33 UTC
Taking Jiri's suggestion as the solution, the result would look like the picture attached.

Comment 5 Jeff Fearn 🐞 2018-06-26 01:25:14 UTC
This bug has missed the BZ5 feature freeze and has been bumped to 5.x.

Comment 6 Meiying Li 2019-10-22 07:37:34 UTC
@Jeff When I try to add one needinfo use the traditional way to 'meli@redhat.com', and the new needinfor bar with 'qgong@redhat.com, meli@redhat.com'
then I really can add this:
Flags: needinfo?(meli@redhat.com) needinfo?(qgong@redhat.com) needinfo?(meli@redhat.com)   (same two needinfos)

Later, I login with my account meli@redhat.com, find there are two warning lins at the bottom of bug 1507324
I am providing the requested information for this bug (Will clear all needinfo requests).
I am providing the information requested of myself (Will clear your needinfo request). 

Different warnings with the similar meaning, could we make it as same one for one bug?
I would like to assign it back to you for further talking, thanks.

Comment 7 Jeff Fearn 🐞 2019-10-22 08:55:57 UTC
(In reply to Meiying Li from comment #6)
> @Jeff When I try to add one needinfo use the traditional way to
> 'meli@redhat.com', and the new needinfor bar with 'qgong@redhat.com,
> meli@redhat.com'
> then I really can add this:
> Flags: needinfo?(meli@redhat.com) needinfo?(qgong@redhat.com)
> needinfo?(meli@redhat.com)   (same two needinfos)

It's always been possible to flag someone for needinfo multiple timer. It's odd but it's expected behaviour.

> Later, I login with my account meli@redhat.com, find there are two warning
> lins at the bottom of bug 1507324
> I am providing the requested information for this bug (Will clear all
> needinfo requests).
> I am providing the information requested of myself (Will clear your needinfo
> request). 
> 
> Different warnings with the similar meaning, could we make it as same one
> for one bug?


It is legitimate to show both in some cases, and does no harm in this case, soI'd rather not increase the number of different UI experiences unless there is a good reason to do so.

> I would like to assign it back to you for further talking, thanks.

Please don't do this. If you want to ask questions just needinfo me and leave changing the status until the questions have been resolved.

Comment 8 Meiying Li 2019-10-23 07:36:12 UTC
(In reply to Jeff Fearn 🐞 from comment #7)
> Please don't do this. If you want to ask questions just needinfo me and
> leave changing the status until the questions have been resolved.
Thanks for quick reply. I won't change status next time.

As talked in Comment #7, QE will set this issue as verified because the implement meets our expectation till now.

Comment 10 Jeff Fearn 🐞 2019-11-11 00:18:14 UTC
This change is now live. If there are any issues, do not reopen this
bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.