Bug 123498 - Kernel crash/oops/panic on x86_64 install
Kernel crash/oops/panic on x86_64 install
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 17:23 EDT by Jeffrey W. Baker
Modified: 2015-01-04 17:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey W. Baker 2004-05-18 17:23:38 EDT
The kernel panics on FC2 install on x86_64.  The problem is the
already-reported crash with the top of the stack in pci_map_sg, which
can be found in the archives of discuss@x86-64.org.  I will reproduce
the stack trace here:

__out_of_line_bug
pci_map_sg
__ide_dma_read
ide_wait_stat
ide_do_request
__run_task_queue
__wait_on_page
file_read_actor
sys_read

The hardware is Rioworks Arima HDAMA with 2 Opteron 244 CPUs and 8GB
main memory, 2 Western Digital 120GB IDE hard drives attached to the
main board.

The crash occurs in the anaconda process, immediately after X starts
and the root image is already painted.  I have tried the text install,
noprobe, iommu=off, iommu=force, and other boot options but the crash
is always the same.
Comment 1 Warren Togami 2004-05-18 18:23:35 EDT
Please find thread names and maybe URL's to helpful posts that are
related to this issue.  That would help us to debug & fix the problem
faster.

Unfortunately it may be difficult for you to install without a working
kernel in Anaconda's disk...
Comment 2 Alan Cox 2004-05-21 20:05:06 EDT
For the iommu=off case you would also want to specify mem=2048M. What
IDE controller is on the HDAMA >
Comment 3 Jeffrey W. Baker 2004-05-21 20:25:06 EDT
The IDE controller is the one built into the AMD8111.  I hadn't
realized until I started tinkering with the initrd that FC2 is
installing from 2.4.22.  I think there's a ton of fixes in 2.6 that
were never backported to 2.4 for this platform.  Maybe it would be
better to install from 2.6 on x86-64?

I tried replacing the initrd kernel with a 2.6.6 built elsewhere, but
there's some proc thing missing and the install complains that I don't
have enough memory (0KB).
Comment 4 Jeffrey W. Baker 2004-05-21 20:29:12 EDT
There seems to be a bug in your bugzilla where the QA contact gets
removed automatically, and it also seems that I am not allowed to add
the QA Contact back in (there's no form field).  I'll add bbrock to
the CC instead.
Comment 5 Msquared 2004-05-25 07:28:18 EDT
Hopefully more information will help.  Here's the screen of stuff that
happened when I tried to install FC2:

EIP is at acpi_ps_parse_aml+0xb2/0x1a4
eax: 00000000  ebx: c147cc00  ecx: c02b38c9  edx: 00000d60
esi: c147cc00  edi: c147bf44  ebp: 00000007  esp: dffd5f60
ds: 007b  es: 007b  ss: 0068
Process swapper (pid: 1, threadinfo=dffd5000 task=dfd47630)
Stack: 00000000 00000000 c147cc00 dffe0284 00000001 c01aa473 dffe0144
dffe0144
       c037e634 00000000 c01aa492 dffe0144 c01a84bd dffe0144 00000000
00000000
       c01a852e 00000000 00000000 00000000 c01a85e2 c01ae62d 00000001
000fc0d0
Call Trace:
 [<c01aa473>] acpi_ns_one_complete_parse+0x6b/0x7b
 [<c01aa492>] acpi_ns_parse_table+0xf/0x29
 [<c01a84bd>] acpi_ns_load_table+0x6d/0x8f
 [<c01a852e>] acpi_ns_load_table_by_type+0x4f/0xea
 [<c01a85e2>] acpi_ns_load_namespace+0x19/0x34
 [<c01ae62d>] acpi_load_tables+0xd9/0x139
 [<c032ccc5>] acpi_bus_init+0x26/0x11b
 [<c032ce1c>] acpi_init+0x62/0xb4
 [<c0320659>] do_initcalls+0x49/0x97
 [<c010029e>] init+0x0/0xe2
 [<c01002bb>] init+0x1d/0xe2
 [<c01041d5>] kernel_thread_helper+0x5/0xb

Code: 82 78 10 00 75 0e 80 48 09 08 8b 83 ac 01 00 00 c6 40 1c 01
 <0>Kernel panic: Attempted to kill init!


My hardware is a Gigabyte GA-7VRXP with DVD-ROM, CDRW-burner, 80GBhd,
512MB RAM.

Mind you, this also happened on an older machine I tried it on, too. 
Very old, though, with AT-style KB connector.  :-)

... Msquared ...
Comment 6 Msquared 2004-05-25 09:44:20 EDT
I'm just re-reading the comments above mine, and it occurs to me that
we may be talking about different (but possibly related) bugs.

The dump I produced occurred immediately after the CD's linux kernel
was decompressed.  It did not wait as long as X startup before dying.
 This dump occurs irrespective of text or graphics install, and even
if I lower the RAM to 128M (machine has 512M), and even if I use
noprobe to try prevent hardware scanning.

Finally, the problem I've experienced occurred both on a recent model
Athlon (the Gigabyte board I mentioned), and on a rather old Pentium.
 In both cases, FC1 was installed with no problem.

I don't know if you want to open a new bug, or whatever, but I thought
you should know in case it was relevant.  :-)  I originally filed
additional info against this bug because it seemed relevant at the time.
Comment 7 Jeffrey W. Baker 2004-05-25 12:31:10 EDT
This bug is completely different symptoms and stack.  Please open a
different bug on it.
Comment 8 Dave Jones 2005-01-11 00:08:27 EST
did FC3 fare any better on this system ?
Comment 9 Dave Jones 2005-04-16 00:14:08 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.