Bug 1234999 - PUT /api/v2/domains/:id returns an incomplete set of attributes
Summary: PUT /api/v2/domains/:id returns an incomplete set of attributes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: alon
QA Contact: jcallaha
URL:
Whiteboard:
Depends On: 1216236
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-23 17:40 UTC by jaudet
Modified: 2019-09-25 21:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:52:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Output of foreman-debug from a Satellite 6.1.0 system running RHEL 7.1. (451.49 KB, application/x-xz)
2015-06-23 17:40 UTC, jaudet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jaudet 2015-06-23 17:40:53 UTC
Created attachment 1042458 [details]
Output of foreman-debug from a Satellite 6.1.0 system running RHEL 7.1.

Description of problem:
A domain has at least the following attributes:

* dns
* domain_parameters_attributes
* fullname
* id
* location
* name
* organization

When one updates a domain, the following attributes are returned:

* created_at
* dns_id
* fullname
* hostgroups_count
* hosts_count
* id
* name
* updated_at

The following attributes are missing from the response:

* domain_parameters_attributes
* location
* organization

Version-Release number of selected component (if applicable):
Satellite 6.1.0. Foreman-debug is attached.

How reproducible:
100%

Steps to Reproduce:
1. Issue HTTP PUT request to https://sat.example.com/api/v2/domains/:id
2. Capture the response. Examine the JSON payload and discover that several
   attributes are not mentioned.
3. There is no step three.

Actual results:
See "Description of problem" section.

Expected results:
See "Description of problem" section.

Additional info:

Comment 1 RHEL Program Management 2015-06-23 17:42:32 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 alon 2015-07-14 12:20:01 UTC
Fixed in http://projects.theforeman.org/issues/10356

Comment 4 Tomer Brisker 2016-04-12 12:48:05 UTC
This has been resolved in current 6.2 snaps, moving to ON_QA for verification.

Comment 5 jcallaha 2016-05-25 17:26:01 UTC
Verified in Satellite 6.2 Beta Snap 12.

{
  "fullname": null,
  "dns_id": null,
  "created_at": "2016-05-19 14:58:38 UTC",
  "updated_at": "2016-05-19 14:58:38 UTC",
  "id": 1,
  "name": "rhq.lab.eng.bos.redhat.com",
  "subnets": [],
  "parameters": [],
  "interfaces": [
    {
      "id": 1,
      "name": "rhsm-qe-1.rhq.lab.eng.bos.redhat.com",
      "ip": "10.16.4.111",
      "mac": "40:f2:e9:69:9c:98",
      "identifier": "enp7s0",
      "primary": true,
      "provision": true,
      "type": "interface"
    }
  ],
  "locations": [],
  "organizations": []
}

Comment 7 errata-xmlrpc 2016-07-27 08:52:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.