Bug 1235024 - [REGRESSION] konsole copies unwanted text to clipboard
Summary: [REGRESSION] konsole copies unwanted text to clipboard
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: konsole5
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-23 19:14 UTC by Jaromír Cápík
Modified: 2016-02-01 02:01 UTC (History)
3 users (show)

Fixed In Version: 15.04.3-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-25 16:06:34 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 343726 0 None None None Never

Description Jaromír Cápík 2015-06-23 19:14:11 UTC
Description of problem:
Hello. After upgrading from F21 to F22 I hit a problem with copy&paste operation when copying text from konsole and pasting to pidgin. When I copy 'mytext' from console and paste to pidgin, the '   Konsole output     mytext' is pasted. It apparently doesn't affect all applications as mousepad accepts the clipboard data without problems.

The problem is being discussed in the upstream tracker:
  https://bugs.kde.org/show_bug.cgi?id=343726

Version-Release number of selected component (if applicable):
konsole5-15.04.0-1.fc22
pidgin-2.10.11-12.fc22

How reproducible:
always

Steps to Reproduce:
1. Select a text with mouse, then copy to clipboard via mouse menu or CTRL+SHIFT+C
2. Paste to Pidgin chat window


Actual results:
The pasted text is prefixed with '   Konsole output     '

Expected results:
The pasted text is equal to the copied data

Comment 1 Fedora Update System 2015-08-15 20:21:22 UTC
konsole5-15.04.3-2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/konsole5-15.04.3-2.fc23

Comment 2 Fedora Update System 2015-08-15 20:21:59 UTC
konsole5-15.04.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/konsole5-15.04.3-2.fc22

Comment 3 Jaromír Cápík 2015-08-17 15:36:12 UTC
It's better, but it still appends newline at the end.

Comment 4 Fedora Update System 2015-08-18 05:14:43 UTC
Package konsole5-15.04.3-2.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing konsole5-15.04.3-2.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13544/konsole5-15.04.3-2.fc23
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-08-25 16:06:33 UTC
konsole5-15.04.3-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.