Bug 1235049 - PUT /api/v2/hosts/:id returns an incomplete set of attributes
Summary: PUT /api/v2/hosts/:id returns an incomplete set of attributes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: alon
QA Contact: jcallaha
URL:
Whiteboard:
Depends On: 1216236
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-23 21:00 UTC by jaudet
Modified: 2019-09-25 21:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:53:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Output of foreman-debug from a Satellite 6.1.0 system running RHEL 7.1. (451.49 KB, application/x-xz)
2015-06-23 21:00 UTC, jaudet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jaudet 2015-06-23 21:00:38 UTC
Created attachment 1042517 [details]
Output of foreman-debug from a Satellite 6.1.0 system running RHEL 7.1.

Description of problem:
A host has at least the following attributes:

* architecture
* build
* capabilities
* compute_profile
* compute_resource
* domain
* enabled
* environment
* host_parameters_attributes
* hostgroup
* id
* image
* ip
* location
* mac
* managed
* medium
* model
* name
* operatingsystem
* organization
* owner
* owner_type
* provision_method
* ptable
* puppet_class
* puppet_proxy
* realm
* root_pass
* subnet

However, the following attributes are returned when a host is updated:

* architecture_id
* build
* certname
* comment
* compute_profile_id
* compute_resource_id
* content_source_id
* content_view_id
* created_at
* discovery_rule_id
* disk
* domain_id
* enabled
* environment_id
* grub_pass
* hostgroup_id
* id
* image_file
* image_id
* installed_at
* ip
* last_compile
* last_freshcheck
* last_report
* lifecycle_environment_id
* location_id
* mac
* managed
* medium_id
* model_id
* name
* operatingsystem_id
* organization_id
* otp
* owner_id
* owner_type
* primary_interface
* provision_method
* ptable_id
* puppet_ca_proxy_id
* puppet_proxy_id
* puppet_status
* realm_id
* root_pass
* serial
* source_file_id
* subnet_id
* updated_at
* use_image
* uuid

The following attributes are not mentioned in the response:

* capabilities
* host_parameters_attributes
* puppet_class

Version-Release number of selected component (if applicable):
Satellite 6.1.0. Foreman-debug is attached.

How reproducible:
100%

Steps to Reproduce:
1. Issue HTTP PUT request to https://sat.example.com/api/v2/hosts/:id
2. Capture the response. Examine the JSON payload and discover that several
   attributes are not mentioned.
3.

Actual results:
See "Description of problem" section.

Expected results:
See "Description of problem" section.

Additional info:

Comment 1 RHEL Program Management 2015-06-23 21:02:33 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 alon 2015-07-14 12:20:47 UTC
Fixed in http://projects.theforeman.org/issues/10356

Comment 4 Tomer Brisker 2016-04-12 12:49:35 UTC
This has been resolved in current 6.2 snaps, moving to ON_QA for verification.

Comment 5 jcallaha 2016-04-12 19:19:10 UTC
Verified in Satellite 6.2 snap 7 compose 1. 

capabilities included.
parameters is now in place of host_parameters_attributes
puppetclasses is now in place of puppet_class

Comment 7 errata-xmlrpc 2016-07-27 08:53:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.