Bug 1235108 - [virtio-win][vioscsi]VIOSCSI driver is not signed by redhat certification on win200832/64 platform
Summary: [virtio-win][vioscsi]VIOSCSI driver is not signed by redhat certification on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-06-24 02:36 UTC by Min Deng
Modified: 2016-11-04 08:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:47:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unsigned (55.46 KB, image/png)
2015-06-24 02:37 UTC, Min Deng
no flags Details
logs (5.59 MB, application/zip)
2015-06-25 05:11 UTC, Min Deng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Min Deng 2015-06-24 02:36:59 UTC
Description of problem:
There is a job named "Embedded Signature Verification" on DTM.One Signature driver is a must if let it pass.
Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-105
qemu-kvm-rhev-2.3.0-2.el7.x86_64
kernel-3.10.0-267.el7.x86_64

How reproducible:
2 times

Steps to Reproduce:
1.boot up guest with following CLI
   /usr/libexec/qemu-kvm -name 105SCS200864ZFR -enable-kvm -m 4G -smp 4 -uuid 1fc34cd1-271c-4a65-b44b-aa87c776c8cd -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/105SCS200864ZFR,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x9 -drive file=105SCS200864ZFR,if=none,id=drive-scsi-disk1,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi1.0,drive=drive-scsi-disk1,id=scsi-disk1,bootindex=1 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=105SCS200864ZFR.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:6c:2a:e5:cb,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7 -drive file=105SCS200864ZFR_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0

2.submit the job named by Embedded Signature Verification
3.Login guest and run "verifier.exe"
Actual results:
The job failed with error message 


Expected results:
The job could pass

Additional info:
Error message
Start Test 6/18/2015 11:25:52.703 AM vioscsi 
Error 6/18/2015 11:26:08.703 AM The Driver C:\Windows\system32\DRIVERS\vioscsi.sys is not a signed driver 
File:    Line: 0 
Error Type:    
Error Code:   0x0 
Error Text:   Error 0x00000000 
End Test 6/18/2015 11:26:08.703 AM vioscsi 
Result:   Fail

Comment 1 Min Deng 2015-06-24 02:37:50 UTC
Created attachment 1042583 [details]
Unsigned

Comment 2 Min Deng 2015-06-24 02:46:29 UTC
Manually checking it from Device Manager,it also shows "Not  Digitally Signed"

Comment 4 Vadim Rozenfeld 2015-06-24 11:20:50 UTC
Hi Min,
Could you please upload the relevant hckx file for the future investigation?

Thanks,
Vadim

Comment 5 Min Deng 2015-06-25 05:10:47 UTC
(In reply to Vadim Rozenfeld from comment #4)
> Hi Min,
> Could you please upload the relevant hckx file for the future investigation?
> 
> Thanks,
> Vadim

Hi Vadim,
   we do not test win2008-32/64 on HCK but DTM so we have not relevant hck log for them.Please have a look on those logs from DTM.Thanks !

Best Regards
Min

Comment 6 Min Deng 2015-06-25 05:11:50 UTC
Created attachment 1042939 [details]
logs

Comment 8 Yu Wang 2016-07-08 07:34:40 UTC
Re-test this job w/ virtio-1.0 device on virtio-win-prewhql-120, this job passed on win2008-32/64.

Above all, this bug has been fixed on virtio-win-prewhql-120.


Thanks
Yu Wang

Comment 9 Yu Wang 2016-07-08 07:35:26 UTC
according to comment#8, change status to verified.

Comment 11 errata-xmlrpc 2016-11-04 08:47:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.