Bug 1235195 - quota: marker accounting miscalculated when renaming a file on with write is in progress
Summary: quota: marker accounting miscalculated when renaming a file on with write is ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1235182
Blocks: qe_tracker_everglades 1202842 1223636 1235990
TreeView+ depends on / blocked
 
Reported: 2015-06-24 09:21 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:15 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1235182
: 1235990 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:15:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-25 09:34:55 UTC
REVIEW: http://review.gluster.org/11403 (quota: marker accounting goes bad with rename while writing a file) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijaikumar Mallikarjuna 2015-06-26 09:52:38 UTC
Patch merged: http://review.gluster.org/#/c/11403/

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:11:46 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:15:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.