Bug 1235203 - tiering: tier status shows as " progressing " but there is no rebalance daemon running
Summary: tiering: tier status shows as " progressing " but there is no rebalance daemo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.1
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1227803
Blocks: 1229275 1260923
TreeView+ depends on / blocked
 
Reported: 2015-06-24 10:01 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1227803
Environment:
Last Closed: 2015-07-30 09:51:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-06-24 10:01:34 UTC
+++ This bug was initially created as a clone of Bug #1227803 +++

Description of problem:

tier status shows as progressing but there is no rebalance daemon running.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create and start tier daemon
2.kill all the bricks in a replica set
3.check tier status and running status of tier daemon

Actual results:

tier daemon died, but status shows still running

Expected results:

status should be failed.

Additional info:

--- Additional comment from Anand Avati on 2015-06-03 10:15:57 EDT ---

REVIEW: http://review.gluster.org/11068 (tiering/rebalance: tier daemon stopped with out updating status) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-04 04:22:39 EDT ---

REVIEW: http://review.gluster.org/11068 (tiering/rebalance: tier daemon stopped with out updating status) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-10 01:10:36 EDT ---

REVIEW: http://review.gluster.org/11068 (tiering/rebalance: tier daemon stopped with out updating status) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-11 03:09:00 EDT ---

REVIEW: http://review.gluster.org/11068 (tiering/rebalance: tier daemon stopped with out updating status) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 00:40:23 EDT ---

REVIEW: http://review.gluster.org/11068 (tiering/rebalance: tier daemon stopped with out updating status) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 05:46:03 EDT ---

REVIEW: http://review.gluster.org/11068 (tiering/rebalance: tier daemon stopped with out updating status) posted (#7) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 1 Anand Avati 2015-06-26 05:05:19 UTC
REVIEW: http://review.gluster.org/11414 (tiering/rebalance: tier daemon stopped with out updating status) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-06-26 15:36:49 UTC
COMMIT: http://review.gluster.org/11414 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 41eb069d553620f702300fc987706cf00c712b9e
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Jun 3 17:10:22 2015 +0530

    tiering/rebalance: tier daemon stopped with out updating status
    
    When a subvol goes down, tier daemon stopped immediately, and
    the status shows as "Progressing".
    
    With this change, with respect to tier xlator, when a subvol
    goes offline it will update the status as failed.
    
    Back port of:
    >Change-Id: I9f722ed0d35cda8c7fc1a7e75af52222e2d0fdb7
    >BUG: 1227803
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/11068
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    (cherry picked from commit d3714f252d91f4d1d5df05c4dcc8bc7c2ee75326)
    
    
    Change-Id: I268b7e2631779d15db5d9aec495dfd00ded94c5c
    BUG: 1235203
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11414
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Kaushal 2015-07-30 09:51:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.