Bug 1235238 - An error message pops up if delete the windows guest in installation procedure
Summary: An error message pops up if delete the windows guest in installation procedure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-24 11:18 UTC by Xiaodai Wang
Modified: 2016-11-04 01:57 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.4.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:57:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description Xiaodai Wang 2015-06-24 11:18:44 UTC
Description of problem:
An error message pops up if delete the windows guest in installation procedure.

Version-Release number of selected component (if applicable):
virt-manager-1.2.1-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Launch virt-manager: #virt-manager.
2. Click New button and choose "Local install media(ISO image or CDROM)". Click Forward, choose a windows iso file.
3. Follow the tips to install the guest.
4. when the installation begins check the image file.
# ls /var/lib/libvirt/images/win7.qcow2 
/var/lib/libvirt/images/win7.qcow2
5. Right click the guest, click Delete, Check "Delete associated storage files", Check the image file "/var/lib/libvirt/images/win7.qcow2" and click Delete.


Actual results:
1. An error message box pops up.
Error continue install: Cannot access storage file '/var/lib/libvirt/images/win7.qcow2'(as uid:107, gid:107):  No such file or directory

2. Check the image file and it has been deleted.
# ls /var/lib/libvirt/images/win7.qcow2 
ls: cannot access /var/lib/libvirt/images/win7.qcow2: No such file or directory

3. The win7 guest still exists and is not deleted.
# virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     win7                           shut off


Expected results:
The guest should be deleted successfully and no error pops up.

Additional info:
1. This doesn't occur with rhel guest.
2. This doesn't occur if deleting a well-installed windows guest.

Comment 3 Cole Robinson 2015-11-22 01:31:43 UTC
I can't reproduce upstream, but there have been a few commits since the last release related to issues similar to this, so it's probably fixed.

Comment 4 Pavel Hrdina 2016-05-13 17:40:48 UTC
Upstream commit:

commit f628c3e266c4e4326bf844e774ad31b96e97d645
Author: Pavel Hrdina <phrdina>
Date:   Fri May 13 17:28:03 2016 +0200

    create: skip continue-install restart if user destroys VM
    
    Commit 159e4af1 fixed a case where VM was started if user destroyed VM
    while installing it.  This moves the code before we check whether we
    need to restart the VM in order to continue in installation (windows
    requires that).

Comment 6 XiaoyunHu 2016-06-23 03:24:43 UTC
I can reproduce this bug with package:
virt-manager-1.3.2-1.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch

Steps:
1. Launch virt-manager: #virt-manager.
2. Click New button and choose "Local install media(ISO image or CDROM)". Click Forward, choose a windows iso file.
3. Follow the tips to install the guest.
4. Right click the guest, click Delete, Check "Delete associated storage files", Check the image file "/var/lib/libvirt/images/win7.qcow2" and click Delete.
5. Check the image file after deleting.
#ls /var/lib/libvirt/images/win7.qcow2

Results:
After step4, the guest can be deleted successfully without error.
After step5, the image file does not exist.
#ls /var/lib/libvirt/images/win7.qcow2
ls: cannot access /var/lib/libvirt/images/win7.qcow2: No such file or directory

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 8 errata-xmlrpc 2016-11-04 01:57:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.