Bug 1235246 - Missing trusted.ec.config xattr for files after heal process
Summary: Missing trusted.ec.config xattr for files after heal process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ashish Pandey
QA Contact:
URL:
Whiteboard:
Depends On: 1235244
Blocks: 1235629
TreeView+ depends on / blocked
 
Reported: 2015-06-24 11:51 UTC by Ashish Pandey
Modified: 2016-06-16 13:16 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1235244
: 1235629 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:16:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-25 11:10:57 UTC
REVIEW: http://review.gluster.org/11407 ( EC : While Healing a file, set the config xattr) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 2 Anand Avati 2015-06-26 04:59:18 UTC
REVIEW: http://review.gluster.org/11407 ( EC : While Healing a file, set the config xattr) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 3 Anand Avati 2015-06-26 05:14:12 UTC
REVIEW: http://review.gluster.org/11415 ( EC : While Healing a file, set the config xattr) posted (#1) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)

Comment 4 Anand Avati 2015-06-26 07:12:08 UTC
REVIEW: http://review.gluster.org/11407 ( EC : While Healing a file, set the config xattr) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Anand Avati 2015-06-26 15:28:55 UTC
COMMIT: http://review.gluster.org/11407 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 6d3b289f8b9b30bca390e72b256aa161e3f65eb5
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Thu Jun 25 16:30:40 2015 +0530

     EC : While Healing a file, set the config xattr
    
     Problem : trusted.ec.config attr was missing for the healed file
    
     Solution: Writing trusted.ec.config while healing a file.
    
    Change-Id: I340dd45ff8ab5bc1cd6e9b0cd2b2ded236e5acf0
    BUG: 1235246
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/11407
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 6 Mike McCune 2016-03-28 22:16:42 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Niels de Vos 2016-06-16 13:16:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.