Bug 1235285 - Cannot change Deployment Role
Summary: Cannot change Deployment Role
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: Jiri Tomasek
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-24 13:14 UTC by Dariusz Smigiel
Modified: 2015-08-05 13:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:55:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (112.69 KB, image/png)
2015-07-05 18:02 UTC, Ola Pavlenko
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dariusz Smigiel 2015-06-24 13:14:56 UTC
Description of problem:
Undercloud created 5 roles: "Compute", "Ceph-Storage", "Swift-Storage", "Cinder-Storage", "Controller". Every time, when User tries to edit anyone, he receives an ERROR popup and logs with info:
[Wed Jun 24 13:09:39.688581 2015] [:error] [pid 110080] ERROR:tuskar_ui.api.tuskar:Couldn't obtain image with id overcloud-compute

Version: OSP7 beta2, OSP Director beta1

How reproducible: All the time

Steps to Reproduce:
1. Build undercloud
2. Login to OSP Dashboard
3. Enter Infrastructure/Deployment Roles tab.
4. By default, there is no action button visible.
5. Link plan with role via CLI, by: tuskar plan-add-role -r <role_uuid> <plan_uuid>
6. Button is now visible. Try to click it and edit it.

Comment 3 Jiri Tomasek 2015-06-24 14:20:31 UTC
Hmm, this seems like this is run on quite old codebase, because the instack-undercloud installation now takes care of adding roles to plan and overcloud-compute image is not existent any more and afaik the image names have been updated in tuskar-ui code.

Comment 4 Mike Burns 2015-06-24 15:54:53 UTC
This was the initial beta from a few weeks ago.  If you can find a similar bug, we can close as a duplicate, or we can mark this testonly and hand it to QE

Comment 7 Dariusz Smigiel 2015-06-25 05:13:23 UTC
@Jiri, I see only beta2 in Partners FTP channel, so cannot use any other version. And instack-undercloud by default doesn't create it for me. Maybe it's the same reason, as Mike mentioned: very early beta.

@Mike, beta2 is dated on 04.06 so I'm OK with marking bugs as duplicate or testonly. At least I know it works, or will be working. Pity, it doesn't work right now :(

Comment 8 Ola Pavlenko 2015-07-05 18:02:33 UTC
Created attachment 1046310 [details]
screenshot

all roles are being added to the plan during undercloud installation.
action button is available . clicking on it opens  the "Edit role" window. 
see attachment.

Comment 9 Dariusz Smigiel 2015-07-06 05:46:16 UTC
Can confirm it. Works for me with RC2, Director Beta2

Comment 11 errata-xmlrpc 2015-08-05 13:55:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.